net/nagios-plugin-ldap: fix build problem
Fix build problem of nagios-plugin-ldap using --with-ldap option of configure. This is minimum change to build fix for nagios-plugin-ldap.
This commit is contained in:
parent
6e1d9540d8
commit
b1476e1a77
4 changed files with 8 additions and 14 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.18 2017/07/04 19:48:52 jperkin Exp $
|
||||
# $NetBSD: Makefile,v 1.19 2017/11/08 03:20:49 taca Exp $
|
||||
#
|
||||
|
||||
PKGNAME= nagios-plugin-ldap-${PLUGINSVERSION}
|
||||
|
@ -14,6 +14,8 @@ DEPENDS+= nagios-plugins-${PLUGINSVERSION}{,nb[0-9]*}:../../net/nagios-plugins
|
|||
|
||||
BINARY_TARGET= check_ldap
|
||||
|
||||
CONFIGURE_ARGS+= --with-ldap=yes
|
||||
|
||||
.include "../../net/nagios-plugins/Makefile.plugin"
|
||||
.include "../../databases/openldap-client/buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile.common,v 1.14 2017/09/10 14:11:30 joerg Exp $
|
||||
# $NetBSD: Makefile.common,v 1.15 2017/11/08 03:20:48 taca Exp $
|
||||
#
|
||||
# used by net/nagios-plugin-ldap/Makefile
|
||||
# used by net/nagios-plugin-mysql/Makefile
|
||||
|
@ -23,5 +23,6 @@ CONFIGURE_ARGS.DragonFly+= fu_cv_sys_stat_statvfs=no
|
|||
CONFIGURE_ARGS+= --with-nagios-user=${NAGIOS_USER:Q}
|
||||
CONFIGURE_ARGS+= --with-nagios-group=${NAGIOS_GROUP:Q}
|
||||
CONFIGURE_ARGS+= --datarootdir=${PREFIX}/share/nagios
|
||||
CONFIGURE_ARGS+= --with-ldap=no
|
||||
|
||||
CONFIGURE_ENV+= MACHINE_ARCH=${MACHINE_ARCH}
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.22 2017/09/09 22:47:35 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.23 2017/11/08 03:20:48 taca Exp $
|
||||
|
||||
SHA1 (nagios-plugins-2.2.1.tar.gz) = 0d3fc8876343a906f0dcc2c00850e4ad956a150a
|
||||
RMD160 (nagios-plugins-2.2.1.tar.gz) = 39c364ac08854a1829d47562d4add1ae58a49334
|
||||
|
@ -8,7 +8,7 @@ SHA1 (patch-ad) = cad52f9d8c5a6b53a1b512238df1590c0fa2177d
|
|||
SHA1 (patch-af) = 12ea1194eee95ea15ecc6d7daedd10eb9541ee6e
|
||||
SHA1 (patch-ah) = 99b5eb4896262f5aa1de60e9f42c395a59794a6b
|
||||
SHA1 (patch-an) = a6adf179db754f98b2da118a8c1101edda026fbc
|
||||
SHA1 (patch-configure) = d418b81f06e22b769cd187a77f45f0add605698e
|
||||
SHA1 (patch-configure) = 8a805fd88735b7b1c9cb96a974a1e6216ff23d2e
|
||||
SHA1 (patch-gl_gettext.h) = 37d14b4472f678bd84c13183e0fb263cd17f6ac5
|
||||
SHA1 (patch-plugins-root_Makefile.in) = 46e8968df375ca35d453e36c277d4052f125897b
|
||||
SHA1 (patch-plugins-scripts_check__breeze.pl) = 57ffda78989fd0d0c0fa26c74b7f53bd083dab4f
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-configure,v 1.3 2017/07/04 19:45:18 jperkin Exp $
|
||||
$NetBSD: patch-configure,v 1.4 2017/11/08 03:20:48 taca Exp $
|
||||
|
||||
Disable all the plugins which are installed by the nagios-plugin-* packages.
|
||||
|
||||
|
@ -13,15 +13,6 @@ Disable all the plugins which are installed by the nagios-plugin-* packages.
|
|||
EXTRAS="$EXTRAS check_radius\$(EXEEXT)"
|
||||
RADIUSLIBS="-lradiusclient"
|
||||
|
||||
@@ -17518,7 +17518,7 @@ _ACEOF
|
||||
|
||||
fi
|
||||
|
||||
- if test "$ac_cv_lib_ldap_main" = "yes"; then
|
||||
+ if false; then
|
||||
LDAPLIBS="-lldap -llber"\
|
||||
LDAPINCLUDE="-I/usr/include/ldap"
|
||||
|
||||
@@ -18947,6 +18947,9 @@ cat confdefs.h >>conftest.$ac_ext
|
||||
cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
|
|
Loading…
Reference in a new issue