Changes 9.15:

Ghostscript now supports the PDF security handler revision 6.

The pdfwrite and ps2write (and related) devices can now be forced to "flatten" glyphs into "basic" marking operations (rather than writing fonts to the output), by giving the -dNoOutputFonts command line option (defaults to "false")

PostScript programs can now use get_params or get_param to determine if a page contains color markings by reading the pageneutralcolor state from the device (so whether the page is "color" or "mono").

Note that this is only accurate when in clist mode, so -dMaxBitmap=0 and -dGrayDetection=true should both be used.

The pdfwrite device now supports Link annotations with GoTo and GoToR actions

The pdfwrite device now supports BMC/BDC/EMC pdfmarks

Regarding the new color management for the pdfwrite device introduced in the previous release, the proscription on using the new color management when producing PDF/A-1 compliant files is now lifted.

To reiterate, also, with the new color management implementation, using the UseCIEColor option is strongly discouraged.

For further information on the new pdfwrite color management, see: Color Conversion and Management

Plus the usual round of bug fixes, compatibility changes, and incremental improvement
This commit is contained in:
adam 2014-10-01 09:04:32 +00:00
parent d72afedf87
commit b14ba352bc
5 changed files with 12 additions and 29 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.11 2014/06/18 09:28:17 wiz Exp $
# $NetBSD: Makefile,v 1.12 2014/10/01 09:04:32 adam Exp $
DISTNAME= ghostscript-${GS_VERSION}
PKGNAME= ${DISTNAME:S/ghostscript/ghostscript-agpl/}
PKGREVISION= 2
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=ghostscript/} \
http://downloads.ghostscript.com/public/

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile.common,v 1.4 2014/04/04 08:48:43 adam Exp $
# $NetBSD: Makefile.common,v 1.5 2014/10/01 09:04:32 adam Exp $
# used by print/ghostscript-agpl/Makefile
# used by fonts/ghostscript-cidfonts/Makefile
# used by fonts/ghostscript-cidfonts-ryumin/Makefile
GS_VERSION= 9.14
GS_VERSION= 9.15

View file

@ -1,12 +1,11 @@
$NetBSD: distinfo,v 1.4 2014/04/04 08:48:43 adam Exp $
$NetBSD: distinfo,v 1.5 2014/10/01 09:04:32 adam Exp $
SHA1 (ghostscript-9.14.tar.bz2) = eab1c9e9850d8aedf02d16f3f7f8198ad9384068
RMD160 (ghostscript-9.14.tar.bz2) = 4f3aad17f271b17bd890ac63af56c75e42e10945
Size (ghostscript-9.14.tar.bz2) = 31080058 bytes
SHA1 (ghostscript-9.15.tar.bz2) = 19f01538d33b9623bc6653d96ea4ec891f14a9d3
RMD160 (ghostscript-9.15.tar.bz2) = 7450cccb0d31430e7aadcddacd63d807c71fefb1
Size (ghostscript-9.15.tar.bz2) = 28826065 bytes
SHA1 (patch-af) = 3dd65dbd9611c00d45997c86d16eada37511dca5
SHA1 (patch-ah) = db74a482e22771414f223a97dd71df5215553d85
SHA1 (patch-ai) = e83a732559094ea8b683a171219388d5087c816f
SHA1 (patch-al) = b4d06da288a608d65cdb014b0f2384406089afe3
SHA1 (patch-base_gserrors_h) = ce75cfb7528871842a3bd35e18a6d91c89823909
SHA1 (patch-devices_devs.mak) = 574c50c1dcb4136a6f150bcfdebb9c7ee62c0ef0
SHA1 (patch-openjpeg_libopenjpeg_opj_malloc_h) = f279a31ed796e73f6dc701fe63c16fa5b120f3f6
SHA1 (patch-openjpeg_libopenjpeg_opj_malloc_h) = bf7e47c77e6960df473d3bf97dfa78f207a14a01

View file

@ -1,15 +0,0 @@
$NetBSD: patch-devices_devs.mak,v 1.1 2014/04/04 08:48:43 adam Exp $
Don't explicitly depend on zlib.h header file.
--- devices/devs.mak.orig 2014-04-03 16:42:54.000000000 +0000
+++ devices/devs.mak
@@ -1597,7 +1597,7 @@ $(DD)pngalpha.dev : $(DEVS_MAK) $(libpng
fpng_=$(DEVOBJ)gdevfpng.$(OBJ) $(DEVOBJ)gdevpccm.$(OBJ)
$(DEVOBJ)gdevfpng.$(OBJ) : $(DEVSRC)gdevfpng.c\
- $(gdevprn_h) $(gdevpccm_h) $(gscdefs_h) $(zlib_h)
+ $(gdevprn_h) $(gdevpccm_h) $(gscdefs_h)
$(CC_) $(I_)$(DEVI_) $(II)$(PI_)$(_I) $(PCF_) $(GLF_) $(DEVO_)gdevfpng.$(OBJ) $(C_) $(DEVSRC)gdevfpng.c
$(DD)fpng.dev : $(DEVS_MAK) $(fpng_) $(GLD)page.dev $(GDEV)

View file

@ -1,10 +1,10 @@
$NetBSD: patch-openjpeg_libopenjpeg_opj_malloc_h,v 1.2 2014/04/04 08:48:43 adam Exp $
$NetBSD: patch-openjpeg_libopenjpeg_opj_malloc_h,v 1.3 2014/10/01 09:04:32 adam Exp $
Work around undefined 'memalign' issue.
--- openjpeg/libopenjpeg/opj_malloc.h.orig 2014-03-26 12:53:47.000000000 +0000
+++ openjpeg/libopenjpeg/opj_malloc.h
@@ -88,7 +88,7 @@ Allocate memory aligned to a 16 byte bou
--- openjpeg/src/lib/openjp2/opj_malloc.h.orig 2014-03-26 12:53:47.000000000 +0000
+++ openjpeg/src/lib/openjp2/opj_malloc.h
@@ -101,7 +101,7 @@ Allocate memory aligned to a 16 byte bou
#elif defined(__FreeBSD__)
#define HAVE_POSIX_MEMALIGN
/* Linux x86_64 and OSX always align allocations to 16 bytes */