Allow building on systems without vsnprintf.
This commit is contained in:
parent
40cc5a8e8c
commit
b18a6f1700
2 changed files with 17 additions and 8 deletions
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.20 2010/02/09 12:31:19 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.21 2010/04/15 12:49:41 joerg Exp $
|
||||
|
||||
SHA1 (bash-4.1.tar.gz) = 3bd1ec9c66f3689f6b3495bdaaf9077b2e5dc150
|
||||
RMD160 (bash-4.1.tar.gz) = 554c7ecb4a63da431768caed1f958c06b8fa7207
|
||||
Size (bash-4.1.tar.gz) = 6598300 bytes
|
||||
SHA1 (patch-aa) = 24fefdd101926d89b4b9faea1ca74a34bdd5b99f
|
||||
SHA1 (patch-af) = 34833c0628a60b5200a9559581c617d878eb62a8
|
||||
SHA1 (patch-af) = 769ca529b3a755faa70f517988722276088859b7
|
||||
SHA1 (patch-ag) = 4da0a43f6b890482affff46b18eef4be67770e48
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-af,v 1.4 2007/09/18 21:20:12 wiz Exp $
|
||||
$NetBSD: patch-af,v 1.5 2010/04/15 12:49:41 joerg Exp $
|
||||
|
||||
--- builtins/printf.def.orig 2007-09-18 15:24:09.000000000 +0000
|
||||
--- builtins/printf.def.orig 2009-11-20 20:31:23.000000000 +0000
|
||||
+++ builtins/printf.def
|
||||
@@ -74,6 +74,11 @@ $END
|
||||
@@ -85,6 +85,11 @@ $END
|
||||
# undef PRIdMAX
|
||||
#endif
|
||||
|
||||
|
@ -14,7 +14,7 @@ $NetBSD: patch-af,v 1.4 2007/09/18 21:20:12 wiz Exp $
|
|||
#if !defined (PRIdMAX)
|
||||
# if HAVE_LONG_LONG
|
||||
# define PRIdMAX "lld"
|
||||
@@ -81,6 +86,13 @@ $END
|
||||
@@ -92,6 +97,13 @@ $END
|
||||
# define PRIdMAX "ld"
|
||||
# endif
|
||||
#endif
|
||||
|
@ -28,7 +28,16 @@ $NetBSD: patch-af,v 1.4 2007/09/18 21:20:12 wiz Exp $
|
|||
|
||||
#if !defined (errno)
|
||||
extern int errno;
|
||||
@@ -466,7 +478,11 @@ printf_builtin (list)
|
||||
@@ -172,7 +184,7 @@ extern int asprintf __P((char **, const
|
||||
#endif
|
||||
|
||||
#if !HAVE_VSNPRINTF
|
||||
-extern int vsnprintf __P((char *, size_t, const char *, ...)) __attribute__((__format__ (printf, 3, 4)));
|
||||
+extern int vsnprintf __P((char *, size_t, const char *, va_list)) __attribute__((__format__ (printf, 3, 0)));
|
||||
#endif
|
||||
|
||||
static void printf_erange __P((char *));
|
||||
@@ -487,7 +499,11 @@ printf_builtin (list)
|
||||
p = pp = getintmax ();
|
||||
if (p != pp)
|
||||
{
|
||||
|
@ -40,7 +49,7 @@ $NetBSD: patch-af,v 1.4 2007/09/18 21:20:12 wiz Exp $
|
|||
PF (f, pp);
|
||||
}
|
||||
else
|
||||
@@ -493,7 +509,11 @@ printf_builtin (list)
|
||||
@@ -514,7 +530,11 @@ printf_builtin (list)
|
||||
p = pp = getuintmax ();
|
||||
if (p != pp)
|
||||
{
|
||||
|
|
Loading…
Reference in a new issue