Apply upstream fix for FPCR register handling on aarch64, fixes bogus

test failures in our test runs.
This commit is contained in:
martin 2019-01-29 16:01:29 +00:00
parent 47cca7e6aa
commit b1d587bee3
3 changed files with 20 additions and 3 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.198 2019/01/22 12:08:14 gson Exp $
# $NetBSD: Makefile,v 1.199 2019/01/29 16:01:29 martin Exp $
DISTNAME= qemu-3.1.0
PKGREVISION= 2
PKGREVISION= 3
CATEGORIES= emulators
MASTER_SITES= https://download.qemu.org/
EXTRACT_SUFX= .tar.xz

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.139 2018/12/12 16:26:58 adam Exp $
$NetBSD: distinfo,v 1.140 2019/01/29 16:01:29 martin Exp $
SHA1 (qemu-3.1.0.tar.xz) = 3ed63c0c05abc8c8ec075dac2688c229f139a5da
RMD160 (qemu-3.1.0.tar.xz) = 7650d76b8578ee2c31cef048c7929b30c607b83d
@ -16,4 +16,5 @@ SHA1 (patch-hw_display_omap__dss.c) = 6b13242f28e32346bc70548c216c578d98fd3420
SHA1 (patch-hw_net_etraxfs__eth.c) = e5dd1661d60dbcd27b332403e0843500ba9544bc
SHA1 (patch-hw_net_xilinx__axienet.c) = ebcd2676d64ce6f31e4a8c976d4fdf530ad5e8b7
SHA1 (patch-hw_usb_dev-mtp.c) = 66543b5559d92f8e2fa9a6eb85e5dfe7c1ad3339
SHA1 (patch-target_arm_cpu.h) = 74b8b52c0d6fd34b5755ef60a459d6d07630dc3b
SHA1 (patch-tests_Makefile.include) = 42345d697cb2e324dccf1d68bd8d61e8001c6162

View file

@ -0,0 +1,16 @@
$NetBSD: patch-target_arm_cpu.h,v 1.1 2019/01/29 16:01:29 martin Exp $
Patch from upstream maintain (Peter Maydell) to fix NetBSD ATF tests
non-trapping FP exception detection.
--- target/arm/cpu.h.orig 2018-12-11 18:44:34.000000000 +0100
+++ target/arm/cpu.h 2019-01-29 15:44:39.081529725 +0100
@@ -1297,7 +1297,7 @@ void vfp_set_fpscr(CPUARMState *env, uin
* we store the underlying state in fpscr and just mask on read/write.
*/
#define FPSR_MASK 0xf800009f
-#define FPCR_MASK 0x07ff9f00
+#define FPCR_MASK 0x07ff0000
#define FPCR_FZ16 (1 << 19) /* ARMv8.2+, FP16 flush-to-zero */
#define FPCR_FZ (1 << 24) /* Flush-to-zero enable bit */