Ensure the local yywrap is used. Fixes build with newer flex.

This commit is contained in:
jperkin 2017-01-04 12:52:40 +00:00
parent 4501c2d100
commit b1eff42d65
2 changed files with 16 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.10 2016/08/14 13:39:29 mef Exp $
$NetBSD: distinfo,v 1.11 2017/01/04 12:52:40 jperkin Exp $
SHA1 (intercal-0.30.tar.gz) = 7c703f388dfb2098e73bbbdabdecdc6878487a07
RMD160 (intercal-0.30.tar.gz) = 151fb0cca1d128575955f69fdb1ac9f32d07c3da
@ -7,3 +7,4 @@ Size (intercal-0.30.tar.gz) = 930759 bytes
SHA1 (patch-aa) = b6f7d5e4a46361f5af3ce3e1a646bc70c5b01ca6
SHA1 (patch-ae) = bb28fb6edd30e5d3dd1c41b42a1784cadb9428b0
SHA1 (patch-ag) = faf03857ad487796879632749489ad33b8648ba2
SHA1 (patch-src_lexer.l) = 351d5a984d2de5e3e1f062b21609580bce090e4c

View file

@ -0,0 +1,14 @@
$NetBSD: patch-src_lexer.l,v 1.1 2017/01/04 12:52:40 jperkin Exp $
Ensure the local yywrap is used.
--- src/lexer.l.orig 2010-09-01 22:29:25.000000000 +0000
+++ src/lexer.l
@@ -38,6 +38,7 @@ LICENSE TERMS
/*#undef wchar_t*/
/*#define wchar_t unsigned char*/
+#undef yywrap
#ifndef yywrap
static int yywrap(void)
{