Split this package into two - the original mtr uses a curses-based

interface, the mtr-gtk package uses gtk. For use in environments
which need mtr's functionality, but which are unlikely to have X11
installed, such as DMZ hosts, etc.

Patches by Andrew Brown, atatat@netbsd.org.
This commit is contained in:
agc 2001-10-16 15:08:55 +00:00
parent 1b5fc9dfe2
commit b1fbdd6549
6 changed files with 116 additions and 4 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.15 2001/09/09 15:22:13 wiz Exp $
# $NetBSD: Makefile,v 1.16 2001/10/16 15:08:55 agc Exp $
#
DISTNAME= mtr-0.42
@ -10,10 +10,16 @@ MAINTAINER= sommerfeld@netbsd.org
HOMEPAGE= http://www.bitwizard.nl/mtr/
COMMENT= Traceroute and ping in a single graphical network diagnostic tool
BUILD_DEPENDS+= autoconf-2.13:../../devel/autoconf
BUILD_DEPENDS+= automake-1.4:../../devel/automake
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_BUILDLINK_ONLY= yes
pre-configure:
cd ${WRKSRC} && ${LOCALBASE}/bin/autoconf
do-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/mtr
${INSTALL} -c -s -m 4755 -o root -g wheel ${WRKSRC}/mtr ${PREFIX}/sbin
@ -21,5 +27,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/SECURITY ${PREFIX}/share/doc/mtr
.include "../../devel/ncurses/buildlink.mk"
.include "../../x11/gtk/buildlink.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,6 +1,9 @@
$NetBSD: distinfo,v 1.2 2001/04/21 11:23:22 wiz Exp $
$NetBSD: distinfo,v 1.3 2001/10/16 15:08:55 agc Exp $
SHA1 (mtr-0.42.tar.gz) = 7bcb6c317911139355cabe5b21e1c7efc5cb5694
Size (mtr-0.42.tar.gz) = 84767 bytes
SHA1 (patch-aa) = c098f19f68220fa6c37d3e43edc2d6c49cba8118
SHA1 (patch-ab) = 9ba3ea130f737864e673e60ce656b96556d3c1cc
SHA1 (patch-ac) = 6f7d40fc957ba61f4e5a4a29993aa963d627906d
SHA1 (patch-ad) = a019773eddeb53fb45afa8de2b1a6b03b436e803
SHA1 (patch-ae) = 66a05d1edb1f300c6573a480d4c4357a94c29f6f

31
net/mtr/patches/patch-ac Normal file
View file

@ -0,0 +1,31 @@
$NetBSD: patch-ac,v 1.1 2001/10/16 15:08:56 agc Exp $
Rip out any mention of GTK from the configure.in script so that mtr
can build happily without it.
--- configure.in 2001/10/16 11:19:57 1.1
+++ configure.in 2001/10/16 11:20:48
@@ -1,10 +1,8 @@
AC_INIT(mtr.c)
AM_INIT_AUTOMAKE(mtr, 0.42)
-AC_SUBST(GTK_OBJ)
AC_SUBST(CURSES_OBJ)
-GTK_OBJ=gtk.o
CURSES_OBJ=curses.o
AC_PROG_CC
@@ -39,11 +37,7 @@
AC_CHECK_LIB(m, floor, , AC_MSG_ERROR(No math library found))
-AM_PATH_GTK(1.0.0, CFLAGS="$CFLAGS $GTK_CFLAGS"
- LIBS="$LIBS $GTK_LIBS",
- AC_MSG_WARN(Building without GTK+ display support)
- AC_DEFINE(NO_GTK)
- GTK_OBJ=)
+AC_DEFINE(NO_GTK)
AC_CHECK_FUNC(socket, ,
AC_CHECK_LIB(socket, socket, , AC_MSG_ERROR(No socket library found)))

25
net/mtr/patches/patch-ad Normal file
View file

@ -0,0 +1,25 @@
$NetBSD: patch-ad,v 1.1 2001/10/16 15:08:56 agc Exp $
Remove the gtk related options since we're not using gtk.
--- mtr.c 2001/10/16 11:22:10 1.1
+++ mtr.c 2001/10/16 11:23:02
@@ -56,7 +56,6 @@
{ "report", 0, 0, 'r' },
{ "report-cycles", 1, 0, 'c' },
{ "curses", 0, 0, 't' },
- { "gtk", 0, 0, 'g' },
{ "interval", 1, 0, 'i' },
{ "psize", 1, 0, 'p' },
{ "no-dns", 0, 0, 'n' },
@@ -182,8 +181,8 @@
}
if(PrintHelp) {
- printf("usage: %s [-hvrctglsni] [--help] [--version] [--report]\n"
- "\t\t[--report-cycles=COUNT] [--curses] [--gtk]\n"
+ printf("usage: %s [-hvrctlsni] [--help] [--version] [--report]\n"
+ "\t\t[--report-cycles=COUNT] [--curses]\n"
"\t\t[--raw] [--split] [--no-dns]\n" /* BL */
"\t\t[--psize=bytes/-p=bytes]\n" /* ok */
"\t\t[--interval=SECONDS] HOSTNAME [PACKETSIZE]\n", argv[0]);

47
net/mtr/patches/patch-ae Normal file
View file

@ -0,0 +1,47 @@
$NetBSD: patch-ae,v 1.1 2001/10/16 15:08:56 agc Exp $
Remove the instruction on how to get to the gtk interface since
we don't have one.
--- mtr.8 2001/10/16 11:24:00 1.1
+++ mtr.8 2001/10/16 11:24:58
@@ -8,7 +8,7 @@
.SH SYNOPSIS
.B mtr
[\c
-.B \-hvrctglsni\c
+.B \-hvrctlsni\c
]
[\c
.B \-\-help\c
@@ -35,9 +35,6 @@
.B \-\-no-dns\c
]
[\c
-.B \-\-gtk\c
-]
-[\c
.B \-\-interval\ SECONDS\c
]
[\c
@@ -147,20 +144,6 @@
.B mtr
to display numeric IP numbers and not try to resolve the
host names.
-
-.TP
-.B \-g
-.TP
-.B \-\-gtk
-.br
-Use this option to force
-.B mtr
-to use the GTK+ based X11 window interface (if available).
-GTK+ must have been available on the system when
-.B mtr
-was built for this to work. See the GTK+ web page at
-.B http://www.gimp.org/gtk/
-for more information about GTK+.
.TP
.B \-s

View file

@ -1,5 +1,6 @@
mtr combines the functionality of the "traceroute" and "ping" programs
into a single network diagnostic tool.
into a single network diagnostic tool. This is the curses-based version
of the program.
Authors: Matt Kimball <mkimball@xmission.com> is the primary author of mtr.
Roger Wolff <R.E.Wolff@BitWizard.nl> is currently maintaining mtr.