lang/clang: USE_TOOLS+= pod2man pod2html, fix DragonFly
For some reason, LLVM is using autoconf files from 2003 which is before DragonFly even existed. I submitted a bug report #12944 at llvm.org's bugzilla to request they use versions from 2012. Also, installation fails at document generation without some extra tools. No need to revbump, either built or it didn't without these packages.
This commit is contained in:
parent
23ef9e4f1b
commit
b22dc86ba5
3 changed files with 16 additions and 3 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.12 2012/05/23 11:02:41 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.13 2012/05/25 09:06:52 marino Exp $
|
||||
|
||||
DISTNAME= clang-3.1
|
||||
CATEGORIES= lang
|
||||
|
@ -16,7 +16,7 @@ PKG_DESTDIR_SUPPORT= user-destdir
|
|||
WRKSRC= ${WRKDIR}/llvm-${PKGVERSION_NOREV}.src
|
||||
|
||||
USE_LANGUAGES= c c++
|
||||
USE_TOOLS+= chown gmake
|
||||
USE_TOOLS+= chown gmake perl pod2man pod2html
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --disable-assertions
|
||||
CONFIGURE_ARGS+= --disable-bindings # disable OCaml
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.10 2012/05/23 11:02:41 adam Exp $
|
||||
$NetBSD: distinfo,v 1.11 2012/05/25 09:06:52 marino Exp $
|
||||
|
||||
SHA1 (clang-3.1.src.tar.gz) = 19f33b187a50d22fda2a6f9ed989699a9a9efd62
|
||||
RMD160 (clang-3.1.src.tar.gz) = 5ae09d3d69d4f1e50e07f6bf3474da96e6a84feb
|
||||
|
@ -9,3 +9,4 @@ Size (llvm-3.1.src.tar.gz) = 11077429 bytes
|
|||
SHA1 (patch-ab) = 140ac84d513cf20c9eb30a9e8e2f6b87bdd074fe
|
||||
SHA1 (patch-ac) = 252f6a1f2cb79fed19668310c72d1079b47eca3c
|
||||
SHA1 (patch-ad) = 4cd7223d1660a4e8d81b33b6c99efbb680664164
|
||||
SHA1 (patch-projects_sample_autoconf_config.sub) = 7e8449c46ed0c3e5530235d33a35f7f4e083d0b0
|
||||
|
|
12
lang/clang/patches/patch-projects_sample_autoconf_config.sub
Normal file
12
lang/clang/patches/patch-projects_sample_autoconf_config.sub
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-projects_sample_autoconf_config.sub,v 1.1 2012/05/25 09:06:53 marino Exp $
|
||||
|
||||
--- projects/sample/autoconf/config.sub.orig 2003-10-16 01:44:20.000000000 +0000
|
||||
+++ projects/sample/autoconf/config.sub
|
||||
@@ -1114,6 +1114,7 @@ case $os in
|
||||
| -hpux* | -unos* | -osf* | -luna* | -dgux* | -solaris* | -sym* \
|
||||
| -amigaos* | -amigados* | -msdos* | -newsos* | -unicos* | -aof* \
|
||||
| -aos* \
|
||||
+ | -dragonfly* \
|
||||
| -nindy* | -vxsim* | -vxworks* | -ebmon* | -hms* | -mvs* \
|
||||
| -clix* | -riscos* | -uniplus* | -iris* | -rtu* | -xenix* \
|
||||
| -hiux* | -386bsd* | -netbsd* | -openbsd* | -freebsd* | -riscix* \
|
Loading…
Reference in a new issue