Update ruby-jekyll to 3.4.3 with pkgsrc own change.

* Add `--execute-bundle` option to `jekyll new` to disable running bundler
  default.

* Now depends on ruby-jekyll-minima and ruby-jekyll-feed.  These are used
  by default theme of a site created by `jekyll new`.


v3.4.3						2017/3/21

* Backport #5957 for v3.4.x: Allow colons in uri_escape filter (#5968)
This commit is contained in:
taca 2017-04-22 17:13:48 +00:00
parent ff49dc8104
commit b24d9055d3
3 changed files with 39 additions and 7 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.21 2017/03/20 16:36:16 taca Exp $
# $NetBSD: Makefile,v 1.22 2017/04/22 17:13:48 taca Exp $
DISTNAME= jekyll-3.4.2
DISTNAME= jekyll-3.4.3
CATEGORIES= www
MAINTAINER= pkgsrc-users@NetBSD.org

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.11 2017/03/20 16:36:16 taca Exp $
$NetBSD: distinfo,v 1.12 2017/04/22 17:13:48 taca Exp $
SHA1 (jekyll-3.4.2.gem) = 656d85dad7db2595dddd627f0bcf61bb8291df6b
RMD160 (jekyll-3.4.2.gem) = 5c145362f4e6411d50c322c67c42dd0b39e4ab0a
SHA512 (jekyll-3.4.2.gem) = 8bc5d0ebf9874131624afbc354a10df900d41b8e48df1081b1fbe1473a49561705e89a5e8e901cb2fe413bcb754e6b886fcf50d5c5f0140167b865ae2389225f
Size (jekyll-3.4.2.gem) = 91136 bytes
SHA1 (jekyll-3.4.3.gem) = 3e8f94f561f94ff9b239e2c23f7a4a291a9bd33c
RMD160 (jekyll-3.4.3.gem) = 69b48975be0990d7651be9b8b5b33076b405411b
SHA512 (jekyll-3.4.3.gem) = e6696d069f401acb49af0d39dd05d9fe55a384711c95104fc970ab0ff9106eb9d66e7afd96c826da713388e68bef6524ad5863223c6595424d1cbb9a24745cd1
Size (jekyll-3.4.3.gem) = 91136 bytes
SHA1 (patch-lib_jekyll_commands_new.rb) = eed3af934584debec177a58b916464ff536b7178

View file

@ -0,0 +1,31 @@
$NetBSD: patch-lib_jekyll_commands_new.rb,v 1.1 2017/04/22 17:13:48 taca Exp $
Do not use bundle unless specify --execute-bundle option.
--- lib/jekyll/commands/new.rb.orig 2017-04-22 08:36:18.000000000 +0000
+++ lib/jekyll/commands/new.rb
@@ -13,6 +13,8 @@ module Jekyll
c.option "blank", "--blank", "Creates scaffolding but with empty files"
c.option "skip-bundle", "--skip-bundle", "Skip 'bundle install'"
+ c.option "execute-bundle", "--execute-bundle", "Use 'bundle install'"
+
c.action do |args, options|
Jekyll::Commands::New.process(args, options)
end
@@ -125,12 +127,13 @@ RUBY
# unless the user opts to generate a blank blog or skip 'bundle install'.
def after_install(path, options = {})
- unless options["blank"] || options["skip-bundle"]
+ execute_bundle = options["execute-bundle"]
+ unless options["blank"] || options["skip-bundle"] || (not execute_bundle)
bundle_install path
end
Jekyll.logger.info "New jekyll site installed in #{path.cyan}."
- Jekyll.logger.info "Bundle install skipped." if options["skip-bundle"]
+ Jekyll.logger.info "Bundle install skipped." if options["skip-bundle"] or (not execute_bundle)
end
def bundle_install(path)