Fix generation/lookup of search indexs in khelpcenter.
Bump PKGREVISION. Update during freeze OKed by wiz.
This commit is contained in:
parent
96ae91c9ce
commit
b27617fcaa
5 changed files with 131 additions and 4 deletions
|
@ -1,6 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.97 2005/12/11 11:01:48 markd Exp $
|
||||
# $NetBSD: Makefile,v 1.98 2005/12/17 19:36:27 markd Exp $
|
||||
|
||||
DISTNAME= kdebase-${_KDE_VERSION}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= x11
|
||||
COMMENT= Base modules for the KDE 3 integrated X11 desktop
|
||||
|
||||
|
@ -29,9 +30,9 @@ CONFIGURE_ARGS+= --without-java
|
|||
|
||||
REPLACE_PERL= kcontrol/fileshare/fileshareset \
|
||||
kcontrol/keys/convertShortcuts.pl \
|
||||
khelpcenter/searchhandlers/khc_htdig.pl \
|
||||
khelpcenter/searchhandlers/khc_docbookdig.pl.in \
|
||||
khelpcenter/searchhandlers/khc_htdig.pl.in \
|
||||
khelpcenter/searchhandlers/khc_htsearch.pl \
|
||||
khelpcenter/searchhandlers/khc_docbookdig.pl \
|
||||
khelpcenter/searchhandlers/khc_mansearch.pl \
|
||||
kicker/kicker/kicker-3.1-properSizeSetting.pl \
|
||||
kicker/kicker/kicker-3.5-kconfigXTize.pl \
|
||||
|
@ -88,6 +89,8 @@ PKG_SUGGESTED_OPTIONS= sasl
|
|||
BUILDLINK_DEPENDS.Xrandr+= Xrandr>=1.0
|
||||
BUILDLINK_DEPENDS.kdelibs+= kdelibs>=${_KDE_VERSION}
|
||||
|
||||
DEPENDS+= htdig>=3.2.0:../../www/htdig-devel
|
||||
|
||||
.if !empty(PKG_OPTIONS:Msamba)
|
||||
.include "../../net/samba/buildlink3.mk"
|
||||
LIBS+= -L${BUILDLINK_PREFIX.samba}/lib/samba -Wl,-R${BUILDLINK_PREFIX.samba}/lib/samba
|
||||
|
@ -128,6 +131,12 @@ SUBST_SED.varlock= s:/var/lock:/var/spool/lock:
|
|||
.endif
|
||||
.endif
|
||||
|
||||
SUBST_CLASSES+= htdig
|
||||
SUBST_STAGE.htdig= post-patch
|
||||
SUBST_MESSAGE.htdig= "Fix htdig paths."
|
||||
SUBST_FILES.htdig= khelpcenter/searchhandlers/khc_htsearch.pl
|
||||
SUBST_SED.htdig= s:/srv/www/cgi-bin:${PREFIX}/libexec/cgi-bin:
|
||||
|
||||
pre-configure:
|
||||
${LN} -s FreeBSD ${WRKSRC}/ksysguard/ksysguardd/DragonFly
|
||||
cd ${WRKSRC}; \
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.77 2005/12/11 11:01:48 markd Exp $
|
||||
$NetBSD: distinfo,v 1.78 2005/12/17 19:36:27 markd Exp $
|
||||
|
||||
SHA1 (kdebase-3.5.0.tar.bz2) = 8826fdd8884151cf224442da78d23d5685bd21e9
|
||||
RMD160 (kdebase-3.5.0.tar.bz2) = 5f8d5735a468f1c4e42cccfc0f006e63e3c3c762
|
||||
|
@ -25,6 +25,9 @@ SHA1 (patch-am) = 07ed2a5717a8f72bc36906ef4fafc360ac63479c
|
|||
SHA1 (patch-bb) = 4c85002b95661db18619283e50512f3ab131a0ba
|
||||
SHA1 (patch-bc) = fd7e784b584763b7351dbdaefda58443bd1aaadb
|
||||
SHA1 (patch-bx) = d58d16fd484fc0a46c1ae93267af19e73af6f990
|
||||
SHA1 (patch-ca) = 0cdd9ee4766fef59a3c1c04a4ff820aee5043e2c
|
||||
SHA1 (patch-cb) = fff02fcd41b27bc2a35ee0658153cb8c81617bd0
|
||||
SHA1 (patch-cc) = ed95490558d4de4a04aa0f45634e44ed0b78fdd8
|
||||
SHA1 (patch-da) = 06da421a8adcb54712e7c04125cffa9bef9003fb
|
||||
SHA1 (patch-db) = f67ffaf0676484db40759574cc2822ad0d6933bd
|
||||
SHA1 (patch-dc) = dd44652ad806d49d45ef86cbff58a01e506deeee
|
||||
|
|
21
x11/kdebase3/patches/patch-ca
Normal file
21
x11/kdebase3/patches/patch-ca
Normal file
|
@ -0,0 +1,21 @@
|
|||
$NetBSD: patch-ca,v 1.4 2005/12/17 19:36:27 markd Exp $
|
||||
|
||||
--- khelpcenter/searchhandlers/khc_mansearch.pl.orig 2005-12-01 00:32:43.000000000 +1300
|
||||
+++ khelpcenter/searchhandlers/khc_mansearch.pl
|
||||
@@ -55,7 +55,7 @@ my @results;
|
||||
while( <MAN> ) {
|
||||
# print "RAW:$_";
|
||||
chop;
|
||||
- /^([^\s]+)\s+\((.*)\)\s+-\s+(.*)$/;
|
||||
+ /^([^(]+)\s+\((.*)\)\s+-\s+(.*)$/;
|
||||
my $page = $1;
|
||||
my $section = $2;
|
||||
my $description = $3;
|
||||
@@ -73,6 +73,7 @@ if ( $nummatches > 0 ) {
|
||||
for my $result ( @results ) {
|
||||
my ( $page, $section, $description ) = @$result;
|
||||
my $url = "man:" . $page;
|
||||
+ $url =~ s/,.*//;
|
||||
print "<li><a href=\"$url\">";
|
||||
print "$page - $description</a></li>\n";
|
||||
if ( ++$count == $maxcount ) { last; }
|
70
x11/kdebase3/patches/patch-cb
Normal file
70
x11/kdebase3/patches/patch-cb
Normal file
|
@ -0,0 +1,70 @@
|
|||
$NetBSD: patch-cb,v 1.4 2005/12/17 19:36:27 markd Exp $
|
||||
|
||||
--- khelpcenter/searchhandlers/khc_docbookdig.pl.in.orig 2005-10-11 04:03:56.000000000 +1300
|
||||
+++ khelpcenter/searchhandlers/khc_docbookdig.pl.in
|
||||
@@ -26,8 +26,8 @@ use strict;
|
||||
|
||||
use Getopt::Long;
|
||||
|
||||
-my $htdigdata = "/srv/www/htdig/common/";
|
||||
-my $htdigbin = "/usr/bin";
|
||||
+my $htdigdata = "@prefix@/share/htdig/common/";
|
||||
+my $htdigbin = "@prefix@/bin";
|
||||
my $kdeprefix = "@prefix@";
|
||||
chomp $kdeprefix;
|
||||
|
||||
@@ -85,7 +85,7 @@ if ( !open( START, ">$startfile" ) ) {
|
||||
exit 1;
|
||||
}
|
||||
|
||||
-my $findcmd = "find $kdeprefix/share/doc/HTML/$lang/ -name index.docbook";
|
||||
+my $findcmd = "find $kdeprefix/share/doc/kde/HTML/$lang/ -name index.docbook";
|
||||
|
||||
print STDERR "FINDCMD: $findcmd\n";
|
||||
|
||||
@@ -121,21 +121,24 @@ if ( !open( PARSER, ">$parserfile" ) ) {
|
||||
print PARSER << "EOT";
|
||||
#! /bin/sh
|
||||
|
||||
+PATH=/bin:/usr/bin:\$PATH
|
||||
+export PATH
|
||||
+
|
||||
file=\$1
|
||||
shift
|
||||
mime=\$1
|
||||
shift
|
||||
|
||||
if test "\$#" -gt 0; then
|
||||
- orig=\${1/file:\/\//}
|
||||
+ orig=`echo \$1 | sed -e 's=file:=/='`
|
||||
shift
|
||||
fi
|
||||
|
||||
case "\$orig" in
|
||||
help:/*)
|
||||
- orig=\${orig/help:\//}
|
||||
- orig=\${orig/\/index.docbook//}
|
||||
- cd $kdeprefix/share/doc/HTML/en/\$orig
|
||||
+ orig=\${orig#help:}
|
||||
+ orig=\${orig\%/index.docbook}
|
||||
+ cd $kdeprefix/share/doc/kde/HTML/en/\$orig
|
||||
file=index.docbook
|
||||
;;
|
||||
*)
|
||||
@@ -162,14 +165,14 @@ common_dir: $commondir
|
||||
locale: $locale
|
||||
database_dir: $htdigdb
|
||||
database_base: \${database_dir}/$identifier
|
||||
-local_urls: help://=$kdeprefix/share/doc/HTML/en/ file://=/
|
||||
+local_urls: help://=$kdeprefix/share/doc/kde/HTML/en/ file://=/
|
||||
local_urls_only: true
|
||||
limit_urls_to: file:// help:/
|
||||
ignore_noindex: true
|
||||
max_hop_count: 4
|
||||
robotstxt_name: kdedig
|
||||
compression_level: 6
|
||||
-template_map: Long long $kdeprefix/share/apps/khelpcenter/searchhandlers/htdig/htdig_long.html
|
||||
+template_map: Long long $kdeprefix/share/kde/apps/khelpcenter/searchhandlers/htdig/htdig_long.html
|
||||
search_algorithm: exact:1 prefix:0.8
|
||||
maximum_pages: 1
|
||||
matches_per_page: 10
|
24
x11/kdebase3/patches/patch-cc
Normal file
24
x11/kdebase3/patches/patch-cc
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-cc,v 1.5 2005/12/17 19:36:28 markd Exp $
|
||||
|
||||
--- khelpcenter/searchhandlers/khc_htdig.pl.in.orig 2005-10-11 04:03:56.000000000 +1300
|
||||
+++ khelpcenter/searchhandlers/khc_htdig.pl.in
|
||||
@@ -26,8 +26,8 @@ use strict;
|
||||
|
||||
use Getopt::Long;
|
||||
|
||||
-my $htdigdata = "/srv/www/htdig/common/";
|
||||
-my $htdigbin = "/usr/bin";
|
||||
+my $htdigdata = "@prefix@/share/htdig/common/";
|
||||
+my $htdigbin = "@prefix@/bin";
|
||||
my $kdeprefix = "@prefix@";
|
||||
chomp $kdeprefix;
|
||||
|
||||
@@ -93,7 +93,7 @@ ignore_noindex: true
|
||||
max_hop_count: 4
|
||||
robotstxt_name: kdedig
|
||||
compression_level: 6
|
||||
-template_map: Long long $kdeprefix/share/apps/khelpcenter/searchhandlers/htdig/htdig_long.html \\
|
||||
+template_map: Long long $kdeprefix/share/kde/apps/khelpcenter/searchhandlers/htdig/htdig_long.html \\
|
||||
Short short $htdigdata/short.html
|
||||
search_algorithm: exact:1 prefix:0.8
|
||||
maximum_pages: 1
|
Loading…
Reference in a new issue