When depending on <cmath> to provide namespaces, also ensure that it is
really used.
This commit is contained in:
parent
150216ecaf
commit
b277825b13
3 changed files with 26 additions and 10 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.34 2018/02/08 07:28:57 mrg Exp $
|
||||
$NetBSD: distinfo,v 1.35 2018/03/31 20:08:11 joerg Exp $
|
||||
|
||||
SHA1 (audacity-minsrc-2.1.2.tar.xz) = d0b8924b846f833182e674d621b28eb666cc97d6
|
||||
RMD160 (audacity-minsrc-2.1.2.tar.xz) = 47fccf8b96b6db95a677045bf122084d233bd80c
|
||||
|
@ -19,7 +19,7 @@ SHA1 (patch-lib-src_sbsms_src-extra_Makefile.am) = 2beca18a286de1b26f4f96976fb58
|
|||
SHA1 (patch-src_FFmpeg.h) = 664efb8a668a9dd5f76704e5a46c495a8c2c3a4d
|
||||
SHA1 (patch-src_effects_NoiseRemoval.cpp) = 6d72545cde66ac90d4eb3821a3a3f384ccbf46f2
|
||||
SHA1 (patch-src_effects_VST_VSTEffect.cpp) = 76a55afd7977505801dd129e139c9782bfd8dfcb
|
||||
SHA1 (patch-src_effects_lv2_LV2Effect.cpp) = 88972bb870f9aa1018337a6e2e4042827f3c6e7f
|
||||
SHA1 (patch-src_effects_nyquist_Nyquist.cpp) = 1a931e9287960a43f862bbfa2c6fc8ee535a4bec
|
||||
SHA1 (patch-src_effects_lv2_LV2Effect.cpp) = b001b79df1e924ef0635436f5b8d02db5fa00dd6
|
||||
SHA1 (patch-src_effects_nyquist_Nyquist.cpp) = 980336375efe53d311b1187b5285ea5c7fe4c4a9
|
||||
SHA1 (patch-src_effects_vamp_LoadVamp.cpp) = 5e57289e99d8ac5323b869138d13b67b5ad8a3d6
|
||||
SHA1 (patch-src_import_ImportFLAC.cpp) = 9064b5f24cfd837d9a5d5bb74450bcfd0096b099
|
||||
|
|
|
@ -1,10 +1,18 @@
|
|||
$NetBSD: patch-src_effects_lv2_LV2Effect.cpp,v 1.1 2018/02/08 07:28:58 mrg Exp $
|
||||
$NetBSD: patch-src_effects_lv2_LV2Effect.cpp,v 1.2 2018/03/31 20:08:12 joerg Exp $
|
||||
|
||||
GCC 6 wants std namespace, found via <cmath>.
|
||||
|
||||
--- src/effects/lv2/LV2Effect.cpp.orig 2016-01-13 14:31:24.000000000 +0000
|
||||
+++ src/effects/lv2/LV2Effect.cpp 2018-02-07 10:20:15.597051982 +0000
|
||||
@@ -562,13 +562,13 @@
|
||||
+++ src/effects/lv2/LV2Effect.cpp
|
||||
@@ -44,6 +44,7 @@
|
||||
#include "lv2/lv2plug.in/ns/ext/buf-size/buf-size.h"
|
||||
#include "lv2/lv2plug.in/ns/ext/parameters/parameters.h"
|
||||
#include "lv2/lv2plug.in/ns/extensions/ui/ui.h"
|
||||
+#include <cmath>
|
||||
|
||||
#if defined(__WXGTK__)
|
||||
#include <gtk/gtk.h>
|
||||
@@ -562,13 +563,13 @@ bool LV2Effect::SetHost(EffectHostInterf
|
||||
lilv_scale_points_free(points);
|
||||
|
||||
// Collect the value and range info
|
||||
|
|
|
@ -1,10 +1,18 @@
|
|||
$NetBSD: patch-src_effects_nyquist_Nyquist.cpp,v 1.1 2018/02/08 07:28:58 mrg Exp $
|
||||
$NetBSD: patch-src_effects_nyquist_Nyquist.cpp,v 1.2 2018/03/31 20:08:12 joerg Exp $
|
||||
|
||||
GCC 6 wants std namespace, found via <cmath>.
|
||||
|
||||
--- src/effects/nyquist/Nyquist.cpp.orig 2018-02-07 10:04:58.228319803 +0000
|
||||
+++ src/effects/nyquist/Nyquist.cpp 2018-02-07 10:14:46.346004080 +0000
|
||||
@@ -666,7 +666,7 @@
|
||||
--- src/effects/nyquist/Nyquist.cpp.orig 2016-01-13 14:31:24.000000000 +0000
|
||||
+++ src/effects/nyquist/Nyquist.cpp
|
||||
@@ -67,6 +67,7 @@ effects from this one class.
|
||||
#include <ostream>
|
||||
#include <sstream>
|
||||
#include <float.h>
|
||||
+#include <cmath>
|
||||
|
||||
#include "../../Experimental.h"
|
||||
|
||||
@@ -666,7 +667,7 @@ bool NyquistEffect::Process()
|
||||
// with very small values, bandwidth calculation may be inf.
|
||||
// (Observed on Linux)
|
||||
double bw = log(mF1 / mF0) / log(2.0);
|
||||
|
|
Loading…
Reference in a new issue