Update to 4.16
Changelog: NSPR 4.16 contains various correctness fixes.
This commit is contained in:
parent
39c12606d7
commit
b283b34b44
3 changed files with 17 additions and 25 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.90 2017/07/03 12:18:17 ryoon Exp $
|
||||
# $NetBSD: Makefile,v 1.91 2017/08/01 12:10:48 ryoon Exp $
|
||||
|
||||
DISTNAME= nspr-${NSPR_RELEASE:S/.0$//}
|
||||
NSPR_RELEASE= 4.15.0
|
||||
NSPR_RELEASE= 4.16.0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_MOZILLA_ALL:=nspr/releases/v${NSPR_RELEASE:S/.0$//}/src/}
|
||||
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.44 2017/07/03 12:18:17 ryoon Exp $
|
||||
$NetBSD: distinfo,v 1.45 2017/08/01 12:10:48 ryoon Exp $
|
||||
|
||||
SHA1 (nspr-4.15.tar.gz) = 56030e0177849034ba3027a23ae2a7f8ed41f379
|
||||
RMD160 (nspr-4.15.tar.gz) = 27b31774022523b9eb88684f7c0b459c2d225ff0
|
||||
SHA512 (nspr-4.15.tar.gz) = 1d6e9ba3ef71376ddb4f5ef2a6796bf3f95cf37abfac89d1745f02cc01003877d088a87946208d3827a3b3e28420215e543a647aadceff2ae6f9c1c70d4ac563
|
||||
Size (nspr-4.15.tar.gz) = 1140182 bytes
|
||||
SHA1 (nspr-4.16.tar.gz) = b295ee2550b43edc0598c20663ceef9fa3fafe51
|
||||
RMD160 (nspr-4.16.tar.gz) = bf58a7ba95ae73356f7d0b28d0ad144e9297af4d
|
||||
SHA512 (nspr-4.16.tar.gz) = 38cb8b26c2ee44063357a9484f1f6b24bab00a0d28a8f1644f64356205e7a407a1858d7a4d5cd2d6b62a39d3c0aea0cf2bddaa95fe61df272a633fe5fdee41b6
|
||||
Size (nspr-4.16.tar.gz) = 1140681 bytes
|
||||
SHA1 (patch-ab) = d93c055bbb12bd9edf5f21138a93898d6b3b3c73
|
||||
SHA1 (patch-ac) = fb55a0da3e7978532823b0b25d17803f50087b95
|
||||
SHA1 (patch-ac) = 9eecea602eb37dedb1675b9ae05061d81b924446
|
||||
SHA1 (patch-ae) = c6cf30927792140d867bb4dc3adf19786f6cdbe0
|
||||
SHA1 (patch-ag) = 653d4bc8cc4eced8f628cfb738c5d99cc1a6cf24
|
||||
SHA1 (patch-az) = 8961cde8e657176e9e18098ab8e8e4d59723ceca
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ac,v 1.12 2017/07/03 12:18:17 ryoon Exp $
|
||||
$NetBSD: patch-ac,v 1.13 2017/08/01 12:10:48 ryoon Exp $
|
||||
|
||||
add runpath to Linux caught during check-shlibs-elf
|
||||
|
||||
--- nspr/configure.in.orig 2017-06-05 20:16:00.000000000 +0000
|
||||
--- nspr/configure.in.orig 2017-07-27 12:31:27.000000000 +0000
|
||||
+++ nspr/configure.in
|
||||
@@ -38,7 +38,7 @@ OBJDIR_NAME=.
|
||||
OBJDIR_SUFFIX=OBJ
|
||||
|
@ -13,15 +13,7 @@ add runpath to Linux caught during check-shlibs-elf
|
|||
LIBPLC='-L$(dist_libdir) -lplc$(MOD_MAJOR_VERSION)'
|
||||
CYGWIN_WRAPPER=
|
||||
MACOS_SDK_DIR=
|
||||
@@ -1389,6 +1389,7 @@ case "$target" in
|
||||
changequote([,])
|
||||
if test "$HOST_DARWIN_MAJOR" -ge 15 ; then
|
||||
AC_DEFINE(HAS_CONNECTX)
|
||||
+ fi
|
||||
AS='$(CC) -x assembler-with-cpp'
|
||||
CFLAGS="$CFLAGS -Wall -fno-common"
|
||||
case "${target_cpu}" in
|
||||
@@ -1571,6 +1572,33 @@ tools are selected during the Xcode/Deve
|
||||
@@ -1573,6 +1573,33 @@ tools are selected during the Xcode/Deve
|
||||
DSO_LDOPTS='-shared -Wl,-soname -Wl,$(notdir $@)'
|
||||
MDCPUCFG_H=_freebsd.cfg
|
||||
PR_MD_CSRCS=freebsd.c
|
||||
|
@ -55,7 +47,7 @@ add runpath to Linux caught during check-shlibs-elf
|
|||
;;
|
||||
|
||||
*-hpux*)
|
||||
@@ -1846,6 +1874,9 @@ tools are selected during the Xcode/Deve
|
||||
@@ -1848,6 +1875,9 @@ tools are selected during the Xcode/Deve
|
||||
MKSHLIB='$(CC) $(DSO_LDOPTS) -o $@'
|
||||
DSO_CFLAGS=-fPIC
|
||||
DSO_LDOPTS='-shared -Wl,-soname -Wl,$(notdir $@)'
|
||||
|
@ -65,8 +57,8 @@ add runpath to Linux caught during check-shlibs-elf
|
|||
_OPTIMIZE_FLAGS=-O2
|
||||
_DEBUG_FLAGS="-g -fno-inline" # most people on linux use gcc/gdb, and that
|
||||
# combo is not yet good at debugging inlined
|
||||
@@ -2169,7 +2200,7 @@ tools are selected during the Xcode/Deve
|
||||
AC_DEFINE(HAVE_SOCKLEN_T)
|
||||
@@ -2173,7 +2203,7 @@ tools are selected during the Xcode/Deve
|
||||
AC_DEFINE(HAVE_POINTER_LOCALTIME_R)
|
||||
CFLAGS="$CFLAGS -ansi -Wall"
|
||||
CXXFLAGS="$CXXFLAGS -ansi -Wall"
|
||||
- DLL_SUFFIX=so.1.0
|
||||
|
@ -74,7 +66,7 @@ add runpath to Linux caught during check-shlibs-elf
|
|||
DSO_CFLAGS=-fPIC
|
||||
MDCPUCFG_H=_openbsd.cfg
|
||||
PR_MD_CSRCS=openbsd.c
|
||||
@@ -2756,7 +2787,7 @@ if test -n "$USE_PTHREADS"; then
|
||||
@@ -2760,7 +2790,7 @@ if test -n "$USE_PTHREADS"; then
|
||||
if test -z "`egrep -i '(unrecognize|unknown)' conftest.out | grep pthread`" && test -z "`egrep -i '(error|incorrect)' conftest.out`" ; then
|
||||
ac_cv_have_dash_pthread=yes
|
||||
case "$target_os" in
|
||||
|
@ -83,7 +75,7 @@ add runpath to Linux caught during check-shlibs-elf
|
|||
# Freebsd doesn't use -pthread for compiles, it uses them for linking
|
||||
;;
|
||||
*)
|
||||
@@ -2794,7 +2825,7 @@ if test -n "$USE_PTHREADS"; then
|
||||
@@ -2798,7 +2828,7 @@ if test -n "$USE_PTHREADS"; then
|
||||
_PTHREAD_LDFLAGS=
|
||||
fi
|
||||
;;
|
||||
|
@ -92,7 +84,7 @@ add runpath to Linux caught during check-shlibs-elf
|
|||
AC_DEFINE(_REENTRANT)
|
||||
AC_DEFINE(_THREAD_SAFE)
|
||||
dnl -pthread links in -lc_r, so don't specify it explicitly.
|
||||
@@ -2875,7 +2906,7 @@ case "$target" in
|
||||
@@ -2879,7 +2909,7 @@ case "$target" in
|
||||
AC_DEFINE(_PR_NEED_PTHREAD_INIT)
|
||||
fi
|
||||
;;
|
||||
|
|
Loading…
Reference in a new issue