Changes 0.83:

* cone/sgml/cone-folderindex.sgml (prompt): Mention the inn 2.5.x bug.
* cone/myreferences.H (m): Fix NULL ptr deref.
* cone/cursesmessage.C (nextLink): Fix wild pointer.
* libmail/copymessage.C (fail): Fix segfault if fetching the contents,
  of the message being copied, fails.
* cone/cursesmessage.C (reformatAddLine): Clear the entire struct
  to suppress warnings from valgrind.
* gcc 4.5 portability fixes.
* tcpd/libcouriergnutls.c (tls_connect): Fix bad call to
  gnutls_server_name_set().

Changes 0.82:
* cone/curseseditmessage.C (getMarkedRegion): Portability fix (gcc 4.4.3).
* all: Some code cleanup.

Changes 0.81:
* cone/spellcheckerAspell.C: Do not set "lang" and "encoding" to empty values.

Changes 0.80:
* cone/libmail: Link with libidn if this library is installed. Added
  getAddrAddr() and setAddrAddr() methods to mail::emailAddress that
  use libidn, if installed, to decode/encode the hostname portion of the
  email address.
* The GNU IDN library is now required to build Cone
This commit is contained in:
adam 2010-05-18 13:24:15 +00:00
parent aba80dd669
commit b2a3ffdb15
4 changed files with 15 additions and 19 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.6 2010/03/21 16:29:40 wiz Exp $
# $NetBSD: Makefile,v 1.7 2010/05/18 13:24:15 adam Exp $
DISTNAME= cone-0.74
DISTNAME= cone-0.83
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=courier/}
EXTRACT_SUFX= .tar.bz2
@ -11,15 +11,15 @@ COMMENT= Console newsreader and emailer
PKG_DESTDIR_SUPPORT= user-destdir
USE_TOOLS+= gmake perl true
USE_LANGUAGES= c c++
USE_TOOLS+= gmake perl true
GCC_REQD+= 3.0 # need Standard C++ Library
.include "options.mk"
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
CONFIGURE_ARGS+= --without-certdb
CONFIGURE_ARGS+= --with-certdb=${SSLCERTS}
# Cone doesn't really need the openssl or c_rehash binaries, but the
# rootcerts/configure script is written poorly and directly overrides

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2009/06/14 18:04:30 joerg Exp $
@comment $NetBSD: PLIST,v 1.3 2010/05/18 13:24:15 adam Exp $
bin/cone
bin/leaf
bin/mailtool
@ -64,10 +64,6 @@ share/cone/cone06newaccount.html
share/cone/cone07remoteconfig.html
share/cone/cone08gpg.html
share/cone/cone09masterpassword.html
share/cone/cone10encryption.html
share/cone/cone11filters.html
share/cone/cone12addressbook.html
share/cone/cone13ldapaddressbook.html
share/cone/conn.html
share/cone/cppnamespace.html
share/cone/emailaddress.html

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.2 2008/02/20 22:31:06 jlam Exp $
$NetBSD: distinfo,v 1.3 2010/05/18 13:24:15 adam Exp $
SHA1 (cone-0.74.tar.bz2) = 74a68e8468494bb020da7f7fd4dc3abd1ef67b83
RMD160 (cone-0.74.tar.bz2) = 30a7d64d04426d975a602999db28e47caaa97e80
Size (cone-0.74.tar.bz2) = 4150864 bytes
SHA1 (cone-0.83.tar.bz2) = da1c39b75146a7cb5a30b524c12fe6a7f7d4a193
RMD160 (cone-0.83.tar.bz2) = 756d8593be400f59948e3dde0af5d072cac58b71
Size (cone-0.83.tar.bz2) = 4145506 bytes
SHA1 (patch-aa) = 379e4875619bda6d7094f906e2cba34f19d879fe
SHA1 (patch-ab) = 897bec29acdab95f679a3b95195614ae94509e29
SHA1 (patch-ab) = 2475c6644d894d1bdbf60977cdc5f96f36e72dde
SHA1 (patch-ac) = 2a6a8ad9c8cc6773b219bfbefabc11eac31f6cb3
SHA1 (patch-ad) = 578dde2e725ca4e1b332ad2e9135446534aa3184
SHA1 (patch-ae) = f11842f29aadd91aaab74dff8583d6b62c06673d

View file

@ -1,13 +1,13 @@
$NetBSD: patch-ab,v 1.1.1.1 2007/11/13 18:02:15 jlam Exp $
$NetBSD: patch-ab,v 1.2 2010/05/18 13:24:15 adam Exp $
--- curses/configure.orig Sun Jul 22 00:35:48 2007
--- curses/configure.orig 2010-03-01 03:54:55.000000000 +0000
+++ curses/configure
@@ -5846,7 +5846,7 @@ _ACEOF
@@ -6318,7 +6318,7 @@ _ACEOF
-for ac_func in glob
+for ac_func in glob mbrtowc wcrtomb
do
as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
{ echo "$as_me:$LINENO: checking for $ac_func" >&5
as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
{ $as_echo "$as_me:$LINENO: checking for $ac_func" >&5