py27-cssselect2: exclude pytest-flake8 and pytest-isort from testing
This commit is contained in:
parent
37561e5cfd
commit
b2aa9e2216
4 changed files with 38 additions and 6 deletions
textproc/py27-cssselect2
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.5 2022/08/24 08:41:09 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2022/11/30 10:19:25 adam Exp $
|
||||
|
||||
DISTNAME= cssselect2-0.2.2
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
|
@ -11,15 +11,13 @@ HOMEPAGE= https://github.com/Kozea/cssselect2
|
|||
COMMENT= CSS selectors for Python ElementTree
|
||||
LICENSE= modified-bsd
|
||||
|
||||
PYTHON_VERSIONS_ACCEPTED= 27
|
||||
|
||||
DEPENDS+= ${PYPKGPREFIX}-tinycss2-[0-9]*:../../textproc/py27-tinycss2
|
||||
TEST_DEPENDS+= ${PYPKGPREFIX}-test-cov-[0-9]*:../../devel/py27-test-cov
|
||||
TEST_DEPENDS+= ${PYPKGPREFIX}-test-flake8-[0-9]*:../../devel/py-test-flake8
|
||||
TEST_DEPENDS+= ${PYPKGPREFIX}-test-isort-[0-9]*:../../devel/py-test-isort
|
||||
TEST_DEPENDS+= ${PYPKGPREFIX}-test-runner-[0-9]*:../../devel/py-test-runner
|
||||
|
||||
USE_LANGUAGES= # none
|
||||
|
||||
PYTHON_VERSIONS_ACCEPTED= 27
|
||||
|
||||
.include "../../lang/python/egg.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,5 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.3 2021/10/26 11:23:18 nia Exp $
|
||||
$NetBSD: distinfo,v 1.4 2022/11/30 10:19:25 adam Exp $
|
||||
|
||||
BLAKE2s (cssselect2-0.2.2.tar.gz) = 157e867c8bc25673af4d357c55b37b50cdde98791e44154c52ff3013c343ca18
|
||||
SHA512 (cssselect2-0.2.2.tar.gz) = 1f11077c6e28f52a1c370c1f3d5fa1156f74b390298323889230304ede6c23a2f2b78c63026f5d84e67518a21fc8df3484577bc77fcf19cb97a84c2a7f28d355
|
||||
Size (cssselect2-0.2.2.tar.gz) = 31764 bytes
|
||||
SHA1 (patch-setup.cfg) = 6328602eed3ae9cc103f84ce842d41ad225e50a1
|
||||
SHA1 (patch-setup.py) = eef629f598e35590d09468c0fdb902e25e934c5a
|
||||
|
|
15
textproc/py27-cssselect2/patches/patch-setup.cfg
Normal file
15
textproc/py27-cssselect2/patches/patch-setup.cfg
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-setup.cfg,v 1.1 2022/11/30 10:19:25 adam Exp $
|
||||
|
||||
Do not use flake8 and isort for tests.
|
||||
|
||||
--- setup.cfg.orig 2022-11-30 09:59:23.000000000 +0000
|
||||
+++ setup.cfg
|
||||
@@ -5,7 +5,7 @@ test = pytest
|
||||
universal = 1
|
||||
|
||||
[tool:pytest]
|
||||
-addopts = --cov=cssselect2 --flake8 --isort cssselect2
|
||||
+addopts = --cov=cssselect2 cssselect2
|
||||
norecursedirs = dist .cache .git build *.egg-info .eggs venv
|
||||
|
||||
[isort]
|
17
textproc/py27-cssselect2/patches/patch-setup.py
Normal file
17
textproc/py27-cssselect2/patches/patch-setup.py
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-setup.py,v 1.1 2022/11/30 10:19:25 adam Exp $
|
||||
|
||||
Do not require pytest-flake8 and pytest-isort as PkgSrc does have Python 2.7
|
||||
versions anymore.
|
||||
|
||||
--- setup.py.orig 2022-11-30 09:57:23.000000000 +0000
|
||||
+++ setup.py
|
||||
@@ -30,7 +30,7 @@ setup(
|
||||
setup_requires=pytest_runner,
|
||||
test_suite='cssselect2.tests',
|
||||
tests_require=[
|
||||
- 'pytest-runner', 'pytest-cov', 'pytest-flake8', 'pytest-isort'],
|
||||
+ 'pytest-runner', 'pytest-cov'],
|
||||
extras_require={'test': [
|
||||
- 'pytest-runner', 'pytest-cov', 'pytest-flake8', 'pytest-isort']},
|
||||
+ 'pytest-runner', 'pytest-cov']},
|
||||
)
|
Loading…
Reference in a new issue