Convert to use buildlink.mk files and mark as USE_BUILDLINK_ONLY. Remove
the unnecessary patches that manipulated things for curses/ncurses. Add patch to remove -I$(includedir) and -L$(libdir) from the compiler flags.
This commit is contained in:
parent
dbfddb7cdc
commit
b32a7a92c8
6 changed files with 29 additions and 68 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.9 2001/04/02 20:06:11 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.10 2001/06/19 15:55:08 jlam Exp $
|
||||
|
||||
DISTNAME= aumix-2.7
|
||||
CATEGORIES= audio
|
||||
|
@ -12,22 +12,19 @@ MAINTAINER= trevor@jpj.net
|
|||
HOMEPAGE= http://jpj.net/~trevor/aumix.html
|
||||
COMMENT= Set mix levels
|
||||
|
||||
DEPENDS+= gtk+-1.2.*:../../x11/gtk
|
||||
BUILD_USES_MSGFMT= yes
|
||||
|
||||
USE_CURSES= yes
|
||||
REPLACE_NCURSES= ${WRKSRC}/configure ${WRKSRC}/src/curses.h \
|
||||
${WRKSRC}/src/gpm-xterm.h
|
||||
USE_LIBINTL= yes
|
||||
#USE_CURSES= yes
|
||||
#USE_LIBINTL= yes
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_BUILDLINK_ONLY= yes
|
||||
USE_CONFIG_WRAPPER= yes
|
||||
|
||||
CONFIGURE_ARGS= --enable-own-labels
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if ${NEED_NCURSES} == "YES"
|
||||
CFLAGS+= -I${WRKSRC}/src -I${LOCALBASE}/include
|
||||
.endif
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --enable-own-labels
|
||||
CONFIGURE_ARGS+= --enable-nls
|
||||
|
||||
.include "../../devel/gettext-lib/buildlink.mk"
|
||||
.include "../../devel/ncurses/buildlink.mk"
|
||||
.include "../../x11/gtk/buildlink.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,7 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.2 2001/04/18 13:04:18 agc Exp $
|
||||
$NetBSD: distinfo,v 1.3 2001/06/19 15:55:08 jlam Exp $
|
||||
|
||||
SHA1 (aumix-2.7.tar.gz) = 7fed58eb4d52e561dd25ad23f8f9630f6ed106a2
|
||||
Size (aumix-2.7.tar.gz) = 168586 bytes
|
||||
SHA1 (patch-aa) = b375a92d8b014c299e50ff84df5f9ec89d8d40a8
|
||||
SHA1 (patch-ab) = 76b501abba29fd5946f312d56a3ca4ec83030fde
|
||||
SHA1 (patch-ac) = 59d6a6dd7015b5f55161231946374d75b33b4536
|
||||
SHA1 (patch-ad) = fc610f71143b892b68f798e3556bc756875dd26c
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1 2001/04/05 13:50:43 wiz Exp $
|
||||
|
||||
--- src/common.h.orig Tue Jun 27 07:51:42 2000
|
||||
+++ src/common.h
|
||||
@@ -61,14 +61,14 @@
|
||||
* Our `LOCAL_TEXT(STRING)' macro stands in for gettext (STRING)' when using
|
||||
* NLS, and simply returns STRING otherwise.
|
||||
*/
|
||||
-#ifdef HAVE_NLS
|
||||
+#if 1
|
||||
#define LOCAL_TEXT(string) gettext (string)
|
||||
#ifdef gettext_noop
|
||||
#define LOCAL_TEXT_NOOP(string) gettext_noop(string)
|
||||
#else
|
||||
#define LOCAL_TEXT_NOOP(string) (string)
|
||||
#endif /* gettext_noop */
|
||||
-#ifdef HAVE_LIBINTL_H
|
||||
+#if 1
|
||||
#include <libintl.h>
|
||||
#include <locale.h>
|
||||
#endif /* HAVE_LIBINTL_H */
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1 2001/04/05 13:50:43 wiz Exp $
|
||||
|
||||
--- src/curses.h.orig Tue Jun 27 07:51:42 2000
|
||||
+++ src/curses.h
|
||||
@@ -4,7 +4,7 @@
|
||||
#include <signal.h> /* updates only needed in interactive modes */
|
||||
#define XOFFSET 0 /* blank columns to leave at the left */
|
||||
#define YOFFSET 0 /* blank lines to leave at the top */
|
||||
-#if HAVE_NCURSES_H
|
||||
+#if 1
|
||||
#include <ncurses.h>
|
||||
#else
|
||||
#include <curses.h>
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1 2001/04/05 13:50:44 wiz Exp $
|
||||
|
||||
--- src/gpm-xterm.h.orig Wed Apr 12 17:02:04 2000
|
||||
+++ src/gpm-xterm.h
|
||||
@@ -24,11 +24,7 @@
|
||||
#ifndef _GPM_XTERM_H_
|
||||
#define _GPM_XTERM_H_
|
||||
|
||||
-#ifdef HAVE_NCURSES_H
|
||||
#include <ncurses.h>
|
||||
-#else
|
||||
-#include <curses.h>
|
||||
-#endif /* HAVE_CURSES */
|
||||
|
||||
/* Xtermish stuff */
|
||||
#define GPM_XTERM_ON \
|
16
audio/aumix/patches/patch-ad
Normal file
16
audio/aumix/patches/patch-ad
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-ad,v 1.1 2001/06/19 15:55:09 jlam Exp $
|
||||
|
||||
--- src/Makefile.in.orig Tue Jun 19 06:09:52 2001
|
||||
+++ src/Makefile.in
|
||||
@@ -88,9 +88,9 @@
|
||||
aumix_SOURCES = common.c curses.c dummy.c gpm-xterm.c gtk.c interactive.c mouse.c common.h curses.h gpm-xterm.h gtk.h interactive.h mouse.h play.xpm record.xpm
|
||||
|
||||
localedir = $(datadir)/locale
|
||||
-INCLUDES = -I../intl -DLOCALEDIR=\"$(localedir)\" -I@includedir@
|
||||
+INCLUDES = -I../intl -DLOCALEDIR=\"$(localedir)\"
|
||||
CFLAGS = @CFLAGS@ @GLIB_CFLAGS@ @GTK_CFLAGS@
|
||||
-LDADD = -L@libdir@
|
||||
+LDADD =
|
||||
LIBS = @LIBS@ @GTK_LIBS@ @INTLLIBS@
|
||||
DEFS = @DEFS@
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
Loading…
Reference in a new issue