make mysql 3.23.51 compile on 1.6.x, which uses bundled mit-pthreads

fixes PR pkg/22988 by Adrian Portelli
This commit is contained in:
jdolecek 2003-09-28 15:09:48 +00:00
parent e42ecfc8c2
commit b35037fad5
4 changed files with 29 additions and 2 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.10 2003/09/28 09:03:52 jdolecek Exp $
$NetBSD: distinfo,v 1.11 2003/09/28 15:09:48 jdolecek Exp $
SHA1 (mysql-3.23.51.tar.gz) = 5833feb9ecacd9870586d20a94c4c4650f988770
Size (mysql-3.23.51.tar.gz) = 11203102 bytes
SHA1 (patch-af) = 89dc4d3761cb9f2be0afc2658b80595ceacd1643
SHA1 (patch-al) = 8d8738a168233dcf968b02c7c48c0711342ea200
SHA1 (patch-am) = b7266fdb45cce5db44aaea5bd2a869ce452933e3

View file

@ -0,0 +1,12 @@
$NetBSD: patch-am,v 1.1 2003/09/28 15:09:48 jdolecek Exp $
--- mysys/my_gethostbyname.c.orig Sun Sep 28 16:33:05 2003
+++ mysys/my_gethostbyname.c Sun Sep 28 16:33:20 2003
@@ -18,7 +18,6 @@
/* Thread safe version of gethostbyname_r() */
#include "mysys_priv.h"
-#include "my_pthread.h"
#include <assert.h>
#if !defined(MSDOS) && !defined(__WIN__)
#include <netdb.h>

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.22 2003/09/28 09:03:53 jdolecek Exp $
$NetBSD: distinfo,v 1.23 2003/09/28 15:09:48 jdolecek Exp $
SHA1 (mysql-3.23.51.tar.gz) = 5833feb9ecacd9870586d20a94c4c4650f988770
Size (mysql-3.23.51.tar.gz) = 11203102 bytes
@ -16,3 +16,4 @@ SHA1 (patch-ak) = f484f0bd5b77e0475c7b693b51f5f5146795afa0
SHA1 (patch-al) = 75b237ea28da2b44f05c0c0fb3493bba060004dc
SHA1 (patch-am) = adc14bcc3bd21e5a522e1a732ded223b641a2ac7
SHA1 (patch-an) = c42a40e8772eb4a59eacae71c416b62682ce78dd
SHA1 (patch-ao) = 39feaabdfe23d3007722001e3bda0b8967c473eb

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ao,v 1.3 2003/09/28 15:09:48 jdolecek Exp $
--- mit-pthreads/include/netdb.h.orig Sun Sep 28 16:36:39 2003
+++ mit-pthreads/include/netdb.h Sun Sep 28 16:37:20 2003
@@ -49,6 +49,8 @@
#define __NETDB_MAXALIASES 35
#define __NETDB_MAXADDRS 35
+extern int h_errno;
+
/*
* Structures returned by network data base library. All addresses are
* supplied in host order, and returned in network order (suitable for