Force pkgsrc msgfmt. Fix socket vs <functional> conflict.

This commit is contained in:
joerg 2020-03-30 19:31:19 +00:00
parent 2888946e4c
commit b36df3e632
3 changed files with 20 additions and 3 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.104 2020/03/26 12:20:01 nia Exp $
# $NetBSD: Makefile,v 1.105 2020/03/30 19:31:19 joerg Exp $
DISTNAME= dasher-5.0.0.b20200225
CATEGORIES= editors gnome
@ -16,9 +16,12 @@ GNU_CONFIGURE= yes
USE_LIBTOOL= yes
USE_LANGUAGES= c c++
USE_TOOLS+= autoreconf autoconf automake autopoint
USE_TOOLS+= autoreconf autoconf automake autopoint msgfmt
USE_TOOLS+= pkg-config
# Requires --desktop in msgfmt.
_TOOLS_USE_PKGSRC.msgfmt= yes
pre-configure:
# tries to invoke git for something, probably fetching the ref
${ECHO} "true" > ${WRKSRC}/build-aux/mkversion

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.33 2020/03/23 12:25:38 nia Exp $
$NetBSD: distinfo,v 1.34 2020/03/30 19:31:19 joerg Exp $
SHA1 (dasher-5.0.0.b20200225-e03b0dbf1f1132e83645ff78c92efd63fca5a812.tar.gz) = 327a9f268df919e9f123edc210115a6f5c089178
RMD160 (dasher-5.0.0.b20200225-e03b0dbf1f1132e83645ff78c92efd63fca5a812.tar.gz) = 2dc783e860df87fe1b5a0c6cc6b9cd2b5c6fac20
SHA512 (dasher-5.0.0.b20200225-e03b0dbf1f1132e83645ff78c92efd63fca5a812.tar.gz) = 4c21270c2608c80d9ecaddc21de9fe6fc840c7803c03b9c7d43b2844ff551df6c89031c934636ea05adaa05e5d467f32eb05ea6859a400866aeeb4d2c604868d
Size (dasher-5.0.0.b20200225-e03b0dbf1f1132e83645ff78c92efd63fca5a812.tar.gz) = 18684114 bytes
SHA1 (patch-Src_DasherCore_SocketInputBase.cpp) = 9ba2c64218fb3338a3de83292f9a0d494d753ea5

View file

@ -0,0 +1,13 @@
$NetBSD: patch-Src_DasherCore_SocketInputBase.cpp,v 1.1 2020/03/30 19:31:19 joerg Exp $
--- Src/DasherCore/SocketInputBase.cpp.orig 2020-03-30 12:56:59.535592416 +0000
+++ Src/DasherCore/SocketInputBase.cpp
@@ -112,7 +112,7 @@ bool Dasher::CSocketInputBase::StartList
name.sin_family = AF_INET;
name.sin_port = htons(port);
name.sin_addr.s_addr = htonl(INADDR_ANY);
- if(bind(sock, (struct sockaddr *)&name, sizeof(name)) < 0) {
+ if(::bind(sock, (struct sockaddr *)&name, sizeof(name)) < 0) {
ReportErrnoError(_("Error binding to socket - already in use?"));
DASHER_SOCKET_CLOSE_FUNCTION(sock);
sock = -1;