ibus-array: update to 0.2.2.

0.2.2

This release is mainly due to requested by FreeBSD community

0.2.1


Minor Updates

    Merged PR#7 Change to set python path to configured one properly
    Add a new ibus-array icon

0.1.2

Update the new short codes

Update the short code table
This commit is contained in:
wiz 2023-11-16 12:01:08 +00:00
parent e2e97ea4a6
commit b375fc6d9c
4 changed files with 14 additions and 79 deletions

View File

@ -1,36 +1,28 @@
# $NetBSD: Makefile,v 1.47 2023/11/08 13:19:45 wiz Exp $
# $NetBSD: Makefile,v 1.48 2023/11/16 12:01:08 wiz Exp $
DISTNAME= ibus-array-0.1.0
PKGREVISION= 26
DISTNAME= ibus-array-0.2.2
CATEGORIES= inputmethod chinese
MASTER_SITES= http://ibus-array.googlecode.com/svn/tarballs/
EXTRACT_SUFX= .tgz
MASTER_SITES= ${MASTER_SITE_GITHUB:=lexical/}
GITHUB_TAG= release-${PKGVERSION_NOREV}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://code.google.com/archive/p/ibus-array/
HOMEPAGE= https://github.com/lexical/ibus-array/
COMMENT= Array 30 Input Method for iBus
LICENSE= gnu-gpl-v3
DEPENDS+= ${PYPKGPREFIX}-gobject3-[0-9]*:../../devel/py-gobject32
PYTHON_VERSIONS_ACCEPTED= 27
DEPENDS+= ${PYPKGPREFIX}-gobject3-[0-9]*:../../devel/py-gobject3
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
USE_PKGLOCALEDIR= yes
USE_TOOLS+= gmake pkg-config automake autoconf autopoint msgfmt msgmerge
WRKSRC= ${WRKDIR}
USE_TOOLS+= gmake pkg-config automake autoconf autopoint autoreconf msgfmt msgmerge
PY_PATCHPLIST= yes
pre-configure:
${RUN}cd ${WRKSRC};${PKGSRC_SETENV} ${CONFIGURE_ENV} ./autogen.sh
PYTHON_VERSIONS_INCOMPATIBLE= 27
SUBST_CLASSES+= epython
SUBST_STAGE.epython= pre-configure
SUBST_FILES.epython= setup/ibus-setup-array.in
SUBST_SED.epython= -e 's;exec python;exec ${PYTHONBIN};g'
pre-configure:
${RUN}cd ${WRKSRC} && ${PKGSRC_SETENV} ${CONFIGURE_ENV} autoreconf -fiv
.include "../../databases/sqlite3/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"

View File

@ -1,7 +1,5 @@
$NetBSD: distinfo,v 1.10 2021/10/26 10:49:33 nia Exp $
$NetBSD: distinfo,v 1.11 2023/11/16 12:01:08 wiz Exp $
BLAKE2s (ibus-array-0.1.0.tgz) = 4fcec181dcc603986c64393c1166cd9d80732ceec61db1d2feee633e5170d0bd
SHA512 (ibus-array-0.1.0.tgz) = b10f60c8e8b8c7fe54ef39c32a169be6ee53b69ea008e0526ac359a253129321afa830fb2b857f3d3cd5059abba452598909a0079164a440af1520ff651435fa
Size (ibus-array-0.1.0.tgz) = 3838716 bytes
SHA1 (patch-setup_main.py) = 3f6a2dc0e93c86b5e8f1b1cbc7cae77043ad9c1a
SHA1 (patch-src_engine.c) = aa7978ae11c8e1410980585ff6f7a76200df6f99
BLAKE2s (ibus-array-0.2.2.tar.gz) = 7641e8a81fe70c92ff92b4e369f07826b4ae041d080a1443dcd4f3dca40ef2ff
SHA512 (ibus-array-0.2.2.tar.gz) = 1d65bdf830162b252f9b648658548f5d025b6ebf6aa825c0e7b264a64a4a155748594cbfbdcad5def5cfca5d98fe38d94bbd7a374c025759a04c35a36816cebb
Size (ibus-array-0.2.2.tar.gz) = 2836658 bytes

View File

@ -1,30 +0,0 @@
$NetBSD: patch-setup_main.py,v 1.1 2019/05/15 14:23:15 leot Exp $
Consistently use spaces instead of tabs to avoid Python 3 TabError-s.
--- setup/main.py.orig 2014-11-01 10:35:57.000000000 +0000
+++ setup/main.py
@@ -38,8 +38,8 @@ class Setup:
self.__create_ui()
def __create_ui(self):
- gettext.bindtextdomain("ibus-array")
- gettext.textdomain("ibus-array")
+ gettext.bindtextdomain("ibus-array")
+ gettext.textdomain("ibus-array")
self.__window = Gtk.Dialog(_('ibus-array setup'), None,
Gtk.DialogFlags.MODAL,
(Gtk.STOCK_CANCEL, Gtk.ResponseType.CANCEL,
@@ -97,9 +97,9 @@ class Setup:
self.__special_notify_button.set_active(False)
def __read(self, name, v):
- value = self.__config.get_value("engine/Array", name)
- if value is None:
- return v
+ value = self.__config.get_value("engine/Array", name)
+ if value is None:
+ return v
return value
def __write(self, name, v):

View File

@ -1,25 +0,0 @@
$NetBSD: patch-src_engine.c,v 1.5 2015/01/29 11:45:25 obache Exp $
* Fixes return type mismatch:
https://code.google.com/p/ibus-array/issues/detail?id=11
--- src/engine.c.orig 2015-01-24 16:30:52.000000000 +0000
+++ src/engine.c
@@ -67,7 +67,7 @@ static gboolean ibus_array_engine_commit
static void ibus_array_engine_space_press(IBusArrayEngine *arrayeng);
-static gboolean ibus_array_engine_update_symbol_lookup_table (IBusArrayEngine *arrayeng);
+static void ibus_array_engine_update_symbol_lookup_table (IBusArrayEngine *arrayeng);
static void ibus_array_engine_update_auxiliary_text (IBusArrayEngine *arrayeng, gchar* aux_string);
@@ -313,7 +313,7 @@ static void ibus_array_engine_update_pre
g_string_free(array_preedit, TRUE);
}
-static gboolean ibus_array_engine_update_symbol_lookup_table (IBusArrayEngine *arrayeng)
+static void ibus_array_engine_update_symbol_lookup_table (IBusArrayEngine *arrayeng)
{
gint i;
gboolean retval;