Update gkrellm to version 2.2.7.

pkgsrc changes:
  - use REQD_DIRS where appropriate
  - add a patch to allow gkrellm to read everything off sysctl() and thus
    don't install it setgid kem on NetBSD 3.99.1+
  - use options framework to choose between OpenSSL and gnutls
  - minor nits

gkrellm changes:

2.2.7 - Tue May 24, 2005
------------------------
        * gkrellmd can send a network interface connect time to be displayed
          on client timer button panels by configuring a net-timer in gkrellmd.conf.
        * Don't add virtual disk (/dev/mdX) stats to composite disk.
        * Bugfixes:
          o server/main.c inet6 compile error on machines with old libc.
          o Philipp Hartmann patch: add gnutls multithread initialization to mail.c
          o While mixing draw_decal_text and decal_scroll_text calls on transparent
            panels the text layer pixmap was not cleanup up properly.
        * Translation updates

2.2.6 - Fri May 13, 2005
------------------------
        * Stanislav Likavcan patch: add monitoring of ibm acpi sensors to linux.c.
        * UI improvement in fs.c and mail.c config button sensitivities and labels.
        * Bugfixes:
          o Test for not force creating user mailbox did not consider a configured
            mail fetch.
          o gkrellmd server mail check was missing the gkrellmd_need_serve() call
            and server/mail.c mailbox code needed syncing with src/mail.c.
          o gkrellmd glib 1.2 g_file_test compatibility was broken.
          o gkrellmd debug-level option was missing.
          o Darwin Makefile: add HAVE_GETADDRINFO=1
          o Don Bostrom patch: when remote mail checking, handle select() EINTR.
          o Charles Bailey patches:
            1) darwin.c and Makefile tweaks for building on OS X 10.3.8.
            2) darwin.c prevent left bit sign extension when shifting memory
               monitor data.
          o Don't read disabled sensors in the sensors thread.
        * Translation updates
This commit is contained in:
cube 2005-09-08 13:19:56 +00:00
parent 548c3b528c
commit b376b0a3ef
13 changed files with 217 additions and 60 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.1.1.1 2004/02/24 22:27:27 cube Exp $
# $NetBSD: Makefile,v 1.2 2005/09/08 13:19:56 cube Exp $
.include "../../sysutils/gkrellm/Makefile.common"
GKRELLM_PKGBASE= gkrellm-share
@ -9,8 +9,9 @@ BUILD_USES_MSGFMT= YES
MAKE_ENV+= MODULES=po
INSTALLATION_DIRS= share/gkrellm2
post-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/gkrellm2
${INSTALL_DATA} ${GKRELLM_SRCDIR}/README ${GKRELLM_SRCDIR}/COPYRIGHT ${PREFIX}/share/gkrellm2
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.44 2005/08/10 20:56:23 jlam Exp $
# $NetBSD: Makefile,v 1.45 2005/09/08 13:19:56 cube Exp $
.include "Makefile.common"
PKGREVISION= # empty1
@ -15,27 +15,30 @@ USE_TOOLS+= pkg-config
.include "../../mk/bsd.prefs.mk"
.if (${OPSYS} == "FreeBSD" || ${OPSYS} == "OpenBSD" || ${OPSYS} == "NetBSD")
# NetBSD 3.99.1 and above don't have to be installed setgid.
.if (${OPSYS} == "FreeBSD" || ${OPSYS} == "OpenBSD" || \
(${OPSYS} == "NetBSD" && (!empty(OS_VERSION:M[123]*) && empty(OS_VERSION:M3.99.*))))
SPECIAL_PERMS+= ${PREFIX}/bin/gkrellm ${ROOT_USER} kmem 2711
.endif
NOT_FOR_PLATFORM= IRIX-*
.include "options.mk"
MAKE_ENV+= MODULES=src LINK_FLAGS=${EXPORT_SYMBOLS_LDFLAGS}
MAKE_ENV+= BINOWNER=${BINOWN} BINGROUP=${BINGRP}
MAKE_ENV+= SSL_TYPE=${GKRELLM_SSL_TYPE}
MAKE_ENV+= PKG_INCLUDE=-I${BUILDLINK_PREFIX.${GKRELLM_SSL_TYPE}}/include
MAKE_ENV+= PKG_LIBS="-L${BUILDLINK_PREFIX.${GKRELLM_SSL_TYPE}}/lib -Wl,-R${BUILDLINK_PREFIX.${GKRELLM_SSL_TYPE}}/lib"
SUBST_STAGE.gkprefix= post-patch
SUBST_FILES.gkprefix= src/gkrellm.h
SUBST_SED.gkprefix= -e '/SYSTEM_/{s!/usr!${PREFIX}!;}'
SUBST_CLASSES+= gkprefix
post-install:
${INSTALL_DATA_DIR} ${PREFIX}/lib/gkrellm2
${INSTALL_DATA_DIR} ${PREFIX}/lib/gkrellm2/plugins
${INSTALL_DATA_DIR} ${PREFIX}/share/gkrellm2/themes
REQD_DIRS= lib/gkrellm2/plugins lib/gkrellm2 include/gkrellm2
.include "../../x11/gtk2/buildlink3.mk"
.include "../../devel/glib2/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.11 2005/05/22 20:08:32 jlam Exp $
# $NetBSD: Makefile.common,v 1.12 2005/09/08 13:19:56 cube Exp $
DISTNAME= ${GKRELLM_DISTBASE}
PKGNAME= ${GKRELLM_PKGBASE}-${GKRELLM_VERSION}
@ -15,12 +15,13 @@ USE_TOOLS+= gmake
USE_PKGLOCALEDIR= YES
MAKE_ENV+= LOCALEDIR=${PREFIX}/${PKGLOCALEDIR}/locale
MAKE_ENV+= GREP=${GREP}
.if defined(GKRELLM_DEBUG)
MAKE_ENV+= DEBUG=yes
.endif
GKRELLM_VERSION= 2.2.5
GKRELLM_VERSION= 2.2.7
GKRELLM_DISTBASE= gkrellm-${GKRELLM_VERSION}
GKRELLM_SRCDIR= ${WRKDIR}/${GKRELLM_DISTBASE}

View file

@ -1,13 +1,6 @@
@comment $NetBSD: PLIST,v 1.10 2005/07/06 17:00:12 cube Exp $
@comment $NetBSD: PLIST,v 1.11 2005/09/08 13:19:56 cube Exp $
bin/gkrellm
include/gkrellm2/gkrellm.h
include/gkrellm2/gkrellm-public-proto.h
lib/pkgconfig/gkrellm.pc
man/man1/gkrellm.1
@unexec ${RMDIR} %D/include/gkrellm2 2>/dev/null || ${TRUE}
@exec ${MKDIR} %D/lib/gkrellm2 || ${TRUE}
@exec ${MKDIR} %D/lib/gkrellm2/plugins || ${TRUE}
@dirrm lib/gkrellm2/plugins
@dirrm lib/gkrellm2
@exec ${MKDIR} %D/share/gkrellm2/themes || ${TRUE}
@dirrm share/gkrellm2/themes

View file

@ -1,12 +1,12 @@
$NetBSD: distinfo,v 1.33 2005/09/06 08:10:59 abs Exp $
$NetBSD: distinfo,v 1.34 2005/09/08 13:19:56 cube Exp $
SHA1 (gkrellm-2.2.5.tar.bz2) = 4cbdf75828b3d8b216694c2e6978c29a4920595a
RMD160 (gkrellm-2.2.5.tar.bz2) = 7755fa7bbf88dfd53185e76604981b2a5c81d74d
Size (gkrellm-2.2.5.tar.bz2) = 668581 bytes
SHA1 (gkrellm-2.2.7.tar.bz2) = a6910b6f843868b4d801f7f7873e1e85c4f2039c
RMD160 (gkrellm-2.2.7.tar.bz2) = 5388e3fba604a7c4b99a9c134ab6526296fe70d8
Size (gkrellm-2.2.7.tar.bz2) = 673728 bytes
SHA1 (patch-aa) = 9dbffbc0bc95ea3fced7162da0ec55333396d256
SHA1 (patch-ab) = de2ef6e1d083a32c274d2ec42fa1b9e9d3d65663
SHA1 (patch-ab) = 015ed1c6b4d07d2da6aeefab2b746bff3fa1a88e
SHA1 (patch-ac) = 8890d5a5e8eaf21508a1bf91de788183fd6f7a75
SHA1 (patch-ad) = c33319783a40ad64f43015200047656efc1bcdb3
SHA1 (patch-ad) = 18218e5e9e7a8cfaabb20ec03865670ae66a15bd
SHA1 (patch-ae) = 5f7b1bdfa99bcec9cfdaee3a97b38b27581dd954
SHA1 (patch-ag) = 6791436e17fccd7265cda8b4e3da229c4937c20f
SHA1 (patch-ah) = 2018be5c2dd11c22c6d3f7c7fc8607e2c63123f3
@ -18,5 +18,6 @@ SHA1 (patch-am) = bf8b01f5e368a5387f8d224ca51ec18a74410b5c
SHA1 (patch-an) = 1e63ce0e4fbe9bd22c46d00c6aeac6b3e7cda440
SHA1 (patch-ao) = 63bf8657fa7707def41b13b3cc74c031098e070a
SHA1 (patch-ap) = b3c89911085e73b8651e35f71b9561046b3cd073
SHA1 (patch-aq) = 4cdf043e8cdabd8482705c80b9c06b416454b658
SHA1 (patch-ar) = 8d672b33875186791dee2bfeea4d6cf10c3ee33c
SHA1 (patch-aq) = 0799e334333ae072a40cdcb6ccd04ed6a2f52765
SHA1 (patch-ar) = eae37435d69b277f2542ee5ff26cbc772272689b
SHA1 (patch-as) = 3df33e28754cf1fee88717b431726bf090c15f70

View file

@ -21,33 +21,48 @@ ifeq ($(ENABLE_NLS),yes)
FLAGS += -DENABLE_NLS -DLOCALEDIR=\"$(LOCALEDIR)\"
endif
ifneq ($(PACKAGE),gkrellm)
FLAGS += -DPACKAGE=\"$(PACKAGE)\"
FLAGS += -DPACKAGE=\"$(PACKAGE)\"
endif
ifeq ($(HAVE_GETADDRINFO),1)
FLAGS += -DHAVE_GETADDRINFO
endif
WITHOUT_SSL?= no
SSL_TYPE?= gnutls openssl
ifeq ($(without-gnutls),1)
SSL_TYPE= $(filter-out gnutls, $(SSL_TYPE))
endif
ifeq ($(without-gnutls),yes)
SSL_TYPE= $(filter-out gnutls, $(SSL_TYPE))
endif
ifeq ($(without-ssl),1)
WITHOUT_SSL= yes
SSL_TYPE= $(filter-out openssl, $(SSL_TYPE))
endif
ifeq ($(without-ssl),yes)
WITHOUT_SSL= yes
SSL_TYPE= $(filter-out openssl, $(SSL_TYPE))
endif
ifeq ($(WITHOUT_SSL),yes)
CONFIGURE_ARGS+= --without-ssl
ifeq ($(filter gnutls, $(SSL_TYPE)),)
CONFIGURE_ARGS+= --without-gnutls
endif
ifeq ($(filter openssl, $(SSL_TYPE)),)
CONFIGURE_ARGS+= --without-openssl
endif
GREP?= grep
DUMMY_VAR:= $(shell ./configure $(CONFIGURE_ARGS))
HAVE_GNUTLS= $(shell $(GREP) -c HAVE_GNUTLS configure.h)
HAVE_SSL= $(shell $(GREP) -c HAVE_SSL configure.h)
ifeq ($(HAVE_GNUTLS),1)
SSL_LIBS?= -lgnutls-openssl
else
ifeq ($(HAVE_SSL),1)
SSL_LIBS?= -lssl -lcrypto
NEED_MD5= no
MD5_LIBS=
endif
endif
LIBS = $(PKG_LIB) $(GTOP_LIBS) $(SMC_LIBS) $(SYS_LIBS) $(MD5_LIBS) $(SSL_LIBS)

View file

@ -1,4 +1,4 @@
VERSION= 2.2.5
VERSION= 2.2.7
# Path options
PREFIX?= /usr/local
@ -100,7 +100,8 @@ LINK_FLAGS+= -prebind -Wl,-bind_at_load -framework CoreFoundation -lX11
GTK_CONFIG= gtk-config
STRIP=
NEED_MD5= no
MD5_LIBS= -lmd5
MD5_LIBS=
HAVE_GETADDRINFO= 1
ifeq ($(MODULE),src)
LINK_FLAGS+= -lX11
endif

View file

@ -0,0 +1,19 @@
# $NetBSD: options.mk,v 1.1 2005/09/08 13:19:56 cube Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.${GKRELLM_PKGBASE}
PKG_OPTIONS_REQUIRED_GROUPS= tls
PKG_OPTIONS_GROUP.tls= gnutls ssl
PKG_SUGGESTED_OPTIONS= ssl
.include "../../mk/bsd.options.mk"
.if !empty(PKG_OPTIONS:Mssl)
.include "../../security/openssl/buildlink3.mk"
GKRELLM_SSL_TYPE= openssl
.endif
.if !empty(PKG_OPTIONS:Mgnutls)
.include "../../security/gnutls/buildlink3.mk"
GKRELLM_SSL_TYPE= gnutls
.endif

View file

@ -1,6 +1,6 @@
$NetBSD: patch-ab,v 1.13 2004/07/05 08:42:27 cube Exp $
$NetBSD: patch-ab,v 1.14 2005/09/08 13:19:56 cube Exp $
--- src/sysdeps/netbsd.c.orig 2004-05-01 19:46:38.000000000 +0200
--- src/sysdeps/netbsd.c.orig 2005-05-24 05:45:10.000000000 +0200
+++ src/sysdeps/netbsd.c
@@ -63,7 +63,8 @@ gkrellm_sys_cpu_read_data(void)
{
@ -82,7 +82,7 @@ $NetBSD: patch-ab,v 1.13 2004/07/05 08:42:27 cube Exp $
if (getloadavg(&avenrun, 1) <= 0)
avenrun = 0;
gkrellm_proc_assign_data(n_processes, 0, n_forks, avenrun);
@@ -183,6 +178,97 @@ gkrellm_sys_proc_init(void)
@@ -183,6 +178,96 @@ gkrellm_sys_proc_init(void)
/* ===================================================================== */
@ -91,7 +91,6 @@ $NetBSD: patch-ab,v 1.13 2004/07/05 08:42:27 cube Exp $
+#include <sys/vmmeter.h>
+#include <sys/sysctl.h>
+#include <uvm/uvm_extern.h>
+#include <kvm.h>
+
+
+void
@ -180,7 +179,7 @@ $NetBSD: patch-ab,v 1.13 2004/07/05 08:42:27 cube Exp $
/* Sensor monitor interface */
/* Tables of voltage correction factors and offsets derived from the
@@ -295,7 +381,7 @@ gkrellm_sys_sensors_init(void)
@@ -295,7 +380,7 @@ gkrellm_sys_sensors_init(void)
int fd; /* file desc. for /dev/sysmon */
int id = 0; /* incremented for each sensor */
int type;
@ -189,7 +188,7 @@ $NetBSD: patch-ab,v 1.13 2004/07/05 08:42:27 cube Exp $
gboolean found_sensors = FALSE;
/* check if some sensor is configured */
@@ -336,3 +422,68 @@ gkrellm_sys_sensors_init(void)
@@ -336,3 +421,149 @@ gkrellm_sys_sensors_init(void)
return found_sensors;
}
@ -240,7 +239,7 @@ $NetBSD: patch-ab,v 1.13 2004/07/05 08:42:27 cube Exp $
+ wbytes = 0;
+#endif
+
+ gkrellm_disk_assign_data_by_name(dk_drives[i].dk_name, rbytes, wbytes);
+ gkrellm_disk_assign_data_by_name(dk_drives[i].dk_name, rbytes, wbytes, FALSE);
+ }
+
+ free(dk_drives);
@ -258,3 +257,84 @@ $NetBSD: patch-ab,v 1.13 2004/07/05 08:42:27 cube Exp $
+ {
+ return -1; /* append disk charts as added */
+ }
+
+#if __NetBSD_Version__ >= 399000100
+
+#include "../inet.h"
+
+#include <errno.h>
+#include <sys/socket.h>
+#include <netinet/in.h>
+#include <netinet/tcp_fsm.h>
+
+static const struct gkrellm_inet_fam {
+ sa_family_t family;
+ const char *mib;
+} families[] = { {AF_INET, "net.inet.tcp.pcblist"},
+#ifdef INET6
+ {AF_INET6, "net.inet6.tcp6.pcblist"},
+#endif
+ {0, NULL} };
+
+void
+gkrellm_sys_inet_read_tcp_data()
+{
+ ActiveTCP tcp;
+ int mib[CTL_MAXNAME], i;
+ size_t sz;
+ u_int namelen;
+ struct kinfo_pcb *pcbt = NULL;
+ const struct gkrellm_inet_fam *pf = families;
+
+ while (pf->mib != NULL) {
+ sz = CTL_MAXNAME;
+ if (sysctlnametomib(pf->mib, mib, &sz) == -1)
+ return;
+ namelen = sz;
+
+ mib[namelen++] = PCB_ALL;
+ mib[namelen++] = 0;
+ mib[namelen++] = sizeof(struct kinfo_pcb);
+ mib[namelen++] = INT_MAX;
+
+ sz = 0;
+ pcbt = NULL;
+ if (sysctl(&mib[0], namelen, pcbt, &sz, NULL, 0) == -1)
+ return;
+ pcbt = malloc(sz);
+ if (pcbt == NULL)
+ return;
+ if (sysctl(&mib[0], namelen, pcbt, &sz, NULL, 0) == -1)
+ return;
+
+ sz /= sizeof(struct kinfo_pcb);
+ for (i = 0; i < sz; i++) {
+ tcp.family = pf->family;
+ if (pf->family == AF_INET) {
+ struct sockaddr_in *sin =
+ (struct sockaddr_in *)&pcbt[i].ki_dst;
+ tcp.remote_addr.s_addr = sin->sin_addr.s_addr;
+ tcp.remote_port = sin->sin_port;
+
+ sin = (struct sockaddr_in *)&pcbt[i].ki_src;
+ tcp.local_port = sin->sin_port;
+#ifdef INET6
+ } else { /* AF_INET6 */
+ struct sockaddr_in6 *sin =
+ (struct sockaddr_in6 *)&pcbt[i].ki_dst;
+ memcpy(&tcp.remote_addr6, &sin->sin6_addr,
+ sizeof(struct in6_addr));
+ tcp.remote_port = sin->sin6_port;
+
+ sin = (struct sockaddr_in6 *)&pcbt[i].ki_src;
+ tcp.local_port = sin->sin6_port;
+#endif
+ }
+ if (pcbt[i].ki_tstate == TCPS_ESTABLISHED)
+ gkrellm_inet_log_tcp_port_data(&tcp);
+ }
+ free(pcbt);
+ pf++;
+ }
+}
+#endif

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ad,v 1.1 2004/06/07 17:01:50 cube Exp $
$NetBSD: patch-ad,v 1.2 2005/09/08 13:19:56 cube Exp $
--- src/sysdeps/bsd-net-open.c.orig 2004-05-01 19:46:38.000000000 +0200
--- src/sysdeps/bsd-net-open.c.orig 2005-05-24 05:44:48.000000000 +0200
+++ src/sysdeps/bsd-net-open.c
@@ -23,108 +23,6 @@
@@ -23,110 +23,10 @@
/* ===================================================================== */
@ -76,7 +76,7 @@ $NetBSD: patch-ad,v 1.1 2004/06/07 17:01:50 cube Exp $
- wbytes = 0;
-#endif
-
- gkrellm_disk_assign_data_by_name(buf, rbytes, wbytes);
- gkrellm_disk_assign_data_by_name(buf, rbytes, wbytes, FALSE);
- }
- }
-}
@ -110,8 +110,20 @@ $NetBSD: patch-ad,v 1.1 2004/06/07 17:01:50 cube Exp $
-/* ===================================================================== */
/* Inet monitor interface */
+#if defined(__OpenBSD__) || ( defined(__NetBSD__) && __NetBSD_Version__ < 399000100 )
+
#include "../inet.h"
@@ -199,95 +97,6 @@ gkrellm_sys_inet_init(void)
/* NO IPv6 SUPPORT YET */
@@ -191,6 +91,7 @@ gkrellm_sys_inet_read_tcp_data(void)
next = (struct inpcb *)inpcb.inp_queue.cqe_next;
}
}
+#endif
gboolean
gkrellm_sys_inet_init(void)
@@ -199,95 +100,6 @@ gkrellm_sys_inet_init(void)
}
/* ===================================================================== */

View file

@ -1,8 +1,20 @@
$NetBSD: patch-aq,v 1.1 2005/03/30 15:26:43 cube Exp $
$NetBSD: patch-aq,v 1.2 2005/09/08 13:19:56 cube Exp $
--- server/main.c.orig 2005-03-11 16:03:54.000000000 +0100
--- server/main.c.orig 2005-05-24 05:46:38.000000000 +0200
+++ server/main.c
@@ -1051,7 +1051,7 @@ main(gint argc, gchar **argv)
@@ -203,7 +203,10 @@ cidr_match(struct sockaddr *sa, socklen_
char *p, *ep;
guchar *addr, *pat;
u_int32_t mask;
- int plen, i;
+ int plen;
+#if defined(INET6)
+ int i;
+#endif
gboolean result;
buf = g_strdup(allowed);
@@ -1062,7 +1065,7 @@ main(gint argc, gchar **argv)
{
client_fd = accept(server_fd,
(struct sockaddr *) &client_addr,

View file

@ -1,21 +1,26 @@
$NetBSD: patch-ar,v 1.1 2005/03/30 15:26:43 cube Exp $
$NetBSD: patch-ar,v 1.2 2005/09/08 13:19:56 cube Exp $
--- server/monitor.c.orig 2005-03-09 17:25:01.000000000 +0100
--- server/monitor.c.orig 2005-05-24 06:29:32.000000000 +0200
+++ server/monitor.c
@@ -550,10 +550,10 @@ serve_disk_data(GkrellmdMonitor *mon, gb
if (!disk->changed && !first_serve)
continue;
@@ -555,14 +555,14 @@ serve_disk_data(GkrellmdMonitor *mon, gb
if (!disk->subdisk_parent)
- snprintf(buf, sizeof(buf), "%s %llu %llu\n",
+ snprintf(buf, sizeof(buf), "%s %" PRIu64 " %" PRIu64 "\n",
disk->name, disk->rb, disk->wb);
{
if (gkrellmd_check_client_version(mon, 2, 2, 7) && disk->virtual)
- snprintf(buf, sizeof(buf), "%s virtual %llu %llu\n",
+ snprintf(buf, sizeof(buf), "%s virtual %" PRIu64 " %" PRIu64 "\n",
disk->name, disk->rb, disk->wb);
else
- snprintf(buf, sizeof(buf), "%s %llu %llu\n",
+ snprintf(buf, sizeof(buf), "%s %" PRIu64 " %" PRIu64 "\n",
disk->name, disk->rb, disk->wb);
}
else if (mon->privat->client->feature_subdisk)
- snprintf(buf, sizeof(buf), "%s %s %llu %llu\n",
+ snprintf(buf, sizeof(buf), "%s %s %" PRIu64 " %" PRIu64 "\n",
disk->name, disk->subdisk_parent, disk->rb, disk->wb);
else
continue;
@@ -1134,7 +1134,7 @@ serve_mem_data(GkrellmdMonitor *mon, gbo
@@ -1233,7 +1233,7 @@ serve_mem_data(GkrellmdMonitor *mon, gbo
if (mem.mem_changed || first_serve)
{
gkrellmd_set_serve_name(mon, "mem");
@ -24,7 +29,7 @@ $NetBSD: patch-ar,v 1.1 2005/03/30 15:26:43 cube Exp $
mem.total, mem.used, mem.free,
mem.shared, mem.buffers, mem.cached);
gkrellmd_serve_data(mon, buf);
@@ -1143,7 +1143,7 @@ serve_mem_data(GkrellmdMonitor *mon, gbo
@@ -1242,7 +1242,7 @@ serve_mem_data(GkrellmdMonitor *mon, gbo
if (mem.swap_changed || first_serve)
{
gkrellmd_set_serve_name(mon, "swap");

View file

@ -0,0 +1,14 @@
$NetBSD: patch-as,v 1.1 2005/09/08 13:19:56 cube Exp $
--- src/configure.orig 2005-05-24 05:27:10.000000000 +0200
+++ src/configure
@@ -17,9 +17,6 @@ do
fi
done
-PKG_INCLUDE=`pkg-config gtk+-2.0 --cflags`
-PKG_LIB=`pkg-config gtk+-2.0 --libs`
-
rm -f configure.h configure.log test test.o test.c
touch configure.h