fdupes: update to 2.0.0.

Changes from 1.6.1 to 2.0.0:

    Add ncurses mode for interactive file deletion (plain mode still available via --plain or ./configure).
    Add --minsize option.
    Add --maxsize option.
    Add --time option.
    Add --order=ctime option.
    Add --log option.
    Use configure script for installation (Autotools/Automake).



Changes from version 1.6.0 to 1.6.1:

    Fix 'invalid option' error for -I.




Changes from 1.51 to 1.6.0:

    Add --nohidden option.
    Add --permissions option.
    Add --order option.
    Add --reverse option.
    Add --immediate option.
    Speed up file comparison.
    Fix bug where fdupes fails to consistently ignore hardlinks, depending on
    file processing order, when F_CONSIDERHARDLINKS flag is not set.
    Fix bug in is_hardlink(): Proper traversal of duplicates is done via
    dupe->duplicates, not via dupe->next.
    Revise md5.c to compile under OSX.
    Remove EXTERNAL_MD5 configuration option.
    Various other changes (see git log).
This commit is contained in:
wiz 2020-04-03 22:11:48 +00:00
parent ae04c11e7b
commit b3a6e1dc83
5 changed files with 13 additions and 116 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.5 2020/04/03 22:06:17 wiz Exp $
# $NetBSD: Makefile,v 1.6 2020/04/03 22:11:48 wiz Exp $
DISTNAME= fdupes-1.51
PKGREVISION= 1
DISTNAME= fdupes-2.0.0
CATEGORIES= sysutils
MASTER_SITES= http://fdupes.googlecode.com/files/
MASTER_SITES= ${MASTER_SITE_GITHUB:=adrianlopezroche/}
GITHUB_RELEASE= ${PKGVERSION_NOREV}
MAINTAINER= ef@math.uni-bonn.de
HOMEPAGE= http://netdial.caribe.net/~adrian2/fdupes.html
@ -11,10 +11,7 @@ COMMENT= Program for identifying or deleting duplicate files
LICENSE= mit
USE_LANGUAGES= c
NO_CONFIGURE= yes
MAKE_FLAGS= INSTALLDIR=${PREFIX}/bin
INSTALLATION_DIRS= bin ${PKGMANDIR}/man1
GNU_CONFIGURE= yes
.include "../../devel/pcre2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,3 +1,4 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2008/12/17 11:56:26 obache Exp $
@comment $NetBSD: PLIST,v 1.2 2020/04/03 22:11:48 wiz Exp $
bin/fdupes
man/man1/fdupes.1
man/man7/fdupes-help.7

View file

@ -1,8 +1,6 @@
$NetBSD: distinfo,v 1.5 2020/04/03 22:06:17 wiz Exp $
$NetBSD: distinfo,v 1.6 2020/04/03 22:11:48 wiz Exp $
SHA1 (fdupes-1.51.tar.gz) = 8276b39026f57a2f9503d7af18efca0a7d42b8ec
RMD160 (fdupes-1.51.tar.gz) = cf2c3524a2f827c50ce2ef257d3d7f9b75951c48
SHA512 (fdupes-1.51.tar.gz) = 7cbc414f25427793317667b8d5494f7247a08ba402855929de77d1db01eb3dce41ea608f8dcca047c4a7856e02b10261982cf2acd7f6a79ab726b3009c710a8d
Size (fdupes-1.51.tar.gz) = 48942 bytes
SHA1 (patch-aa) = 925d3c4923fe1d784273b292ef3be0a36371a9f2
SHA1 (patch-ac) = d04133bbb697d79019383f31d3ee252fc7f32db2
SHA1 (fdupes-2.0.0.tar.gz) = dde93a7937e23fa07cf1e166eb5a0431f7eaedd8
RMD160 (fdupes-2.0.0.tar.gz) = c89ef1afaa08ab8a11f39a63606985cdc34b098c
SHA512 (fdupes-2.0.0.tar.gz) = 3c76cfba1cc650f6e680933cda6236e2110018d8a6a132e146d0d61c8f44cac5944e9966b1f3de5847aca6f233ab4df9b180888e0f4b3e3fa5ae8c5f9cb1484f
Size (fdupes-2.0.0.tar.gz) = 137705 bytes

View file

@ -1,37 +0,0 @@
$NetBSD: patch-aa,v 1.2 2015/12/12 04:00:30 kamil Exp $
Add casts to silence printf errors.
Do not overwrite stdin.
--- fdupes.c.orig 2013-04-20 18:02:18.000000000 +0000
+++ fdupes.c
@@ -643,7 +643,7 @@ void printmatches(file_t *files)
while (files != NULL) {
if (files->hasdupes) {
if (!ISFLAG(flags, F_OMITFIRST)) {
- if (ISFLAG(flags, F_SHOWSIZE)) printf("%lld byte%seach:\n", files->size,
+ if (ISFLAG(flags, F_SHOWSIZE)) printf("%lld byte%seach:\n", (long long)files->size,
(files->size != 1) ? "s " : " ");
if (ISFLAG(flags, F_DSAMELINE)) escapefilename("\\ ", &files->d_name);
printf("%s%c", files->d_name, ISFLAG(flags, F_DSAMELINE)?' ':'\n');
@@ -796,7 +796,7 @@ void deletefiles(file_t *files, int prom
do {
printf("Set %d of %d, preserve files [1 - %d, all]",
curgroup, groups, counter);
- if (ISFLAG(flags, F_SHOWSIZE)) printf(" (%lld byte%seach)", files->size,
+ if (ISFLAG(flags, F_SHOWSIZE)) printf(" (%lld byte%seach)", (long long)files->size,
(files->size != 1) ? "s " : " ");
printf(": ");
fflush(stdout);
@@ -1164,8 +1164,9 @@ int main(int argc, char **argv) {
}
else
{
- stdin = freopen("/dev/tty", "r", stdin);
- deletefiles(files, 1, stdin);
+ FILE* fd;
+ fd = freopen("/dev/tty", "r", stdin);
+ deletefiles(files, 1, fd);
}
}

View file

@ -1,62 +0,0 @@
$NetBSD: patch-ac,v 1.4 2020/04/03 22:06:17 wiz Exp $
Fix various target paths.
Add a rule in order not to depend on gmake.
Honor CFLAGS and LDFLAGS.
--- Makefile.orig 2013-04-20 17:51:58.000000000 +0000
+++ Makefile
@@ -11,7 +11,7 @@
# determination of the actual installation directories.
# Suggested values are "/usr/local", "/usr", "/pkgs/fdupes-$(VERSION)"
#
-PREFIX = /usr/local
+PREFIX ?= /usr/local
#
# When compiling for 32-bit systems, FILEOFFSET_64BIT must be enabled
@@ -50,13 +50,13 @@ PROGRAM_NAME=fdupes
# BIN_DIR indicates directory where program is to be installed.
# Suggested value is "$(PREFIX)/bin"
#
-BIN_DIR = $(PREFIX)/bin
+BIN_DIR = $(DESTDIR)$(PREFIX)/bin
#
# MAN_DIR indicates directory where the fdupes man page is to be
# installed. Suggested value is "$(PREFIX)/man/man1"
#
-MAN_BASE_DIR = $(PREFIX)/man
+MAN_BASE_DIR = $(DESTDIR)$(PREFIX)/${PKGMANDIR}
MAN_DIR = $(MAN_BASE_DIR)/man1
MAN_EXT = 1
@@ -80,7 +80,7 @@ MKDIR = mkdir -p
CC = gcc
COMPILER_OPTIONS = -Wall -O -g
-CFLAGS= $(COMPILER_OPTIONS) -I. -DVERSION=\"$(VERSION)\" $(EXTERNAL_MD5) $(OMIT_GETOPT_LONG) $(FILEOFFSET_64BIT)
+CFLAGS+= $(COMPILER_OPTIONS) -I. -DVERSION=\"$(VERSION)\" $(EXTERNAL_MD5) $(OMIT_GETOPT_LONG) $(FILEOFFSET_64BIT)
INSTALL_PROGRAM = $(INSTALL) -c -m 0755
INSTALL_DATA = $(INSTALL) -c -m 0644
@@ -91,7 +91,9 @@ INSTALL_DATA = $(INSTALL) -c -m 0644
#
#ADDITIONAL_OBJECTS = getopt.o
-OBJECT_FILES = fdupes.o md5/md5.o $(ADDITIONAL_OBJECTS)
+OBJECT_FILES = fdupes.o md5.o $(ADDITIONAL_OBJECTS)
+
+md5.o: md5/md5.c
#####################################################################
# no need to modify anything beyond this point #
@@ -100,7 +102,7 @@ OBJECT_FILES = fdupes.o md5/md5.o $(ADDI
all: fdupes
fdupes: $(OBJECT_FILES)
- $(CC) $(CFLAGS) -o fdupes $(OBJECT_FILES)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o fdupes $(OBJECT_FILES)
installdirs:
test -d $(BIN_DIR) || $(MKDIR) $(BIN_DIR)