audio/moss + dependencies: remove
Upstream is discontinued and this is the last package to depend on on the also obsolete python 2.7 only audio/py-ogg and audio/py-vorbis, will allow to remove them. Newer python bindings for OGG Vorbis can be found here: https://github.com/TeamPyOgg/PyOgg
This commit is contained in:
parent
15e2a8221b
commit
b3da553249
17 changed files with 1 additions and 335 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.653 2022/04/06 16:32:21 nia Exp $
|
||||
# $NetBSD: Makefile,v 1.654 2022/04/24 00:20:01 tnn Exp $
|
||||
#
|
||||
|
||||
COMMENT= Audio tools, players, and libraries
|
||||
|
@ -316,7 +316,6 @@ SUBDIR+= mixxx
|
|||
SUBDIR+= mkcdtoc
|
||||
SUBDIR+= moc
|
||||
SUBDIR+= moodbar
|
||||
SUBDIR+= moss
|
||||
SUBDIR+= mp32ogg
|
||||
SUBDIR+= mp3_check
|
||||
SUBDIR+= mp3asm
|
||||
|
@ -420,9 +419,7 @@ SUBDIR+= py-music21
|
|||
SUBDIR+= py-musicbrainz-ngs
|
||||
SUBDIR+= py-musique
|
||||
SUBDIR+= py-mutagen
|
||||
SUBDIR+= py-ogg
|
||||
SUBDIR+= py-soundfile
|
||||
SUBDIR+= py-vorbis
|
||||
SUBDIR+= qjackctl
|
||||
SUBDIR+= qmmp
|
||||
SUBDIR+= qsynth
|
||||
|
|
|
@ -1,3 +0,0 @@
|
|||
MOSS (MP3/OGG Streaming Server) is an HTTP-based streaming server
|
||||
written in Python. It supports the web mode where you browse and
|
||||
select songs, and the live mode which supports real-time broadcast.
|
|
@ -1,37 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.37 2022/02/28 10:06:34 wiz Exp $
|
||||
|
||||
DISTNAME= moss-0.1.13
|
||||
PKGREVISION= 9
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://kldp.net/frs/download.php/1580/
|
||||
|
||||
MAINTAINER= myunggoni@users.kldp.net
|
||||
HOMEPAGE= https://moss.kldp.net/
|
||||
COMMENT= MP3/OGG Streaming Server
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
DEPENDS+= ${PYPKGPREFIX}-ogg>=1.3:../../audio/py-ogg
|
||||
DEPENDS+= ${PYPKGPREFIX}-vorbis>=1.3:../../audio/py-vorbis
|
||||
|
||||
PYTHON_VERSIONS_ACCEPTED= 27 # py-ogg, py-vorbis
|
||||
|
||||
REPLACE_PYTHON= *.py
|
||||
|
||||
RCD_SCRIPTS= moss
|
||||
CONF_FILES= ${PREFIX}/share/moss/moss.conf.sample \
|
||||
${PKG_SYSCONFDIR}/moss.conf
|
||||
|
||||
BUILD_DEFS+= VARBASE
|
||||
|
||||
SUBST_CLASSES+= path
|
||||
SUBST_MESSAGE.path= Fixing hardcoded paths.
|
||||
SUBST_STAGE.path= pre-configure
|
||||
SUBST_FILES.path= moss.conf.sample
|
||||
SUBST_SED.path= -e 's,$${PREFIX}/var,${VARBASE},g'
|
||||
SUBST_SED.path+= -e 's,$${PREFIX}/share,${PREFIX}/share,g'
|
||||
|
||||
FILES_SUBST+= INTERPRETER=${PYTHONBIN:Q}
|
||||
|
||||
.include "../../lang/python/egg.mk"
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,35 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.7 2022/02/28 10:06:34 wiz Exp $
|
||||
bin/moss
|
||||
${PYSITELIB}/${EGG_INFODIR}
|
||||
${PYSITELIB}/moss/__init__.py
|
||||
${PYSITELIB}/moss/__init__.pyc
|
||||
${PYSITELIB}/moss/__init__.pyo
|
||||
${PYSITELIB}/moss/fileinfo.py
|
||||
${PYSITELIB}/moss/fileinfo.pyc
|
||||
${PYSITELIB}/moss/fileinfo.pyo
|
||||
${PYSITELIB}/moss/htmltmpl.py
|
||||
${PYSITELIB}/moss/htmltmpl.pyc
|
||||
${PYSITELIB}/moss/htmltmpl.pyo
|
||||
${PYSITELIB}/moss/live.py
|
||||
${PYSITELIB}/moss/live.pyc
|
||||
${PYSITELIB}/moss/live.pyo
|
||||
${PYSITELIB}/moss/mkpasswd.py
|
||||
${PYSITELIB}/moss/mkpasswd.pyc
|
||||
${PYSITELIB}/moss/mkpasswd.pyo
|
||||
${PYSITELIB}/moss/moss.py
|
||||
${PYSITELIB}/moss/moss.pyc
|
||||
${PYSITELIB}/moss/moss.pyo
|
||||
${PYSITELIB}/moss/template.py
|
||||
${PYSITELIB}/moss/template.pyc
|
||||
${PYSITELIB}/moss/template.pyo
|
||||
${PYSITELIB}/moss/web.py
|
||||
${PYSITELIB}/moss/web.pyc
|
||||
${PYSITELIB}/moss/web.pyo
|
||||
share/moss/images/back.gif
|
||||
share/moss/images/dir.gif
|
||||
share/moss/images/file.gif
|
||||
share/moss/images/play.gif
|
||||
share/moss/images/root.gif
|
||||
share/moss/mkpasswd.py
|
||||
share/moss/moss.conf.sample
|
||||
share/moss/templates/default.tmpl
|
|
@ -1,6 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.9 2021/10/26 09:59:13 nia Exp $
|
||||
|
||||
BLAKE2s (moss-0.1.13.tar.gz) = 96eaf0cbaf15b29b804dd162f6eca8fa5784256cb85956b294191937dc5d9549
|
||||
SHA512 (moss-0.1.13.tar.gz) = 360f3093998db755b37e419021006458a302b739f034fe50232ba7f153858d0e6052972ea948c3fa09bb518153f44ab02ae09b7242fd4c6ced3fb08ce88b8542
|
||||
Size (moss-0.1.13.tar.gz) = 43581 bytes
|
||||
SHA1 (patch-aa) = 31b252c52e4e0010064a1a9dca38dcd53d407d9e
|
|
@ -1,28 +0,0 @@
|
|||
#!@RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
# $NetBSD: moss.sh,v 1.2 2011/10/07 22:37:02 shattered Exp $
|
||||
#
|
||||
|
||||
# PROVIDE: moss
|
||||
# REQUIRE: DAEMON LOGIN wscons
|
||||
# KEYWORD: shutdown
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
. /etc/rc.subr
|
||||
fi
|
||||
|
||||
name="moss"
|
||||
rcvar=$name
|
||||
command="@PREFIX@/bin/${name}"
|
||||
command_interpreter="@INTERPRETER@"
|
||||
pidfile="/var/run/moss.pid"
|
||||
required_files="@PREFIX@/etc/moss.conf"
|
||||
command_args="-c ${required_files}"
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
load_rc_config $name
|
||||
run_rc_command "$1"
|
||||
else
|
||||
echo -n " ${name}"
|
||||
${command} ${command_args}
|
||||
fi
|
|
@ -1,99 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.4 2004/11/27 01:22:26 minskim Exp $
|
||||
|
||||
--- setup.py.orig Sat Oct 23 20:22:42 2004
|
||||
+++ setup.py
|
||||
@@ -41,50 +41,50 @@ class my_install_data(install_data):
|
||||
global installed_lib_dir
|
||||
install_data.finalize_options(self)
|
||||
|
||||
- if not os.path.isdir(os.path.join(self.install_dir, "etc")):
|
||||
- print "creating %s" % os.path.join(self.install_dir, "etc")
|
||||
- os.mkdir(os.path.join(self.install_dir, "etc"))
|
||||
-
|
||||
- if not os.path.isfile(os.path.join(self.install_dir, "etc", "moss.conf")):
|
||||
- print "creating %s" % os.path.join(self.install_dir, "etc", "moss.conf")
|
||||
-
|
||||
- src = open("moss.conf.sample", "r")
|
||||
- dest = open(os.path.join(self.install_dir, "etc", "moss.conf"), "w")
|
||||
-
|
||||
- for line in src.readlines():
|
||||
- if line.find("${PREFIX}") != -1:
|
||||
- line = line.replace("${PREFIX}", self.install_dir)
|
||||
-
|
||||
- dest.write(line)
|
||||
-
|
||||
- src.close()
|
||||
- dest.close()
|
||||
- else:
|
||||
- if self.force:
|
||||
- print "creating %s" % os.path.join(self.install_dir, "etc", "moss.conf")
|
||||
-
|
||||
- src = open("moss.conf.sample", "r")
|
||||
- dest = open(os.path.join(self.install_dir, "etc", "moss.conf"), "w")
|
||||
-
|
||||
- for line in src.readlines():
|
||||
- if line.find("${PREFIX}") != -1:
|
||||
- line = line.replace("${PREFIX}", self.install_dir)
|
||||
-
|
||||
- dest.write(line)
|
||||
-
|
||||
- src.close()
|
||||
- dest.close()
|
||||
-
|
||||
- if not os.path.isdir(os.path.join(self.install_dir, "var")):
|
||||
- os.mkdir(os.path.join(self.install_dir, "var"))
|
||||
-
|
||||
- if not os.path.isdir(os.path.join(self.install_dir, "var", "log")):
|
||||
- print "creating %s" % os.path.join(self.install_dir, "var", "log")
|
||||
- os.mkdir(os.path.join(self.install_dir, "var", "log"))
|
||||
-
|
||||
- if not os.path.isdir(os.path.join(self.install_dir, "var", "run")):
|
||||
- print "creating %s" % os.path.join(self.install_dir, "var", "run")
|
||||
- os.mkdir(os.path.join(self.install_dir, "var", "run"))
|
||||
+# if not os.path.isdir(os.path.join(self.install_dir, "etc")):
|
||||
+# print "creating %s" % os.path.join(self.install_dir, "etc")
|
||||
+# os.mkdir(os.path.join(self.install_dir, "etc"))
|
||||
+#
|
||||
+# if not os.path.isfile(os.path.join(self.install_dir, "etc", "moss.conf")):
|
||||
+# print "creating %s" % os.path.join(self.install_dir, "etc", "moss.conf")
|
||||
+#
|
||||
+# src = open("moss.conf.sample", "r")
|
||||
+# dest = open(os.path.join(self.install_dir, "etc", "moss.conf"), "w")
|
||||
+#
|
||||
+# for line in src.readlines():
|
||||
+# if line.find("${PREFIX}") != -1:
|
||||
+# line = line.replace("${PREFIX}", self.install_dir)
|
||||
+#
|
||||
+# dest.write(line)
|
||||
+#
|
||||
+# src.close()
|
||||
+# dest.close()
|
||||
+# else:
|
||||
+# if self.force:
|
||||
+# print "creating %s" % os.path.join(self.install_dir, "etc", "moss.conf")
|
||||
+#
|
||||
+# src = open("moss.conf.sample", "r")
|
||||
+# dest = open(os.path.join(self.install_dir, "etc", "moss.conf"), "w")
|
||||
+#
|
||||
+# for line in src.readlines():
|
||||
+# if line.find("${PREFIX}") != -1:
|
||||
+# line = line.replace("${PREFIX}", self.install_dir)
|
||||
+#
|
||||
+# dest.write(line)
|
||||
+#
|
||||
+# src.close()
|
||||
+# dest.close()
|
||||
+#
|
||||
+# if not os.path.isdir(os.path.join(self.install_dir, "var")):
|
||||
+# os.mkdir(os.path.join(self.install_dir, "var"))
|
||||
+#
|
||||
+# if not os.path.isdir(os.path.join(self.install_dir, "var", "log")):
|
||||
+# print "creating %s" % os.path.join(self.install_dir, "var", "log")
|
||||
+# os.mkdir(os.path.join(self.install_dir, "var", "log"))
|
||||
+#
|
||||
+# if not os.path.isdir(os.path.join(self.install_dir, "var", "run")):
|
||||
+# print "creating %s" % os.path.join(self.install_dir, "var", "run")
|
||||
+# os.mkdir(os.path.join(self.install_dir, "var", "run"))
|
||||
|
||||
if not os.path.isdir(os.path.join(self.install_dir, "share")):
|
||||
os.mkdir(os.path.join(self.install_dir, "share"))
|
|
@ -1 +0,0 @@
|
|||
Libogg bindings for Python. See multimedia/libogg for details.
|
|
@ -1,24 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.22 2022/01/10 20:40:19 wiz Exp $
|
||||
|
||||
DISTNAME= pyogg-1.3
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/py//}
|
||||
PKGREVISION= 4
|
||||
CATEGORIES= audio python
|
||||
MASTER_SITES= http://vorbis.com/files/1.0.1/unix/py/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://vorbis.com/
|
||||
COMMENT= Python bindings for OGG library
|
||||
LICENSE= gnu-lgpl-v2
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIG_SHELL= ${PYTHONBIN}
|
||||
CONFIGURE_SCRIPT= config_unix.py
|
||||
CONFIGURE_ARGS+= --prefix ${PREFIX}
|
||||
|
||||
PYTHON_VERSIONS_ACCEPTED= 27 # not yet ported as of 1.3
|
||||
|
||||
.include "../../lang/python/egg.mk"
|
||||
.include "../../multimedia/libogg/buildlink3.mk"
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,7 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.6 2022/01/14 17:51:51 wiz Exp $
|
||||
${PYINC}/pyogg/pyogg.h
|
||||
${PYSITELIB}/ogg/__init__.py
|
||||
${PYSITELIB}/ogg/__init__.pyc
|
||||
${PYSITELIB}/ogg/__init__.pyo
|
||||
${PYSITELIB}/ogg/_ogg.so
|
||||
${PYSITELIB}/${EGG_INFODIR}
|
|
@ -1,17 +0,0 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.18 2012/05/07 01:53:15 dholland Exp $
|
||||
|
||||
BUILDLINK_TREE+= pyogg
|
||||
|
||||
.if !defined(PYOGG_BUILDLINK3_MK)
|
||||
PYOGG_BUILDLINK3_MK:=
|
||||
|
||||
.include "../../lang/python/pyversion.mk"
|
||||
|
||||
BUILDLINK_API_DEPENDS.pyogg+= ${PYPKGPREFIX}-ogg>=1.3
|
||||
BUILDLINK_ABI_DEPENDS.pyogg+= ${PYPKGPREFIX}-ogg>=1.3nb2
|
||||
BUILDLINK_PKGSRCDIR.pyogg?= ../../audio/py-ogg
|
||||
|
||||
.include "../../multimedia/libogg/buildlink3.mk"
|
||||
.endif # PYOGG_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -pyogg
|
|
@ -1,5 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.5 2021/10/26 09:59:26 nia Exp $
|
||||
|
||||
BLAKE2s (pyogg-1.3.tar.gz) = d6ed3409cbc74782ef50c5b1fc43f6ebd75c91fbb459ecb30f662ef896e82fe1
|
||||
SHA512 (pyogg-1.3.tar.gz) = 396d2d5c15bf35c40d34b2937ac59d918195d1f3b6cf137d74571ddd8b568c7e77727b1af05aae2aec91e6db23b308f11582c3dcc1876c00b6150150a011b82f
|
||||
Size (pyogg-1.3.tar.gz) = 23871 bytes
|
|
@ -1 +0,0 @@
|
|||
Vorbis bindings for Python; see vorbis for details.
|
|
@ -1,25 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.23 2022/01/22 15:45:56 wiz Exp $
|
||||
|
||||
DISTNAME= pyvorbis-1.3
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/py//}
|
||||
PKGREVISION= 3
|
||||
CATEGORIES= audio python
|
||||
MASTER_SITES= http://vorbis.com/files/1.0.1/unix/py/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://vorbis.com/
|
||||
COMMENT= Python bindings for Vorbis library
|
||||
LICENSE= gnu-lgpl-v2
|
||||
|
||||
PYTHON_VERSIONS_ACCEPTED= 27 # py-ogg, and itself not ported as of 1.3
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIG_SHELL= ${PYTHONBIN}
|
||||
CONFIGURE_SCRIPT= config_unix.py
|
||||
CONFIGURE_ARGS+= --prefix ${PREFIX}
|
||||
|
||||
.include "../../audio/py-ogg/buildlink3.mk"
|
||||
.include "../../audio/libvorbis/buildlink3.mk"
|
||||
.include "../../lang/python/egg.mk"
|
||||
.include "../../multimedia/libogg/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,3 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2022/01/22 15:45:56 wiz Exp $
|
||||
${PYSITELIB}/ogg/vorbis.so
|
||||
${PYSITELIB}/${EGG_INFODIR}
|
|
@ -1,6 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.5 2021/10/26 09:59:26 nia Exp $
|
||||
|
||||
BLAKE2s (pyvorbis-1.3.tar.gz) = e6bdcc39cfb8872215ecfea0ea509b5c80b563861e6f1ca145ed1968e666731c
|
||||
SHA512 (pyvorbis-1.3.tar.gz) = 85cfa6438c6a2c68160ce8ff4afa36ddfccedd695d900c9575c9ea3d64c5cdc692de1f5417a33a28350c05878acd1a886f65ff8cc8e34eaddc6ba51ed12694a6
|
||||
Size (pyvorbis-1.3.tar.gz) = 38075 bytes
|
||||
SHA1 (patch-aa) = d698a2e6000882d8ec512b8549f1e35f88f10127
|
|
@ -1,34 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2004/02/15 15:47:29 minskim Exp $
|
||||
|
||||
--- src/pyvorbisfile.c.foo Tue Sep 9 05:40:48 2003
|
||||
+++ src/pyvorbisfile.c Sat Nov 22 15:03:35 2003
|
||||
@@ -178,10 +178,12 @@
|
||||
static void
|
||||
py_ov_file_dealloc(PyObject *self)
|
||||
{
|
||||
+ py_vorbisfile *py_self;
|
||||
+
|
||||
if (PY_VORBISFILE(self))
|
||||
ov_clear(PY_VORBISFILE(self));
|
||||
|
||||
- py_vorbisfile *py_self = (py_vorbisfile *) self;
|
||||
+ py_self = (py_vorbisfile *) self;
|
||||
if (py_self->py_file) {
|
||||
/* If file was opened from a file object, decref it, so it can
|
||||
close */
|
||||
@@ -221,6 +223,7 @@
|
||||
PyErr_Clear(); /* clear first failure */
|
||||
if (PyArg_ParseTuple(args, "O!|sl", &PyFile_Type, &fobject,
|
||||
&initial, &ibytes)) {
|
||||
+ int orig_fd, new_fd;
|
||||
|
||||
fname = NULL;
|
||||
file = PyFile_AsFile(fobject);
|
||||
@@ -234,7 +237,6 @@
|
||||
Really, you shouldn't be passing in files anymore, but in the
|
||||
interest of backwards compatibility it'll stay.
|
||||
*/
|
||||
- int orig_fd, new_fd;
|
||||
orig_fd = fileno(file);
|
||||
new_fd = dup(orig_fd);
|
||||
file = fdopen(new_fd, "r");
|
Loading…
Reference in a new issue