Skip NaN on VAX.

This commit is contained in:
jklos 2013-10-29 17:34:04 +00:00
parent 29c34f6a79
commit b3f7ecfa92
2 changed files with 15 additions and 1 deletions

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.38 2013/10/04 21:02:11 wiz Exp $
$NetBSD: distinfo,v 1.39 2013/10/29 17:34:04 jklos Exp $
SHA1 (m4-1.4.17.tar.gz) = 4f80aed6d8ae3dacf97a0cb6e989845269e342f0
RMD160 (m4-1.4.17.tar.gz) = d81675f1d358ce5eee27184a9d946acfc97a912b
Size (m4-1.4.17.tar.gz) = 1820658 bytes
SHA1 (patch-ab) = 9e9527cdd4b7ba3501d603f0e5ca60c2150e4359
SHA1 (patch-isnan.c) = a960f35e5168bed47c5924e36bfb254dc1a44621
SHA1 (patch-lib_stdio.in.h) = cc5a8572e274b576a154c7a6b14f0a14de5abacd

View file

@ -0,0 +1,13 @@
$NetBSD: patch-isnan.c,v 1.1 2013/10/29 17:34:04 jklos Exp $
--- lib/isnan.c.orig 2013-09-22 06:15:20.000000000 +0000
+++ lib/isnan.c
@@ -118,7 +118,7 @@ FUNC (DOUBLE x)
/* Be careful to not do any floating-point operation on x, such as x == x,
because x may be a signaling NaN. */
# if defined __SUNPRO_C || defined __ICC || defined _MSC_VER \
- || defined __DECC || defined __TINYC__ \
+ || defined __DECC || defined __TINYC__ || defined __vax__ \
|| (defined __sgi && !defined __GNUC__)
/* The Sun C 5.0, Intel ICC 10.0, Microsoft Visual C/C++ 9.0, Compaq (ex-DEC)
6.4, and TinyCC compilers don't recognize the initializers as constant