fix on alpha. (type mismatch).

while here use the DEFAULT_SERIAL_DEVICE setting to hopefully have a better
default on most machines.
This commit is contained in:
dmcmahill 2001-05-07 03:28:11 +00:00
parent e5735fb287
commit b40c5c23c2
4 changed files with 29 additions and 1 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.1.1.1 2001/05/04 11:06:03 wiz Exp $
# $NetBSD: Makefile,v 1.2 2001/05/07 03:28:11 dmcmahill Exp $
#
DISTNAME= bkpupsd-2.0pl3
@ -10,4 +10,8 @@ MAINTAINER= taca@kyoto.jepro.co.jp
HOMEPAGE= http://www.jepro.co.jp/
COMMENT= simple UPS daemon for BK-Pro, BK series and FREQUPS F series
.include "../../mk/bsd.prefs.mk"
MAKE_ENV+= DEFAULT_DEVICE=${DEFAULT_SERIAL_DEVICE}
.include "../../mk/bsd.pkg.mk"

View file

@ -1,3 +1,5 @@
SHA1 (bkpupsd-2.0pl3.tar.gz) = 0f7a057b9e3d7d62022422458d4ea816d76f02b5
Size (bkpupsd-2.0pl3.tar.gz) = 33609 bytes
SHA1 (patch-aa) = 3480f2edf91678adabf093fd057839b13bbcae5c
SHA1 (patch-ab) = 05bf74aca950a7378e47912487665c67bd0e3057

View file

@ -0,0 +1,11 @@
$NetBSD: patch-aa,v 1.1 2001/05/07 03:28:11 dmcmahill Exp $
--- src/main.c.orig Fri Nov 17 01:09:33 2000
+++ src/main.c Sun May 6 23:16:55 2001
@@ -236,5 +236,5 @@
syslog(LOG_INFO,
"No battery low status checking, "
- "use default timeout %ld seconds", ups->fail_timeout);
+ "use default timeout %ld seconds", (long int) (ups->fail_timeout));
}

View file

@ -0,0 +1,11 @@
$NetBSD: patch-ab,v 1.1 2001/05/07 03:28:12 dmcmahill Exp $
--- Makefile.inc.NetBSD.orig Thu Oct 5 01:09:04 2000
+++ Makefile.inc.NetBSD Sun May 6 23:22:11 2001
@@ -6,5 +6,5 @@
PREFIX?= /usr/local
BINDIR= ${PREFIX}/sbin
-DEFAULT_DEVICE= /dev/dty00
+DEFAULT_DEVICE?= /dev/dty00
MANDIR= ${PREFIX}/man
SED?= sed