Add patch from PR 43815 to fix build on some Linuces.
This commit is contained in:
parent
653416ded8
commit
b42a7402b8
2 changed files with 33 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.8 2010/07/24 13:42:12 obache Exp $
|
||||
$NetBSD: distinfo,v 1.9 2010/11/18 13:56:05 wiz Exp $
|
||||
|
||||
SHA1 (avahi-0.6.27.tar.gz) = e763bbeba92fd5b3ba3e2af5fc85aaf99b406c8b
|
||||
RMD160 (avahi-0.6.27.tar.gz) = 36e6a242f0c926351e31871d8a4f8a52a501fdc3
|
||||
|
@ -8,6 +8,7 @@ SHA1 (patch-ab) = aca73131b1a1df97dab6f221c59bd5e21136f816
|
|||
SHA1 (patch-ac) = f506e4f7839ca7201abfc0fe22120993e9a2279d
|
||||
SHA1 (patch-ad) = 0777139388729f5a8a1aa8dffd602f3c34c9f61b
|
||||
SHA1 (patch-ae) = d0db18ff6c830da992510465df53d0bc0433d2a1
|
||||
SHA1 (patch-af) = c8d0ea175abfc25c5d55e51fc00cb86ecdb8574c
|
||||
SHA1 (patch-ag) = f729ef5b61ffaa641fe5abe78b42c4f6316569b7
|
||||
SHA1 (patch-ah) = 4b3ffdb927daef8c939527fd5c5893f9f88b3ff3
|
||||
SHA1 (patch-ai) = 406b314c8105e28cffb83a92bb80f2dc1b264c3f
|
||||
|
|
31
net/avahi/patches/patch-af
Normal file
31
net/avahi/patches/patch-af
Normal file
|
@ -0,0 +1,31 @@
|
|||
$NetBSD: patch-af,v 1.3 2010/11/18 13:56:05 wiz Exp $
|
||||
|
||||
PR 43815:
|
||||
net/avahi fails on my Linux system:
|
||||
|
||||
...
|
||||
CC avahi_daemon-sd-daemon.o
|
||||
sd-daemon.c: In function 'sd_notify':
|
||||
sd-daemon.c:356: error: 'SOCK_CLOEXEC' undeclared (first use in this function)
|
||||
sd-daemon.c:356: error: (Each undeclared identifier is reported only once
|
||||
sd-daemon.c:356: error: for each function it appears in.)
|
||||
gmake[2]: *** [avahi_daemon-sd-daemon.o] Error 1
|
||||
|
||||
This is because my glibc and Kernel is not modern enough for this
|
||||
version of avahi.
|
||||
|
||||
http://avahi.org/ticket/316
|
||||
|
||||
--- avahi-daemon/sd-daemon.c.orig 2010-07-13 00:45:20.000000000 +0000
|
||||
+++ avahi-daemon/sd-daemon.c
|
||||
@@ -41,6 +41,10 @@
|
||||
#include <stdarg.h>
|
||||
#include <stdio.h>
|
||||
|
||||
+#if !defined(SOCK_CLOEXEC) && !defined(DISABLE_SYSTEMD)
|
||||
+#define DISABLE_SYSTEMD 1
|
||||
+#endif
|
||||
+
|
||||
#include "sd-daemon.h"
|
||||
|
||||
int sd_listen_fds(int unset_environment) {
|
Loading…
Reference in a new issue