Update to ngspice-23 from ngspice-20. From the NEWS file:
Ngspice-23, June 5th, 2011 ============ - New features: + Reduction of trtol to 1 only if 'A' devices in the circuit and xspice is enabled + command wrs2p to write a s-parameter file using Touchstone vers. 1 format + d_source d_state d_ram, test cases for those xspice codemodels + transient noise simulation added to independent voltage and current sources + Random telegraph noise added to independent voltage and current sources + 'time = nnn' in stop command added + random voltage generator option trrandom to independent voltage and current sources + ngspice build possible in a separate directory (e.g. in ng-spice-rework/release) + update FIND .. WHEN measurements + diode & bjt temperature model update with tlev and tlevc + merge bsim3v1a code with bsim3v0 and bsim3v1s code with bsim3v1 + bjt2: removed - all GP extensions of this model are now in the bjt model + HiSIM_HV model vers. 1.2.1 added + bsim3v32: delvto and mulu0 as instance parameters + Replace HiSIM1 by HiSIM_2.5.1_Release_20110407 - Bug fixes: + More on prototypes, type casts, reordering of functions, compiler warnings + allow models like 2N2904 or 2SK136 also in subcircuits + fix sensitvity calculation (for the dc-2+.cir testcase) + allow multiple call to setup w/ correct node collapsing + Many small bugs Ngspice-22, Sept 26th, 2010 ============ - New features: + OpenMP multicore support for BSIM3, BSIM4, and BSIMSOI4 + reinstate {$var} expansion in interactive interpreter + .TITLE line added + update to 'spectrum' script + par('expression') in .four, .plot, .print, .meas, .save commands + command 'option' for use in spinit, .spiceinit, and in scripts + adms procedure updated + new random number generator, random functions sunif() and sgauss() + ngspice manual updated - Bug fixes: + Major code cleanup to reduce compiler/linker warnings: ansi function prototypes, void/char pointers to named pointers, explicit type casts and many more + Many small bugs Ng-spice-rework-21, Jun3, 13th 2010 ============ - Updated Devices: BSIMSOI 4.3.1 - New features: + Compatibility: C, L, R, devices and E, G sources with expressions Variables HERTZ, TIME, TEMPER added + E, G sources with pwl function + New manual + Plotting with Gnuplot, + Writing wrdata for simple text table to file + .measure improved + transmission line models improved - Bug fixes: + Many small bugs, memory leaks, memory overflows
This commit is contained in:
parent
2bf7f4bd4e
commit
b455cef8c1
5 changed files with 9 additions and 49 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.38 2010/02/28 18:00:19 dmcmahill Exp $
|
||||
# $NetBSD: Makefile,v 1.39 2011/08/30 12:01:03 dmcmahill Exp $
|
||||
#
|
||||
|
||||
DISTNAME= ng-spice-rework-20
|
||||
PKGNAME= ng-spice-20
|
||||
DISTNAME= ngspice-23
|
||||
PKGNAME= ng-spice-23
|
||||
CATEGORIES= cad
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=ngspice/}
|
||||
|
||||
|
@ -12,14 +12,13 @@ COMMENT= Next generation circuit simulation program
|
|||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
WRKSRC= ${WRKDIR}/ngspice-20
|
||||
USE_LIBTOOL= YES
|
||||
USE_TOOLS+= gmake makeinfo
|
||||
USE_GNU_READLINE= uses rl_* interface
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
CONFIGURE_ARGS+= --disable-debug
|
||||
CONFIGURE_ARGS+= --with-readline
|
||||
CONFIGURE_ARGS+= --with-readline=yes
|
||||
LIBS+= ${BUILDLINK_LDADD.getopt}
|
||||
|
||||
INFO_FILES= # PLIST
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.11 2010/02/28 18:00:19 dmcmahill Exp $
|
||||
@comment $NetBSD: PLIST,v 1.12 2011/08/30 12:01:03 dmcmahill Exp $
|
||||
@comment bin/nghelp
|
||||
bin/ngmakeidx
|
||||
bin/ngmultidec
|
||||
|
@ -6,7 +6,6 @@ bin/ngnutmeg
|
|||
bin/ngproc2mod
|
||||
bin/ngsconvert
|
||||
bin/ngspice
|
||||
info/ngspice.info
|
||||
man/man1/ngmultidec.1
|
||||
man/man1/ngnutmeg.1
|
||||
man/man1/ngsconvert.1
|
||||
|
|
|
@ -1,7 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.14 2010/03/17 21:54:58 dmcmahill Exp $
|
||||
$NetBSD: distinfo,v 1.15 2011/08/30 12:01:03 dmcmahill Exp $
|
||||
|
||||
SHA1 (ng-spice-rework-20.tar.gz) = 870d69b88d6cc0d83a8a0416a6782a4abd296de0
|
||||
RMD160 (ng-spice-rework-20.tar.gz) = 73eff9cd601253523816a7c8a93e88a795ce96bb
|
||||
Size (ng-spice-rework-20.tar.gz) = 7167239 bytes
|
||||
SHA1 (patch-aa) = 08f84b761ac1cf568af6e5a10475259c39f6ecc3
|
||||
SHA1 (patch-ak) = c5c08a75b6d41eaad75ac121566dd1b289579a39
|
||||
SHA1 (ngspice-23.tar.gz) = 65fa23d1168cb3af7651b990344f763c77bf6132
|
||||
RMD160 (ngspice-23.tar.gz) = 34a5bb0a06e67a9ebe21f7abe8067cd8e793ea9e
|
||||
Size (ngspice-23.tar.gz) = 6485536 bytes
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.7 2010/03/17 21:54:58 dmcmahill Exp $
|
||||
|
||||
--- src/frontend/com_sysinfo.c.orig 2009-10-04 15:57:10.000000000 +0000
|
||||
+++ src/frontend/com_sysinfo.c 2010-03-17 21:53:46.000000000 +0000
|
||||
@@ -287,5 +287,5 @@
|
||||
// numProcs++;
|
||||
strPtr += strlen(matchStrProc);
|
||||
- if isblank(*strPtr) numProcs++;
|
||||
+ if (isblank(*strPtr)) numProcs++;
|
||||
}
|
||||
info->numLogicalProcessors = numProcs;
|
|
@ -1,25 +0,0 @@
|
|||
$NetBSD: patch-ak,v 1.2 2010/02/28 18:00:19 dmcmahill Exp $
|
||||
|
||||
--- src/frontend/aspice.c.orig 2008-05-31 08:38:56.000000000 +0000
|
||||
+++ src/frontend/aspice.c
|
||||
@@ -177,15 +177,11 @@ sigchild(void)
|
||||
* whether the exit was normal or not.
|
||||
*/
|
||||
|
||||
-#if defined(__NetBSD__)
|
||||
- pid_t status;
|
||||
-#elif defined(__FreeBSD__) || defined(__APPLE__) || defined(SOLARIS)
|
||||
- int status;
|
||||
-#else
|
||||
- union wait status;
|
||||
-#endif
|
||||
-
|
||||
-
|
||||
+/*
|
||||
+ * On posix systems, wait() is:
|
||||
+ * pid_t wait(int *status);
|
||||
+ */
|
||||
+int status;
|
||||
|
||||
void
|
||||
ft_checkkids(void)
|
Loading…
Reference in a new issue