Imported flvstreamer 2.1c1 from wip/flvstreamer

flvstreamer is an open source command-line RTMP client intended to stream audio
or video content from all types of flash or rtmp servers. Forked from rtmpdump
v1.6 with encrypted rtmp and swf verification support removed. This tool
provides free interoperability with the previously undocumented adobe RTMP
protocol so widely in use on the internet today. It was developed entirely by
reverse engineering methods and without access to any proprietary or
restrictive-license protocol specifications.

ok wiz@
This commit is contained in:
khorben 2014-11-12 18:38:18 +00:00
parent 1a36600f48
commit b47f8c8989
6 changed files with 80 additions and 0 deletions

View file

@ -0,0 +1,7 @@
flvstreamer is an open source command-line RTMP client intended to stream audio
or video content from all types of flash or rtmp servers. Forked from rtmpdump
v1.6 with encrypted rtmp and swf verification support removed. This tool
provides free interoperability with the previously undocumented adobe RTMP
protocol so widely in use on the internet today. It was developed entirely by
reverse engineering methods and without access to any proprietary or
restrictive-license protocol specifications.

View file

@ -0,0 +1,20 @@
# $NetBSD: Makefile,v 1.1 2014/11/12 18:38:18 khorben Exp $
DISTNAME= flvstreamer-2.1c1
WRKSRC= ${WRKDIR}/flvstreamer
CATEGORIES= multimedia
MASTER_SITES= http://download.savannah.gnu.org/releases/flvstreamer/source/
MAINTAINER= khorben@defora.org
HOMEPAGE= http://savannah.nongnu.org/projects/flvstreamer
COMMENT= Open source command-line RTMP client
LICENSE= gnu-gpl-v2
USE_TOOLS+= gmake
MAKE_FLAGS+= posix
MAKE_FLAGS+= PREFIX=${PREFIX}
MAKE_FLAGS+= DESTDIR=${DESTDIR}
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,4 @@
@comment $NetBSD: PLIST,v 1.1 2014/11/12 18:38:18 khorben Exp $
bin/flvstreamer
bin/rtmpsrv
bin/streams

View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1 2014/11/12 18:38:18 khorben Exp $
SHA1 (flvstreamer-2.1c1.tar.gz) = 07fac3dea65d8de8afbcc3c892d7830a90b66f10
RMD160 (flvstreamer-2.1c1.tar.gz) = 48ab173d4f0332ef2b4d42a72e7c637c7943066f
Size (flvstreamer-2.1c1.tar.gz) = 77379 bytes
SHA1 (patch-Makefile) = e1222d997dc7e1cca7535efaaf0b403b80d011f5
SHA1 (patch-rtmp.c) = aebc2b14fa57de50a159b6d25b1f10f69cec9563

View file

@ -0,0 +1,28 @@
$NetBSD: patch-Makefile,v 1.1 2014/11/12 18:38:18 khorben Exp $
Let the relevant binaries be installed through "make install"
--- Makefile.orig 2010-02-15 01:06:20.000000000 +0000
+++ Makefile
@@ -8,6 +8,8 @@ LDFLAGS=-Wall $(XLDFLAGS)
LIBS=
THREADLIB=-lpthread
SLIBS=$(THREADLIB) $(LIBS)
+PREFIX=/usr/local
+DESTDIR=
EXT=
@@ -21,6 +23,12 @@ progs: flvstreamer streams rtmpsrv rtmps
posix linux unix osx:
@$(MAKE) $(MAKEFLAGS) progs
+install:
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
+ install -m 755 flvstreamer $(DESTDIR)$(PREFIX)/bin/flvstreamer
+ install -m 755 rtmpsrv $(DESTDIR)$(PREFIX)/bin/rtmpsrv
+ install -m 755 streams $(DESTDIR)$(PREFIX)/bin/streams
+
mingw:
@$(MAKE) CROSS_COMPILE=mingw32- LIBS="$(LIBS) -lws2_32 -lwinmm -lgdi32" THREADLIB= EXT=.exe $(MAKEFLAGS) progs

View file

@ -0,0 +1,14 @@
$NetBSD: patch-rtmp.c,v 1.1 2014/11/12 18:38:18 khorben Exp $
Fix build on NetBSD
--- rtmp.c.orig 2010-02-15 01:04:35.000000000 +0000
+++ rtmp.c
@@ -21,6 +21,7 @@
*
*/
+#include <sys/time.h>
#include <stdint.h>
#include <stdlib.h>
#include <string.h>