Update to 2.03:
January 23 2008 - V2.02 Improvements to clustering, training and classifier. Major internationalization improvements for large-character-set languages, eg Kannada. Removed some compiler warnings. Added multipage tiff support for training and running. Updated graphics output to talk to new java-based viewer. Added ability to save n-best lists. Added leptonica support for more file types. Improved Init/End to make them safe. Reduced memory use of dictionaries. Added some new APIs to TessBaseAPI. April 21 2008 - V2.02 (again) Fixed namespace collisions with jpeg library (INT32). Portability fixes for Windows for new code. Updates to autoconf system for new code. April 22 2008 - V2.03 Fixed crash introduced in 2.02. Fixed lack of tessembedded.cpp in distribution. Added test for leptonica header files and conditional test for lib.
This commit is contained in:
parent
e6bcdf8814
commit
b4a554e958
5 changed files with 53 additions and 22 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.3 2007/11/29 16:42:08 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2008/05/30 13:06:26 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= tesseract-2.01
|
||||
DISTNAME= tesseract-2.03
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://tesseract-ocr.googlecode.com/files/
|
||||
|
||||
|
@ -13,6 +13,7 @@ PKG_DESTDIR_SUPPORT=user-destdir
|
|||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LANGUAGES= c c++
|
||||
USE_TOOLS+= gmake
|
||||
|
||||
post-build:
|
||||
${SED} -e "s,@PREFIX@,${PREFIX}," ${FILESDIR}/tesseract.sh \
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 2007/11/29 16:42:09 wiz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.4 2008/05/30 13:06:26 wiz Exp $
|
||||
bin/cntraining
|
||||
bin/mftraining
|
||||
bin/tesseract
|
||||
|
@ -39,7 +39,6 @@ include/tesseract/closed.h
|
|||
include/tesseract/clst.h
|
||||
include/tesseract/cluster.h
|
||||
include/tesseract/clusttool.h
|
||||
include/tesseract/cmndwin.h
|
||||
include/tesseract/const.h
|
||||
include/tesseract/context.h
|
||||
include/tesseract/control.h
|
||||
|
@ -66,8 +65,6 @@ include/tesseract/elst.h
|
|||
include/tesseract/elst2.h
|
||||
include/tesseract/emalloc.h
|
||||
include/tesseract/errcode.h
|
||||
include/tesseract/evntlst.h
|
||||
include/tesseract/evnts.h
|
||||
include/tesseract/expandblob.h
|
||||
include/tesseract/extern.h
|
||||
include/tesseract/extract.h
|
||||
|
@ -90,8 +87,6 @@ include/tesseract/general.h
|
|||
include/tesseract/globaloc.h
|
||||
include/tesseract/globals.h
|
||||
include/tesseract/gradechop.h
|
||||
include/tesseract/grphics.h
|
||||
include/tesseract/grphshm.h
|
||||
include/tesseract/hashfn.h
|
||||
include/tesseract/heuristic.h
|
||||
include/tesseract/hideedge.h
|
||||
|
@ -114,6 +109,8 @@ include/tesseract/intproto.h
|
|||
include/tesseract/ipoints.h
|
||||
include/tesseract/kdtree.h
|
||||
include/tesseract/labls.h
|
||||
include/tesseract/leptonica_pageseg.h
|
||||
include/tesseract/leptonica_pageseg_interface.h
|
||||
include/tesseract/linlsq.h
|
||||
include/tesseract/listio.h
|
||||
include/tesseract/lmedsq.h
|
||||
|
@ -164,15 +161,16 @@ include/tesseract/outlines.h
|
|||
include/tesseract/output.h
|
||||
include/tesseract/pageblk.h
|
||||
include/tesseract/pageres.h
|
||||
include/tesseract/pageseg.h
|
||||
include/tesseract/pagewalk.h
|
||||
include/tesseract/paircmp.h
|
||||
include/tesseract/pdblock.h
|
||||
include/tesseract/pdclass.h
|
||||
include/tesseract/permdawg.h
|
||||
include/tesseract/permngram.h
|
||||
include/tesseract/permnum.h
|
||||
include/tesseract/permute.h
|
||||
include/tesseract/pgedit.h
|
||||
include/tesseract/pgeditx.h
|
||||
include/tesseract/picofeat.h
|
||||
include/tesseract/pieces.h
|
||||
include/tesseract/pithsync.h
|
||||
|
@ -197,18 +195,14 @@ include/tesseract/rejctmap.h
|
|||
include/tesseract/reject.h
|
||||
include/tesseract/render.h
|
||||
include/tesseract/rwpoly.h
|
||||
include/tesseract/sbdmenu.h
|
||||
include/tesseract/sbgconst.h
|
||||
include/tesseract/sbgdefs.h
|
||||
include/tesseract/sbgtypes.h
|
||||
include/tesseract/scaleimg.h
|
||||
include/tesseract/scanedg.h
|
||||
include/tesseract/scanutils.cpp
|
||||
include/tesseract/scanutils.h
|
||||
include/tesseract/scrollview.h
|
||||
include/tesseract/seam.h
|
||||
include/tesseract/secname.h
|
||||
include/tesseract/serialis.h
|
||||
include/tesseract/showim.h
|
||||
include/tesseract/sigmenu.h
|
||||
include/tesseract/sortflts.h
|
||||
include/tesseract/speckle.h
|
||||
|
@ -220,7 +214,10 @@ include/tesseract/stepblob.h
|
|||
include/tesseract/stopper.h
|
||||
include/tesseract/strngs.h
|
||||
include/tesseract/structures.h
|
||||
include/tesseract/submen.h
|
||||
include/tesseract/svmnode.h
|
||||
include/tesseract/svpaint.cpp
|
||||
include/tesseract/svshowim.h
|
||||
include/tesseract/svutil.h
|
||||
include/tesseract/tally.h
|
||||
include/tesseract/tessarray.h
|
||||
include/tesseract/tessbox.h
|
||||
|
@ -252,8 +249,6 @@ include/tesseract/unicharmap.h
|
|||
include/tesseract/unicharset.h
|
||||
include/tesseract/varable.h
|
||||
include/tesseract/varabled.h
|
||||
include/tesseract/varblmen.h
|
||||
include/tesseract/varblwin.h
|
||||
include/tesseract/variables.h
|
||||
include/tesseract/vecfuncs.h
|
||||
include/tesseract/werd.h
|
||||
|
@ -266,10 +261,10 @@ lib/libtesseract_ccutil.a
|
|||
lib/libtesseract_classify.a
|
||||
lib/libtesseract_cutil.a
|
||||
lib/libtesseract_dict.a
|
||||
lib/libtesseract_display.a
|
||||
lib/libtesseract_full.a
|
||||
lib/libtesseract_image.a
|
||||
lib/libtesseract_main.a
|
||||
lib/libtesseract_pageseg.a
|
||||
lib/libtesseract_textord.a
|
||||
lib/libtesseract_training.a
|
||||
lib/libtesseract_viewer.a
|
||||
|
@ -279,6 +274,7 @@ share/doc/tesseract/README
|
|||
share/tessdata/configs/api_config
|
||||
share/tessdata/configs/box.train
|
||||
share/tessdata/configs/inter
|
||||
share/tessdata/configs/kannada
|
||||
share/tessdata/configs/makebox
|
||||
share/tessdata/configs/unlv
|
||||
share/tessdata/confsets
|
||||
|
|
|
@ -1,5 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.3 2007/11/29 16:42:09 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.4 2008/05/30 13:06:26 wiz Exp $
|
||||
|
||||
SHA1 (tesseract-2.01.tar.gz) = c35f3448e97d61e00980abba6b2e9cb6e151c366
|
||||
RMD160 (tesseract-2.01.tar.gz) = e28bb1d60baf73c8eaa646b32825d9931116851e
|
||||
Size (tesseract-2.01.tar.gz) = 1050770 bytes
|
||||
SHA1 (tesseract-2.03.tar.gz) = b7859278ff98a8b64bf98b5a519688e1559cec57
|
||||
RMD160 (tesseract-2.03.tar.gz) = 7519e7f4d876444bd3264d599dbf423e22443311
|
||||
Size (tesseract-2.03.tar.gz) = 1075509 bytes
|
||||
SHA1 (patch-aa) = 6edb250b22714ffec9490602fe11cd2b284ba4bb
|
||||
SHA1 (patch-ab) = 0ddb1a61d2bd445a65c54390f877b7d1c0aa39a0
|
||||
|
|
14
graphics/tesseract/patches/patch-aa
Normal file
14
graphics/tesseract/patches/patch-aa
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-aa,v 1.1 2008/05/30 13:06:26 wiz Exp $
|
||||
|
||||
--- viewer/svutil.cpp.orig 2008-04-22 00:07:25.000000000 +0000
|
||||
+++ viewer/svutil.cpp
|
||||
@@ -31,6 +31,9 @@
|
||||
#include <signal.h>
|
||||
#include <netdb.h>
|
||||
#include <sys/socket.h>
|
||||
+#ifdef __NetBSD__
|
||||
+#include <netinet/in.h>
|
||||
+#endif
|
||||
#ifdef __linux__
|
||||
#include <sys/prctl.h>
|
||||
#endif
|
18
graphics/tesseract/patches/patch-ab
Normal file
18
graphics/tesseract/patches/patch-ab
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-ab,v 1.1 2008/05/30 13:06:26 wiz Exp $
|
||||
|
||||
Without this patch:
|
||||
Entering directory `/scratch/graphics/tesseract/work/tesseract-2.03/java'
|
||||
*** No rule to make target `install'. Stop.
|
||||
Leaving directory `/scratch/graphics/tesseract/work/tesseract-2.03/java'
|
||||
|
||||
--- Makefile.in.orig 2008-05-30 12:43:20.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -76,7 +76,7 @@ PACKAGE_YEAR = @PACKAGE_YEAR@
|
||||
RANLIB = @RANLIB@
|
||||
VERSION = @VERSION@
|
||||
|
||||
-SUBDIRS = ccstruct ccutil classify cutil dict pageseg image textord viewer wordrec ccmain training tessdata testing dlltest java
|
||||
+SUBDIRS = ccstruct ccutil classify cutil dict pageseg image textord viewer wordrec ccmain training tessdata testing dlltest # java
|
||||
|
||||
EXTRA_DIST = eurotext.tif phototest.tif ReleaseNotes tesseract.spec config tesseract.dsp tesseract.dsw tesseract.vcproj tesseract.sln StdAfx.cpp StdAfx.h tessdll.cpp tessdll.h tessdll.dsp tessdll.vcproj
|
||||
|
Loading…
Reference in a new issue