perl5: updated to 5.28.2

NAME
       perldelta - what is new for perl v5.28.2

DESCRIPTION
       This document describes differences between the 5.28.1 release and the 5.28.2 release.

       If you are upgrading from an earlier release such as 5.28.0, first read perl5281delta, which describes
       differences between 5.28.0 and 5.28.1.

Incompatible Changes
   Any set of digits in the Common script are legal in a script run of another script
       There are several sets of digits in the Common script.  "[0-9]" is the most familiar.  But there are also
       "[\x{FF10}-\x{FF19}]" (FULLWIDTH DIGIT ZERO - FULLWIDTH DIGIT NINE), and several sets for use in
       mathematical notation, such as the MATHEMATICAL DOUBLE-STRUCK DIGITs.  Any of these sets should be able to
       appear in script runs of, say, Greek.  But the previous design overlooked all but the ASCII digits "[0-9]",
       so the design was flawed.  This has been fixed, so is both a bug fix and an incompatibility.

       All digits in a run still have to come from the same set of ten digits.

Modules and Pragmata
   Updated Modules and Pragmata
       o   Module::CoreList has been upgraded from version 5.20181129_28 to 5.20190419.

       o   PerlIO::scalar has been upgraded from version 0.29 to 0.30.

       o   Storable has been upgraded from version 3.08 to 3.08_01.

Platform Support
   Platform-Specific Notes
       Windows
           The Windows Server 2003 SP1 Platform SDK build, with its early x64 compiler and tools, was accidentally
           broken in Perl 5.27.9.  This has now been fixed.

       Mac OS X
           Perl's build and testing process on Mac OS X for "-Duseshrplib" builds is now compatible with Mac OS X
           System Integrity Protection (SIP).

           SIP prevents binaries in /bin (and a few other places) being passed the "DYLD_LIBRARY_PATH" environment
           variable.  For our purposes this prevents "DYLD_LIBRARY_PATH" from being passed to the shell, which
           prevents that variable being passed to the testing or build process, so running "perl" couldn't find
           libperl.dylib.

           To work around that, the initial build of the perl executable expects to find libperl.dylib in the build
           directory, and the library path is then adjusted during installation to point to the installed library.

Selected Bug Fixes
       o   If an in-place edit is still in progress during global destruction and the process exit code (as stored
           in $?) is zero, perl will now treat the in-place edit as successful, replacing the input file with any
           output produced.

           This allows code like:

             perl -i -ne 'print "Foo"; last'

           to replace the input file, while code like:

             perl -i -ne 'print "Foo"; die'

           will not.

       o   A regression in Perl 5.28 caused the following code to fail

            close(STDIN); open(CHILD, "|wc -l")'

           because the child's stdin would be closed on exec.  This has now been fixed.

       o   "pack "u", "invalid uuencoding"" now properly NUL terminates the zero-length SV produced.

       o   Failing to compile a format now aborts compilation.  Like other errors in sub-parses this could leave
           the parser in a strange state, possibly crashing perl if compilation continued.

       o   See "Any set of digits in the Common script are legal in a script run of another script".
This commit is contained in:
adam 2019-04-23 09:27:46 +00:00
parent 22892b62ca
commit b4b7a7b19b
12 changed files with 81 additions and 94 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.251 2018/12/02 13:39:56 adam Exp $
# $NetBSD: Makefile,v 1.252 2019/04/23 09:27:46 adam Exp $
.include "license.mk"
.include "Makefile.common"
@ -294,7 +294,7 @@ post-extract:
${WRKSRC}/cpan/DB_File/hints/minix.pl
pre-configure:
cd ${WRKSRC} && find `pwd` -name "*.orig" -type f -exec ${RM} -f {} \;
find ${WRKSRC} -name "*.orig" -type f -delete
post-build:
${SED} -e "s,@PERL5@,"${PERL5:Q}",g" \

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile.common,v 1.35 2018/12/02 13:39:56 adam Exp $
# $NetBSD: Makefile.common,v 1.36 2019/04/23 09:27:46 adam Exp $
#
# used by lang/perl5/Makefile
# used by databases/p5-gdbm/Makefile
DISTNAME= perl-5.28.1
DISTNAME= perl-5.28.2
CATEGORIES= lang devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:S,/modules/by-module/$,/src/5.0/,}
DISTFILES+= ${DISTNAME}${EXTRACT_SUFX}

View file

@ -1,19 +1,19 @@
$NetBSD: distinfo,v 1.156 2018/12/02 13:39:56 adam Exp $
$NetBSD: distinfo,v 1.157 2019/04/23 09:27:46 adam Exp $
SHA1 (perl-5.28.1.tar.xz) = 5fc239bebb8c484c3f5c58e663274ce668981651
RMD160 (perl-5.28.1.tar.xz) = e2f0618fc01bcd253ef6e003c1d9b957b6f6aa53
SHA512 (perl-5.28.1.tar.xz) = 6d18e9684c3a15bea2ccd28f116d1829c3acd5547551ee3539f0060c0d1a75246dfe570dfb9d5f00625a994a0afb0cbd6a5a5f9a407fef75a421e7dbc6491b43
Size (perl-5.28.1.tar.xz) = 12372080 bytes
SHA1 (perl-5.28.2.tar.xz) = e7be78eca9ac5596783e6abcf957408050a7b650
RMD160 (perl-5.28.2.tar.xz) = 8ec4c3a3fa2df12c47cf3e9613dc215333f3d042
SHA512 (perl-5.28.2.tar.xz) = 0f2e4f7cb5d8cf6e00054b3842907e29b6c85902d97fb881d5bea65edbc875fef4e15e064561fac7c8db4939586576dd76a225026c7cca9624261c887b1fdb08
Size (perl-5.28.2.tar.xz) = 12374448 bytes
SHA1 (patch-Configure) = 00754ccc8bbeb38f8a0363d1bfba908fea9ef4d6
SHA1 (patch-Makefile.SH) = febb87d876a44091a761d3ef99c649f3e4bdd394
SHA1 (patch-aa) = 3a2b39c9eb903e68ef7d03ae448c51c147c19aa1
SHA1 (patch-ab) = 0ad5988b7cadfb13d9646a59a57f6cf884a6238a
SHA1 (patch-ac) = 4baa8f80695687abb53d4f4e1830cf86db5b2bf7
SHA1 (patch-caretx.c) = cbe55cdb897c02805a51582f6a7e413ca313b630
SHA1 (patch-Makefile.SH) = a267630c3476baf6361e35a914f7cc741e313e72
SHA1 (patch-caretx.c) = b76b4175a58123fa4dfd2adf36b2207dcb6cf65a
SHA1 (patch-cflags.SH) = 7ad64e5a17b876bff4bbe238abc4a57354acf4fe
SHA1 (patch-dist_Storable_Makefile.PL) = fd8964cf3c94ba811caaf71be21650b29e4c8e50
SHA1 (patch-cpan_ExtUtils-MakeMaker_lib_ExtUtils_MM__Unix.pm) = 3a2b39c9eb903e68ef7d03ae448c51c147c19aa1
SHA1 (patch-dist_Storable_Makefile.PL) = 9664a9851d08eeb078da12210a41190d082aab9b
SHA1 (patch-hints_cygwin.sh) = 1b21d927d6b7379754c4cd64a2b05d3632c35470
SHA1 (patch-hints_linux.sh) = 4baa8f80695687abb53d4f4e1830cf86db5b2bf7
SHA1 (patch-hints_minix.sh) = cb62ad0be5c38ca5b79f180252ca0843a0444f8a
SHA1 (patch-hints_netbsd.sh) = 0d549a48800372d75fe34b783529a78cba90f646
SHA1 (patch-hints_solaris__2.sh) = 0e54889648a6f0f2a0232c5e01bef89d245c213d
SHA1 (patch-ta) = a9d13eeec22733e4087942f217a0d47a19498a6f
SHA1 (patch-installperl) = 0ad5988b7cadfb13d9646a59a57f6cf884a6238a
SHA1 (patch-t_io_fs.t) = a9d13eeec22733e4087942f217a0d47a19498a6f

View file

@ -1,4 +1,4 @@
# $NetBSD: hacks.mk,v 1.22 2018/11/21 09:37:57 maya Exp $
# $NetBSD: hacks.mk,v 1.23 2019/04/23 09:27:46 adam Exp $
.if !defined(PERL5_HACKS_MK)
PERL5_HACKS_MK= defined
@ -40,7 +40,7 @@ BUILDLINK_TRANSFORM+= opt:-O3:-O2
&& !empty(CC_VERSION:Mgcc-[45].*.*)
# XXX: is there any good way to replace the default -O2 with multiple args?
PKG_HACKS+= alpha-optimisation
#BUILDLINK_TRANSFORM+= opt:-O[2-9]*:-O2 -fno-tree-ter
#BUILDLINK_TRANSFORM+= opt:-O[2-9]*:-O2 -fno-tree-ter
CFLAGS+=-fno-tree-ter
.endif

View file

@ -1,12 +1,22 @@
$NetBSD: patch-Makefile.SH,v 1.7 2018/09/01 08:03:02 schmonz Exp $
$NetBSD: patch-Makefile.SH,v 1.8 2019/04/23 09:27:46 adam Exp $
Use correct -install_name on Darwin.
Fix DTrace object generation.
Fix Storable build on OS X where DYLD_LIBRARY_PATH is no longer
inherited by child processes.
--- Makefile.SH.orig 2018-05-21 13:22:09.000000000 +0000
+++ Makefile.SH
@@ -275,6 +275,7 @@ LNS = $lns
--- Makefile.SH.orig 2019-04-02 22:36:35.000000000 +0200
+++ Makefile.SH 2019-04-23 10:07:15.000000000 +0200
@@ -70,7 +70,7 @@
${revision}.${patchlevel}.${subversion}"
case "$osvers" in
1[5-9]*|[2-9]*)
- shrpldflags="$shrpldflags -install_name `pwd`/\$@ -Xlinker -headerpad_max_install_names"
+ shrpldflags="$shrpldflags -install_name \$(shrpdir)/\$@ -Xlinker -headerpad_max_install_names"
exeldflags="-Xlinker -headerpad_max_install_names"
;;
*)
@@ -283,6 +283,7 @@
# NOTE: some systems don't grok "cp -f". XXX Configure test needed?
CPS = $cp
RMS = rm -f
@ -14,7 +24,7 @@ inherited by child processes.
ranlib = $ranlib
# The following are mentioned only to make metaconfig include the
@@ -1167,7 +1168,7 @@ esac
@@ -1197,7 +1198,7 @@
$spitshell >>$Makefile <<EOT
dist/Storable/lib/Storable/Limit.pm : \$(PERL_EXE) dist/Storable/stacksize $storable_limit_dep

View file

@ -1,72 +1,15 @@
$NetBSD: patch-caretx.c,v 1.2 2018/10/15 03:01:37 taca Exp $
$NetBSD: patch-caretx.c,v 1.3 2019/04/23 09:27:46 adam Exp $
* NetBSD's implementation sometimes returns "/"; reject that too.
* Apply 03b94aa47e981af3c7b0118bfb11facda2b95251 from upstream make
$^X fallback work when platform-specific technique fails.
NetBSD's implementation sometimes returns "/"; reject that too.
--- caretx.c.orig 2018-05-21 12:29:23.000000000 +0000
--- caretx.c.orig 2019-04-02 20:36:35.000000000 +0000
+++ caretx.c
@@ -56,7 +56,19 @@ Perl_set_caret_X(pTHX) {
SV *const caret_x = GvSV(tmpgv);
#if defined(OS2)
sv_setpv(caret_x, os2_execname(aTHX));
-#elif defined(USE_KERN_PROC_PATHNAME)
+ return;
+#elif defined(WIN32)
+ char *ansi;
+ WCHAR widename[MAX_PATH];
+ GetModuleFileNameW(NULL, widename, sizeof(widename)/sizeof(WCHAR));
+ ansi = win32_ansipath(widename);
+ sv_setpv(caret_x, ansi);
+ win32_free(ansi);
+ return;
+#else
+ /* We can try a platform-specific one if possible; if it fails, or we
+ * aren't running on a suitable platform, we'll fall back to argv[0]. */
+# ifdef USE_KERN_PROC_PATHNAME
size_t size = 0;
int mib[4];
mib[0] = CTL_KERN;
@@ -76,7 +88,7 @@ Perl_set_caret_X(pTHX) {
return;
}
}
-#elif defined(USE_NSGETEXECUTABLEPATH)
+# elif defined(USE_NSGETEXECUTABLEPATH)
char buf[1];
uint32_t size = sizeof(buf);
@@ -95,7 +107,7 @@ Perl_set_caret_X(pTHX) {
return;
}
}
-#elif defined(HAS_PROCSELFEXE)
+# elif defined(HAS_PROCSELFEXE)
char buf[MAXPATHLEN];
SSize_t len = readlink(PROCSELFEXE_PATH, buf, sizeof(buf) - 1);
/* NOTE: if the length returned by readlink() is sizeof(buf) - 1,
@@ -120,20 +132,14 @@ Perl_set_caret_X(pTHX) {
to the executable (or returning an error from the readlink). Any
@@ -133,7 +133,7 @@ Perl_set_caret_X(pTHX) {
valid path has a '/' in it somewhere, so use that to validate the
result. See http://www.freebsd.org/cgi/query-pr.cgi?pr=35703
+
+ NetBSD's implementation sometimes returns "/"; reject that too.
*/
- if (len > 0 && memchr(buf, '/', len)) {
+ if (len > 1 && memchr(buf, '/', len)) {
sv_setpvn(caret_x, buf, len);
return;
}
-#elif defined(WIN32)
- char *ansi;
- WCHAR widename[MAX_PATH];
- GetModuleFileNameW(NULL, widename, sizeof(widename)/sizeof(WCHAR));
- ansi = win32_ansipath(widename);
- sv_setpv(caret_x, ansi);
- win32_free(ansi);
- return;
-#else
+# endif
/* Fallback to this: */
sv_setpv(caret_x, PL_origargv[0]);
#endif

View file

@ -0,0 +1,34 @@
$NetBSD: patch-cpan_ExtUtils-MakeMaker_lib_ExtUtils_MM__Unix.pm,v 1.1 2019/04/23 09:27:46 adam Exp $
* $Is{NetBSD} and $Is{Interix} are unified into $Is{BSD}.
* Ignore installed packlist when creating new packlist.
--- cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm.orig 2017-04-19 13:37:05.000000000 +0000
+++ cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm
@@ -28,8 +28,6 @@ BEGIN {
$Is{VMS} = $^O eq 'VMS';
$Is{OSF} = $^O eq 'dec_osf';
$Is{IRIX} = $^O eq 'irix';
- $Is{NetBSD} = $^O eq 'netbsd';
- $Is{Interix} = $^O eq 'interix';
$Is{SunOS4} = $^O eq 'sunos';
$Is{Solaris} = $^O eq 'solaris';
$Is{SunOS} = $Is{SunOS4} || $Is{Solaris};
@@ -1022,7 +1020,7 @@ sub xs_make_dynamic_lib {
push(@m," \$(RM_F) \$\@\n");
my $libs = '$(LDLOADLIBS)';
- if (($Is{NetBSD} || $Is{Interix} || $Is{Android}) && $Config{'useshrplib'} eq 'true') {
+ if ($Is{BSD} && $Config{'useshrplib'} eq 'true') {
# Use nothing on static perl platforms, and to the flags needed
# to link against the shared libperl library on shared perl
# platforms. We peek at lddlflags to see if we need -Wl,-R
@@ -2264,7 +2262,7 @@ pure_vendor_install :: all
$(NOECHO) $(MOD_INSTALL) \
};
push @m,
-q{ read "}.$self->catfile('$(VENDORARCHEXP)','auto','$(FULLEXT)','.packlist').q{" \
+q{ read "" \
write "}.$self->catfile('$(DESTINSTALLVENDORARCH)','auto','$(FULLEXT)','.packlist').q{" \
} unless $self->{NO_PACKLIST};

View file

@ -1,16 +1,16 @@
$NetBSD: patch-dist_Storable_Makefile.PL,v 1.1 2018/09/01 08:03:02 schmonz Exp $
$NetBSD: patch-dist_Storable_Makefile.PL,v 1.2 2019/04/23 09:27:46 adam Exp $
Fix Storable build on OS X where DYLD_LIBRARY_PATH is no longer
inherited by child processes.
--- dist/Storable/Makefile.PL.orig 2018-05-21 12:29:23.000000000 +0000
--- dist/Storable/Makefile.PL.orig 2019-04-02 20:36:35.000000000 +0000
+++ dist/Storable/Makefile.PL
@@ -95,7 +95,7 @@ sub depend {
@@ -102,7 +102,7 @@ sub depend {
"
$limit_pm : stacksize \$(INST_$linktype)$extra_deps
\$(MKPATH) \$(INST_LIB)
- \$(FULLPERLRUNINST) stacksize $options
+ \$(LDLIBPTH) \$(FULLPERLRUNINST) stacksize $options
- $whichperl stacksize $options
+ \$(LDLIBPTH) $whichperl stacksize $options
release : dist
git tag \$(VERSION)

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ac,v 1.19 2014/06/04 00:21:33 dsainty Exp $
$NetBSD: patch-hints_linux.sh,v 1.1 2019/04/23 09:27:46 adam Exp $
We intentionally wire down the 'libswanted' list in the package Makefile,
so don't let the hints file add new libraries that may be found outside

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ab,v 1.21 2017/07/07 05:54:24 wiz Exp $
$NetBSD: patch-installperl,v 1.1 2019/04/23 09:27:46 adam Exp $
--- installperl.orig 2014-05-26 13:34:20.000000000 +0000
+++ installperl

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ta,v 1.6 2013/06/08 21:32:25 schmonz Exp $
$NetBSD: patch-t_io_fs.t,v 1.1 2019/04/23 09:27:46 adam Exp $
On NetBSD, filesystems may be mounted with the noatime option.

View file

@ -1,4 +1,4 @@
# $NetBSD: version.mk,v 1.4 2011/08/05 18:06:14 adam Exp $
# $NetBSD: version.mk,v 1.5 2019/04/23 09:27:46 adam Exp $
#
# Distill the PERL5_REQD list into a single value that is the highest
# version of Perl required.
@ -9,7 +9,7 @@ PERL5_REQD+= 5.0
PERL5_REQD+= ${_OPSYS_PERL_REQD}
.if !defined(_PERL5_REQD)
_PERL5_REQD?= none
_PERL5_REQD?= none
. for _version_ in ${PERL5_REQD}
. for _pkg_ in perl-${_version_}
. if !empty(_PERL5_REQD:Mnone)