libgit2: Update to 1.0.1
v1.0.1 ------ This is a bugfix release with the following changes: - Calculating information about renamed files during merges is more efficient because dissimilarity about files is now being cached and no longer needs to be recomputed. - The `git_worktree_prune_init_options` has been correctly restored for backward compatibility. In v1.0 it was incorrectly deprecated with a typo. - The optional ntlmclient dependency now supports NetBSD. - A bug where attempting to stash on a bare repository may have failed has been fixed. - Configuration files that are unreadable due to permissions are now silently ignored, and treated as if they do not exist. This matches git's behavior; previously this case would have been an error. - v4 index files are now correctly written; previously we would read them correctly but would not write the prefix-compression accurately, causing corruption. - A bug where the smart HTTP transport could not read large data packets has been fixed. Previously, fetching from servers like Gerrit, that sent large data packets, would error.
This commit is contained in:
parent
c27703bc60
commit
b4d1fde839
3 changed files with 7 additions and 26 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.48 2020/05/22 10:56:04 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.49 2020/06/09 11:04:56 nia Exp $
|
||||
|
||||
DISTNAME= libgit2-1.0.0
|
||||
PKGREVISION= 2
|
||||
DISTNAME= libgit2-1.0.1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=libgit2/}
|
||||
GITHUB_TAG= v${PKGVERSION_NOREV}
|
||||
|
@ -11,9 +10,7 @@ HOMEPAGE= https://libgit2.org/
|
|||
COMMENT= Portable, pure C implementation of the Git core methods
|
||||
LICENSE= gnu-gpl-v2 # linking exception (linking allowed in more ways)
|
||||
|
||||
EXTRACT_USING= bsdtar
|
||||
USE_CMAKE= yes
|
||||
USE_LANGUAGES= c99
|
||||
USE_TOOLS+= pkg-config
|
||||
|
||||
CMAKE_ARGS+= -DREGEX_BACKEND="pcre2"
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.21 2020/04/06 08:33:40 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.22 2020/06/09 11:04:56 nia Exp $
|
||||
|
||||
SHA1 (libgit2-1.0.0.tar.gz) = 70ea27ada7433b08c08b2706dc8520a8da2156fb
|
||||
RMD160 (libgit2-1.0.0.tar.gz) = 6b3f8c350692ff04b10a1dcc03167e7773db9617
|
||||
SHA512 (libgit2-1.0.0.tar.gz) = 7e3b6582dd1567fd5ebfc829a98e22acfd5566ba08f2fb9b7a6783fa87f5e8952ac67f1a2c13adb543e56753d858e73a03204bac17a096c72f5daf4ba376d904
|
||||
Size (libgit2-1.0.0.tar.gz) = 5312324 bytes
|
||||
SHA1 (patch-deps_ntlmclient_compat.h) = c808fccd9ee6bc99f0620cd8820fbdb301d4c42b
|
||||
SHA1 (libgit2-1.0.1.tar.gz) = 9f5702ae1e13e7f9fb0128069b3aa62bf933b9c5
|
||||
RMD160 (libgit2-1.0.1.tar.gz) = f4d42e0348758a189cf6d3e68ede4ad2fe151e33
|
||||
SHA512 (libgit2-1.0.1.tar.gz) = 7c307822b22e3771e5e908b115600310f7901b3250287532c498003b25a5b1e007bfa23592f16ec4d83c1567a9213710526f78cab7c120316e9a8fc74c5e57a9
|
||||
Size (libgit2-1.0.1.tar.gz) = 5312878 bytes
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-deps_ntlmclient_compat.h,v 1.2 2020/04/06 08:33:41 wiz Exp $
|
||||
|
||||
NetBSD does not have htonll.
|
||||
|
||||
--- deps/ntlmclient/compat.h.orig 2020-04-01 13:49:12.000000000 +0000
|
||||
+++ deps/ntlmclient/compat.h
|
||||
@@ -21,7 +21,7 @@
|
||||
# include <stdbool.h>
|
||||
#endif
|
||||
|
||||
-#ifdef __linux__
|
||||
+#if defined(__linux__) || defined(__NetBSD__)
|
||||
/* See man page endian(3) */
|
||||
# include <endian.h>
|
||||
# define htonll htobe64
|
Loading…
Reference in a new issue