Patch around problem in configure script directly, using a patch
from uwe in PR 49522. Remove autoconf dependency.
This commit is contained in:
parent
ff71751305
commit
b4ec221fb1
3 changed files with 22 additions and 7 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.11 2015/01/02 12:56:37 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.12 2015/01/02 22:34:02 wiz Exp $
|
||||
|
||||
DISTNAME= idutils-4.6
|
||||
CATEGORIES= devel
|
||||
|
@ -13,8 +13,7 @@ LICENSE= gnu-gpl-v3
|
|||
CONFLICTS= sh-utils>=2.0nb2 coreutils-[0-9]*
|
||||
|
||||
USE_PKGLOCALEDIR= yes
|
||||
# autoconf needed for 4.6; see PR 49522; can probably be removed on next update
|
||||
USE_TOOLS+= autoconf msgfmt
|
||||
USE_TOOLS+= msgfmt
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV+= ac_cv_prog_EMACS=no
|
||||
|
@ -27,9 +26,6 @@ MAKE_FLAGS+= elc_SCRIPTS=
|
|||
LISPDIR= ${PREFIX}/share/emacs/site-lisp
|
||||
INSTALLATION_DIRS= ${LISPDIR}
|
||||
|
||||
pre-configure:
|
||||
cd ${WRKSRC} && autoconf
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/lisp/idutils.el ${DESTDIR}${LISPDIR}
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.7 2014/12/15 11:35:42 mef Exp $
|
||||
$NetBSD: distinfo,v 1.8 2015/01/02 22:34:02 wiz Exp $
|
||||
|
||||
SHA1 (idutils-4.6.tar.xz) = cb977ce3e4b2bacda85797e9048986e1c1765148
|
||||
RMD160 (idutils-4.6.tar.xz) = 9b136e5bedf04183a631c1c7642c7982deb5016d
|
||||
|
@ -12,5 +12,6 @@ SHA1 (patch-ai) = 5e64a7c67075a3d308b6e66252559afa20d02639
|
|||
SHA1 (patch-aj) = 8381724be238e518a86377b3226cf05e99b83f1d
|
||||
SHA1 (patch-ak) = c2b3573a5386e77fc6bc1d5a4e89ccd1af830630
|
||||
SHA1 (patch-al) = 163e06074da62edbcacd459788cfea3528e94e30
|
||||
SHA1 (patch-configure) = 06e53f65b7515276f054049c502b3187ba7a156f
|
||||
SHA1 (patch-lib_fflush_c) = 41e1dcfc0982148d1a2c7cceb6aa117c1ded774a
|
||||
SHA1 (patch-lib_fseeko_c) = 35ac50c58f8d6339d37ff72a0e2b58f0233a7cc0
|
||||
|
|
18
devel/idutils/patches/patch-configure
Normal file
18
devel/idutils/patches/patch-configure
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-configure,v 1.1 2015/01/02 22:34:02 wiz Exp $
|
||||
|
||||
Fix autoconf bug when /bin/bash exists.
|
||||
PR 49522
|
||||
|
||||
--- configure.orig 2012-02-03 10:41:35.000000000 +0000
|
||||
+++ configure
|
||||
@@ -479,6 +479,10 @@ as_cr_alnum=$as_cr_Letters$as_cr_digits
|
||||
chmod +x "$as_me.lineno" ||
|
||||
{ $as_echo "$as_me: error: cannot create $as_me.lineno; rerun with a POSIX shell" >&2; as_fn_exit 1; }
|
||||
|
||||
+ # If we had to re-execute with $CONFIG_SHELL, we're ensured to have
|
||||
+ # already done that, so ensure we don't try to do so again and fall
|
||||
+ # in an infinite loop. This has already happened in practice.
|
||||
+ _as_can_reexec=no; export _as_can_reexec
|
||||
# Don't try to exec as it changes $[0], causing all sort of problems
|
||||
# (the dirname of $[0] is not the place where we might find the
|
||||
# original and so on. Autoconf is especially sensitive to this).
|
Loading…
Reference in a new issue