Update to 0.1.0:
0.1.0 (3 March 2007) General improvements: * Add on-demand compilation driver (Aleksey Demakov, Klaus Treichel). * Add jit_function_from_vtable_pointer function (Klaus Treichel). * Add jit_insn_mark_breakpoint_variable function (Radek Polak). * Add signal handlers (Kirill Kononenko). * Add JIT_OPTION_POSITION_INDEPENDENT context option (not supported by the backends yet) (Aleksey Demakov). * Add function indirectors (Klaus Treichel). * Allocate function redirectors and indirectors in the code cache (Aleksey Demakov). * Use mmap to allocate executable memory where available (Klaus Treichel). * Now can dump to any stream not just stdout and stderr (Radek Polak). * Use a global lock during context initialization (Aleksey Demakov). * Fix problems that take place after compilation is restarted on cache page overflow (Aleksey Demakov). ...and more, see the NEWS file.
This commit is contained in:
parent
0491e08655
commit
b50fbe3e36
3 changed files with 8 additions and 31 deletions
|
@ -1,10 +1,10 @@
|
|||
# $NetBSD: Makefile,v 1.12 2007/11/17 12:04:11 rillig Exp $
|
||||
# $NetBSD: Makefile,v 1.13 2008/02/18 15:51:44 xtraeme Exp $
|
||||
#
|
||||
|
||||
DISTNAME= libjit-0.0.4
|
||||
PKGREVISION= 1
|
||||
DISTNAME= libjit-0.1.0
|
||||
#PKGREVISION= 1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.southern-storm.com.au/download/
|
||||
MASTER_SITES= http://download.savannah.gnu.org/releases/dotgnu-pnet/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.southern-storm.com.au/libjit.html
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.4 2006/01/09 19:00:43 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.5 2008/02/18 15:51:44 xtraeme Exp $
|
||||
|
||||
SHA1 (libjit-0.0.4.tar.gz) = 663055ee5bb600e9dfd28c03456a66bf2b66811b
|
||||
RMD160 (libjit-0.0.4.tar.gz) = e8ff27b3f1e0dbff0ed6cc1d5fd2a5cc4a74f1fd
|
||||
Size (libjit-0.0.4.tar.gz) = 580278 bytes
|
||||
SHA1 (patch-aa) = e5c58111aad14e4ead390fa55630b06cdf2711da
|
||||
SHA1 (libjit-0.1.0.tar.gz) = db279db806f33ac8c6dba2b6e5f4fb5976e46afb
|
||||
RMD160 (libjit-0.1.0.tar.gz) = b711e46425fb8bc03ca289f0cf1af71b890ecfb6
|
||||
Size (libjit-0.1.0.tar.gz) = 1092908 bytes
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.3 2006/01/09 19:00:43 joerg Exp $
|
||||
|
||||
--- jit/jit-cpuid-x86.c.orig 2006-01-09 18:53:59.000000000 +0000
|
||||
+++ jit/jit-cpuid-x86.c
|
||||
@@ -57,6 +57,7 @@ static void cpuid_query(unsigned int ind
|
||||
{
|
||||
#if defined(__GNUC__)
|
||||
__asm__ __volatile__ (
|
||||
+ "\tpushl %%ebx\n"
|
||||
"\tmovl %0, %%eax\n"
|
||||
"\txorl %%ebx, %%ebx\n"
|
||||
"\txorl %%ecx, %%ecx\n"
|
||||
@@ -68,7 +69,8 @@ static void cpuid_query(unsigned int ind
|
||||
"\tmovl %%ebx, 4(%%esi)\n"
|
||||
"\tmovl %%ecx, 8(%%esi)\n"
|
||||
"\tmovl %%edx, 12(%%esi)\n"
|
||||
- : : "m"(index), "m"(info) : "eax", "ebx", "ecx", "edx", "esi"
|
||||
+ "\tpopl %%ebx\n"
|
||||
+ : : "m"(index), "m"(info) : "eax", "ecx", "edx", "esi"
|
||||
);
|
||||
#endif
|
||||
}
|
Loading…
Reference in a new issue