Import musepack-0rc475 as audio/musepack.

This is a speed and portability optimized version of Andree Buschmann's
MPEG-Plus decoder.
This commit is contained in:
wiz 2014-04-18 12:43:42 +00:00
parent 7ccf95a4bd
commit b5108d4ed6
6 changed files with 75 additions and 0 deletions

2
audio/musepack/DESCR Normal file
View file

@ -0,0 +1,2 @@
This is a speed and portability optimized version of Andree Buschmann's
MPEG-Plus decoder.

23
audio/musepack/Makefile Normal file
View file

@ -0,0 +1,23 @@
# $NetBSD: Makefile,v 1.1 2014/04/18 12:43:42 wiz Exp $
DISTNAME= musepack_src_r475
PKGNAME= musepack-0rc475
CATEGORIES= audio
MASTER_SITES= http://files.musepack.net/source/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.musepack.net/
COMMENT= MPEG-Plus and MusePack decoder (V8)
LICENSE= modified-bsd
USE_CMAKE= yes
INSTALLATION_DIRS= lib
post-install:
rm -rf ${DESTDIR}${PREFIX}/include/mpc/.svn/
${INSTALL_LIB} ${WRKSRC}/libmpcdec/libmpcdec.so ${DESTDIR}${PREFIX}/lib
.include "../../audio/libcuefile/buildlink3.mk"
.include "../../audio/libreplaygain/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

16
audio/musepack/PLIST Normal file
View file

@ -0,0 +1,16 @@
@comment $NetBSD: PLIST,v 1.1 2014/04/18 12:43:42 wiz Exp $
bin/mpc2sv8
bin/mpcchap
bin/mpccut
bin/mpcdec
bin/mpcenc
bin/mpcgain
bin/wavcmp
include/mpc/datatypes.h
include/mpc/minimax.h
include/mpc/mpc_types.h
include/mpc/mpcdec.h
include/mpc/mpcmath.h
include/mpc/reader.h
include/mpc/streaminfo.h
lib/libmpcdec.so

View file

@ -0,0 +1,13 @@
# $NetBSD: buildlink3.mk,v 1.1 2014/04/18 12:43:42 wiz Exp $
BUILDLINK_TREE+= musepack
.if !defined(MUSEPACK_BUILDLINK3_MK)
MUSEPACK_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.musepack+= musepack>=0rc475
BUILDLINK_PKGSRCDIR.musepack?= ../../audio/musepack
.endif # MUSEPACK_BUILDLINK3_MK
BUILDLINK_TREE+= -musepack

6
audio/musepack/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2014/04/18 12:43:42 wiz Exp $
SHA1 (musepack_src_r475.tar.gz) = bdd4042773eb5c885df70d7a19914fa6e2306391
RMD160 (musepack_src_r475.tar.gz) = 622d04eeb309beacd2b6bb650178dcdc42773db2
Size (musepack_src_r475.tar.gz) = 188737 bytes
SHA1 (patch-mpcenc_keyboard.c) = 42e038f003c64369e245e3688f6f0783bd2d443a

View file

@ -0,0 +1,15 @@
$NetBSD: patch-mpcenc_keyboard.c,v 1.1 2014/04/18 12:43:42 wiz Exp $
Add header for struct timeval.
--- mpcenc/keyboard.c.orig 2006-12-19 19:39:02.000000000 +0000
+++ mpcenc/keyboard.c
@@ -52,6 +52,8 @@ CheckKey ( void )
#else
+#include <sys/time.h>
+
# ifdef USE_TERMIOS
# include <termios.h>