Update xmame to 0.77.1.

Changes since 0.74.1 includes:
- Everything from MAME 0.77.
- Ported two more effects from AdvanceMAME: hq2x and lq2x.  (Pieter
  Hulshoff)
- Adjusted and cleaned up some YUV code.  (Alastair Robinson)
This commit is contained in:
kristerw 2003-12-03 00:17:22 +00:00
parent c65f30767e
commit b5182f0ff3
3 changed files with 10 additions and 58 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.100 2003/09/20 00:45:26 kristerw Exp $
# $NetBSD: Makefile,v 1.101 2003/12/03 00:17:22 kristerw Exp $
#
DISTNAME= xmame-0.74.1
DISTNAME= xmame-0.77.1
CATEGORIES= emulators games x11
MASTER_SITES= http://x.mame.net/download/
EXTRACT_SUFX= .tar.bz2
@ -77,6 +77,11 @@ MAKE_FLAGS+= JOY_USB=1
. endif
.endif
.if !empty(CC_VERSION:Mgcc-2*)
# Prevent memory explosion for gcc 2.95 and older.
MAKE_FLAGS+= LOW_MEM=1
.endif
OWN_DIRS= ${SPOOLDIR}
post-configure:

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.41 2003/09/20 00:45:27 kristerw Exp $
$NetBSD: distinfo,v 1.42 2003/12/03 00:17:22 kristerw Exp $
SHA1 (xmame-0.74.1.tar.bz2) = e58ff982cce38cd0b17ed18999580e1e456c4895
Size (xmame-0.74.1.tar.bz2) = 11344029 bytes
SHA1 (xmame-0.77.1.tar.bz2) = 2120ef8858e83c601f8ad00cbd315bc56f75f18a
Size (xmame-0.77.1.tar.bz2) = 12036528 bytes
SHA1 (patch-aa) = cf7e599022fe0b3bc6f12d57c4c2d5ece7d82d0a
SHA1 (patch-ad) = 1d9726bb43e53da8f8edc56d4aa0929d890496d0
SHA1 (patch-ae) = df9ce91871bfcff611ff8f616482d4ff2e8204a3

View file

@ -1,52 +0,0 @@
$NetBSD: patch-ad,v 1.4 2003/05/27 12:42:40 kristerw Exp $
--- src/unix/video-drivers/blit.h.orig Sat May 24 21:36:36 2003
+++ src/unix/video-drivers/blit.h Tue May 27 13:57:14 2003
@@ -27,6 +27,13 @@
These routines use long copies so everything should always be long aligned.
*/
+#if __GNUC__ <= 2
+/* The massive unrolling in this file causes a memory explosion in
+ * GCC 2.95 (e.g. x11_window.c needas about 450 Mbytes of memory
+ * to compile). Limit the code unrolling for GCC 2.x. */
+#define BROKEN_COMPILER
+#endif
+
#ifdef PACK_BITS
/* scale destptr delta's by 3/4 since we're using 32 bits ptr's for a 24 bits
dest */
@@ -156,6 +163,7 @@
+#ifndef BROKEN_COMPILER
case 2:
#define SCALE_X(X) ((X)*2)
#ifdef INDIRECT
@@ -265,6 +273,7 @@
#include "blit_core.h"
break;
+#endif /* #ifndef BROKEN_COMPILER */
#undef SCALE_X
#undef COPY_LINE2
@@ -517,6 +526,7 @@
#define SCALE_Y(Y) ((Y)<<1)
/* 1x2 no scanlines */
+#ifndef BROKEN_COMPILER
case 0x00102:
#ifdef DOUBLEBUFFER
@@ -958,6 +968,10 @@
/* This is what happens when you give an assembly-language programmer
a C compiler. Thanks to td, of course. -JDL */
+#endif /* #ifndef BROKEN_COMPILER */
+#undef COPY_LINE2
+#undef SCALE_X
+#undef SCALE_Y
default:
#ifdef INDIRECT