fix non-portable times(NULL) invocation which made "dvdunauthor"

crash on NetBSD, bump PKGREVISION
This commit is contained in:
drochner 2009-09-07 18:25:20 +00:00
parent 1c1592002e
commit b52802af5e
3 changed files with 34 additions and 3 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.18 2009/08/26 21:20:14 sno Exp $
# $NetBSD: Makefile,v 1.19 2009/09/07 18:25:20 drochner Exp $
DISTNAME= dvdauthor-0.6.14
PKGREVISION= 3
PKGREVISION= 4
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=dvdauthor/}

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.7 2007/11/11 16:59:26 wiz Exp $
$NetBSD: distinfo,v 1.8 2009/09/07 18:25:20 drochner Exp $
SHA1 (dvdauthor-0.6.14.tar.gz) = 493412bf103069b9261af3be1bc23da56d7d112a
RMD160 (dvdauthor-0.6.14.tar.gz) = b5d75b613c3be1e41ea5c3f247a993723430977a
Size (dvdauthor-0.6.14.tar.gz) = 319371 bytes
SHA1 (patch-aa) = cb9ef061b2384c434d7c6b166b1fdb812d2999e2

View file

@ -0,0 +1,30 @@
$NetBSD: patch-aa,v 1.3 2009/09/07 18:25:20 drochner Exp $
--- src/dvdunauthor.c.orig 2009-09-05 13:45:16.000000000 +0200
+++ src/dvdunauthor.c
@@ -818,6 +818,7 @@ static void getVobs( dvd_reader_t *dvd,
cell_adr_t *cells;
int numcells,i,j,totalsect,numsect;
clock_t start,now,clkpsec;
+ struct tms unused_tms;
cptr=titlef?ifo->vts_c_adt:ifo->menu_c_adt;
if( cptr ) {
@@ -836,7 +837,7 @@ static void getVobs( dvd_reader_t *dvd,
for( i=0; i<numcells; i++ )
totalsect += cells[i].last_sector - cells[i].start_sector + 1;
clkpsec=sysconf(_SC_CLK_TCK);
- start=times(NULL);
+ start=times(&unused_tms);
for( i=0; i<numcells; i++ ) {
int h,b,plen;
@@ -874,7 +875,7 @@ static void getVobs( dvd_reader_t *dvd,
for( b=cells[i].start_sector; b<=cells[i].last_sector; b+=BIGBLOCKSECT ) {
int rl=cells[i].last_sector+1-b;
if( rl > BIGBLOCKSECT ) rl = BIGBLOCKSECT;
- now=times(NULL);
+ now=times(&unused_tms);
if( now-start>3*clkpsec && numsect>0 ) {
int rmn=(totalsect-numsect)*(now-start)/(numsect*clkpsec);
fprintf(stderr,"STAT: [%d] VOB %d, Cell %d (%d%%, %d:%02d remain)\r",i,cells[i].vob_id,cells[i].cell_id,(numsect*100+totalsect/2)/totalsect,rmn/60,rmn%60);