Update to 0.1.1

pkgsrc changes:
- Use the 'dep' version to install roundcube with no included dependencies
  and instead manage it all through pkgsrc - suggestion from schmonz@
- Move the config files to ${PREFIX}/share/roundcube/config as it was
  becomming difficult to manage them under ${PKG_SYSCONFDIR}
- Add the GUI installer scripts to the install so users can use it for the
  initial setup and generation of the configuration files.
- Add a note to the roundcube.conf file about protection of the
  installer directory once initially used.
- Don't assume apache is the only supported web server (because it's not)
  we don't support any additional ones now but this will make integration
  down the track easier if we do.
- Increased PKG_SUGGESTED_OPTIONS based on documentation in the INSTALL file.
- Add more required PHP options to roundcube.conf

Thanks to Dan Engholm for feedback on the package.

From the ChangeLog:
* Clear selection when selecting single item (1484942)
* Remove hard-coded image size in skin templates (1484893)
* Database schema improvements (dropped unnecessary indexes)
* Fixed creating a new folder with a comma in its name (1484681)
* Fixed sorting of messages when default mailbox is empty (1484317)
* Improve message previewpane - less loading (1484316)
* Fixed login form autocompletion (1484839)
* Fixed virtuser_query option for mdb2 backend (1484874)
* Fixed attachment resoting from Drafts when message body was empty (1484506)
* Fixed usage of ob_gzhandler (1484851)
* Fixed message part window in IE6 (1484610)
* Fixed decoding of mime-encoded strings (1484191)
* Fixed some iconv/mb_string problems (1484598)
* Correctly quote mailbox name when using in URL (1484313)
* Fixed "headers already sent" errors (1484860)
This commit is contained in:
adrianp 2008-05-04 16:34:03 +00:00
parent 8130cb4c25
commit b539000eea
9 changed files with 233 additions and 255 deletions

View file

@ -1,5 +1,5 @@
===========================================================================
$NetBSD: MESSAGE,v 1.4 2008/03/15 13:54:58 adrianp Exp $
$NetBSD: MESSAGE,v 1.5 2008/05/04 16:34:03 adrianp Exp $
Please refer to the following file on how to setup your RoundCube
installation.
@ -9,7 +9,7 @@ installation.
For pkgsrc installations the RoundCube package is installed in
non-default locations.
Configuration files: ${PKG_SYSCONFDIR}/roundcube/
Configuration files: ${RCDIR}/config/
Log files: ${VARBASE}/log/roundcube/
Document root: ${PREFIX}/share/roundcube/
@ -19,4 +19,9 @@ to httpd.conf:
Include ${PKG_SYSCONFDIR}/roundcube.conf
NOTE: As of version 0.1.1 the location of some of the roundcube
configuration files have changed. In addition to this please read the
note in the ${PKG_SYSCONFDIR}/roundcube.conf file about the
protection of the installer directory.
===========================================================================

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.8 2008/03/15 13:54:59 adrianp Exp $
# $NetBSD: Makefile,v 1.9 2008/05/04 16:34:03 adrianp Exp $
#
DISTNAME= roundcubemail-0.1
PKGNAME= ${DISTNAME:S/mail//}
DISTNAME= roundcubemail-${VERSION}-dep
PKGNAME= ${DISTNAME:S/mail-${VERSION}-dep/-${VERSION}/}
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=roundcubemail/}
@ -12,49 +12,54 @@ COMMENT= Browser-based multilingual IMAP client
USE_LANGUAGES= # none
NO_BUILD= yes
VERSION= 0.1.1
.include "../../mk/bsd.prefs.mk"
.include "../../lang/php/phpversion.mk"
PKG_SYSCONFSUBDIR?= httpd
DEPENDS+= ${PHP_PKG_PREFIX}-pear-Net_SMTP>=1.2.10:../../net/pear-Net_SMTP
DEPENDS+= ${PHP_PKG_PREFIX}-pear-Mail_Mime>=1.3:../../mail/pear-Mail_Mime
DEPENDS+= ${PHP_PKG_PREFIX}-pear-MDB2>=2.4.1:../../databases/pear-MDB2
DEPENDS+= ${PHP_PKG_PREFIX}-pear-Auth_SASL-[0-9]*:../../mail/pear-Auth_SASL
PKG_GROUPS_VARS+= APACHE_GROUP
PKG_USERS_VARS+= APACHE_USER
BUILD_DEFS+= VARBASE APACHE_USER APACHE_GROUP
PKG_SYSCONFSUBDIR?= roundcube
RCDIR= ${PREFIX}/share/roundcube
EGDIR= ${PREFIX}/share/examples/roundcube
DOCDIR= ${PREFIX}/share/doc/roundcube
PAX_DIRS= program skins
WWW_USER?= ${APACHE_USER}
WWW_GROUP?= ${APACHE_GROUP}
MESSAGE_SUBST+= DOCDIR=${DOCDIR:Q} PKG_SYSCONFDIR=${PKG_SYSCONFDIR:Q}
MESSAGE_SUBST+= VARBASE=${VARBASE:Q}
FILES_SUBST+= RCDIR=${RCDIR:Q}
PKG_GROUPS_VARS+= WWW_GROUP
PKG_USERS_VARS+= WWW_USER
BUILD_DEFS+= VARBASE WWW_USER WWW_GROUP APACHE_USER APACHE_GROUP
OWN_DIRS+= ${PKG_SYSCONFDIR}/roundcube
OWN_DIRS_PERMS+=${VARBASE}/log/roundcube ${APACHE_USER} ${APACHE_GROUP} 0755
OWN_DIRS_PERMS+=${VARBASE}/tmp/roundcube ${APACHE_USER} ${APACHE_GROUP} 0755
RCDIR= ${PREFIX}/share/roundcube
EGDIR= ${PREFIX}/share/examples/roundcube
DOCDIR= ${PREFIX}/share/doc/roundcube
PAX_DIRS= program skins installer
CONF_FILES= ${EGDIR}/roundcube.conf ${PKG_SYSCONFDIR}/roundcube.conf
CONF_FILES_PERMS+= \
${EGDIR}/db.inc.php ${PKG_SYSCONFDIR}/roundcube/db.inc.php \
${ROOT_USER} ${APACHE_GROUP} 0640 \
${EGDIR}/main.inc.php ${PKG_SYSCONFDIR}/roundcube/main.inc.php \
${ROOT_USER} ${APACHE_GROUP} 0640
MESSAGE_SUBST+= DOCDIR=${DOCDIR:Q} PKG_SYSCONFDIR=${PKG_SYSCONFDIR:Q}
MESSAGE_SUBST+= VARBASE=${VARBASE:Q} RCDIR=${RCDIR:Q}
FILES_SUBST+= RCDIR=${RCDIR:Q}
OWN_DIRS_PERMS+= ${VARBASE}/log/roundcube \
${WWW_USER} ${WWW_GROUP} 0755
OWN_DIRS_PERMS+= ${VARBASE}/tmp/roundcube \
${WWW_USER} ${WWW_GROUP} 0755
CONF_FILES= ${EGDIR}/roundcube.conf \
${PKG_SYSCONFDIR}/roundcube.conf
SUBST_CLASSES+= files
SUBST_STAGE.files= do-configure
SUBST_FILES.files= roundcube.conf
SUBST_FILES.files+= config/main.inc.php.dist
SUBST_FILES.files+= program/include/main.inc
SUBST_SED.files= -e "s|@RCDIR@|${RCDIR}|g"
SUBST_SED.files+= -e "s|@VARBASE@|${VARBASE}|g"
SUBST_SED.files+= -e "s|@PKG_SYSCONFDIR@|${PKG_SYSCONFDIR}|g"
SUBST_MESSAGE.files= Fixing configuration files.
INSTALLATION_DIRS= ${RCDIR}/program ${RCDIR}/skins ${EGDIR}/SQL ${DOCDIR}
.include "options.mk"
.include "../../mk/apache.mk"
.include "options.mk"
post-extract:
${CP} ${FILESDIR}/roundcube.conf ${WRKSRC}/roundcube.conf
@ -63,6 +68,7 @@ pre-install:
${FIND} ${WRKSRC} -name "*.orig" -print | ${XARGS} ${RM} -f
do-install:
${INSTALL_DATA_DIR} ${RCDIR}/config
${INSTALL_DATA} ${WRKSRC}/roundcube.conf ${EGDIR}/roundcube.conf
${INSTALL_DATA} ${WRKSRC}/INSTALL ${DOCDIR}
${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCDIR}
@ -72,17 +78,27 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/SQL/*.sql ${EGDIR}/SQL/
${INSTALL_DATA} ${WRKSRC}/.htaccess ${RCDIR}/
${INSTALL_DATA} ${WRKSRC}/index.php ${RCDIR}/
${INSTALL_DATA} ${WRKSRC}/robots.txt ${RCDIR}/
${INSTALL_DATA} ${WRKSRC}/config/db.inc.php.dist ${EGDIR}/db.inc.php
${INSTALL_DATA} ${WRKSRC}/config/main.inc.php.dist ${EGDIR}/main.inc.php
${INSTALL_DATA} ${WRKSRC}/config/db.inc.php.dist \
${EGDIR}/db.inc.php.dist
${INSTALL_DATA} ${WRKSRC}/config/main.inc.php.dist \
${EGDIR}/main.inc.php.dist
${INSTALL_DATA} ${WRKSRC}/config/db.inc.php.dist \
${RCDIR}/config/db.inc.php.dist
${INSTALL_DATA} ${WRKSRC}/config/main.inc.php.dist \
${RCDIR}/config/main.inc.php.dist
.for i in ${PAX_DIRS}
cd ${WRKSRC}/${i} && ${PAX} -rw . ${RCDIR}/${i}
${FIND} ${RCDIR}/${i} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
${FIND} ${RCDIR}/${i} -type d | ${XARGS} ${CHMOD} ${PKGDIRMODE}
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${RCDIR}/${i}
.endfor
${CHMOD} ${PKGDIRMODE} ${RCDIR}/config
${CHOWN} ${WWW_USER}:${WWW_GROUP} ${RCDIR}/config
${CHOWN} ${WWW_USER}:${WWW_GROUP} ${RCDIR}/config/*.dist
. for i in ${PAX_DIRS}
cd ${WRKSRC}/${i} && ${PAX} -rw . ${RCDIR}/${i}
${FIND} ${RCDIR}/${i} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
${FIND} ${RCDIR}/${i} -type d | ${XARGS} ${CHMOD} ${PKGDIRMODE}
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${RCDIR}/${i}
. endfor
.include "../../mk/bsd.pkg.mk"

View file

@ -1,37 +1,51 @@
@comment $NetBSD: PLIST,v 1.5 2008/03/15 13:54:59 adrianp Exp $
@comment $NetBSD: PLIST,v 1.6 2008/05/04 16:34:03 adrianp Exp $
share/doc/roundcube/INSTALL
share/doc/roundcube/LICENSE
share/doc/roundcube/README
share/doc/roundcube/UPGRADING
share/examples/roundcube/SQL/mssql.initial.sql
share/examples/roundcube/SQL/mysql.initial.sql
share/examples/roundcube/SQL/mysql.update-0.1a.sql
share/examples/roundcube/SQL/mysql.update.sql
share/examples/roundcube/SQL/mysql5.initial.sql
share/examples/roundcube/SQL/postgres.initial.sql
share/examples/roundcube/SQL/postgres.update.sql
share/examples/roundcube/SQL/sqlite.initial.sql
share/examples/roundcube/SQL/sqlite.update.sql
share/examples/roundcube/db.inc.php
share/examples/roundcube/main.inc.php
share/examples/roundcube/db.inc.php.dist
share/examples/roundcube/main.inc.php.dist
share/examples/roundcube/roundcube.conf
share/roundcube/.htaccess
share/roundcube/index.php
share/roundcube/config/db.inc.php.dist
share/roundcube/config/main.inc.php.dist
share/roundcube/installer/check.php
share/roundcube/installer/client.js
share/roundcube/installer/config.php
share/roundcube/installer/images/add.png
share/roundcube/installer/images/banner_bg.gif
share/roundcube/installer/images/banner_logo.gif
share/roundcube/installer/images/banner_right.gif
share/roundcube/installer/images/delete.png
share/roundcube/installer/index.php
share/roundcube/installer/rcube_install.php
share/roundcube/installer/styles.css
share/roundcube/installer/test.php
share/roundcube/installer/welcome.html
share/roundcube/program/blank.gif
share/roundcube/program/blocked.gif
share/roundcube/program/include/bugs.inc
share/roundcube/program/include/rcube_html.inc
share/roundcube/program/include/rcube_user.inc
share/roundcube/program/include/main.inc
share/roundcube/program/include/rcmail_template.inc
share/roundcube/program/include/rcube_contacts.inc
share/roundcube/program/include/rcube_db.inc
share/roundcube/program/include/rcube_html.inc
share/roundcube/program/include/rcube_imap.inc
share/roundcube/program/include/rcube_ldap.inc
share/roundcube/program/include/rcube_mdb2.inc
share/roundcube/program/include/rcube_shared.inc
share/roundcube/program/include/rcube_smtp.inc
share/roundcube/program/include/rcube_sqlite.inc
share/roundcube/program/include/rcube_user.inc
share/roundcube/program/include/session.inc
share/roundcube/program/js/app.js
share/roundcube/program/js/common.js
@ -149,6 +163,7 @@ share/roundcube/program/js/tiny_mce/themes/advanced/about.htm
share/roundcube/program/js/tiny_mce/themes/advanced/anchor.htm
share/roundcube/program/js/tiny_mce/themes/advanced/charmap.htm
share/roundcube/program/js/tiny_mce/themes/advanced/color_picker.htm
share/roundcube/program/js/tiny_mce/themes/advanced/css/editor_content.css
share/roundcube/program/js/tiny_mce/themes/advanced/css/editor_popup.css
share/roundcube/program/js/tiny_mce/themes/advanced/docs/en/about.htm
share/roundcube/program/js/tiny_mce/themes/advanced/docs/en/common_buttons.htm
@ -250,101 +265,6 @@ share/roundcube/program/js/tiny_mce/utils/form_utils.js
share/roundcube/program/js/tiny_mce/utils/mclayer.js
share/roundcube/program/js/tiny_mce/utils/mctabs.js
share/roundcube/program/js/tiny_mce/utils/validate.js
share/roundcube/program/lib/Auth/SASL.php
share/roundcube/program/lib/Auth/SASL/Anonymous.php
share/roundcube/program/lib/Auth/SASL/Common.php
share/roundcube/program/lib/Auth/SASL/CramMD5.php
share/roundcube/program/lib/Auth/SASL/DigestMD5.php
share/roundcube/program/lib/Auth/SASL/Login.php
share/roundcube/program/lib/Auth/SASL/Plain.php
share/roundcube/program/lib/DB.php
share/roundcube/program/lib/DB/common.php
share/roundcube/program/lib/DB/dbase.php
share/roundcube/program/lib/DB/fbsql.php
share/roundcube/program/lib/DB/ibase.php
share/roundcube/program/lib/DB/ifx.php
share/roundcube/program/lib/DB/msql.php
share/roundcube/program/lib/DB/mssql.php
share/roundcube/program/lib/DB/mysql.php
share/roundcube/program/lib/DB/mysqli.php
share/roundcube/program/lib/DB/oci8.php
share/roundcube/program/lib/DB/odbc.php
share/roundcube/program/lib/DB/pgsql.php
share/roundcube/program/lib/DB/sqlite.php
share/roundcube/program/lib/DB/storage.php
share/roundcube/program/lib/DB/sybase.php
share/roundcube/program/lib/Mail/mime.php
share/roundcube/program/lib/Mail/mimeDecode.php
share/roundcube/program/lib/Mail/mimePart.php
share/roundcube/program/lib/MDB2.php
share/roundcube/program/lib/MDB2/Date.php
share/roundcube/program/lib/MDB2/Driver/Datatype/Common.php
share/roundcube/program/lib/MDB2/Driver/Datatype/mssql.php
share/roundcube/program/lib/MDB2/Driver/Datatype/mysql.php
share/roundcube/program/lib/MDB2/Driver/Datatype/mysqli.php
share/roundcube/program/lib/MDB2/Driver/Datatype/pgsql.php
share/roundcube/program/lib/MDB2/Driver/Datatype/sqlite.php
share/roundcube/program/lib/MDB2/Driver/Function/Common.php
share/roundcube/program/lib/MDB2/Driver/Function/mssql.php
share/roundcube/program/lib/MDB2/Driver/Function/mysql.php
share/roundcube/program/lib/MDB2/Driver/Function/mysqli.php
share/roundcube/program/lib/MDB2/Driver/Function/pgsql.php
share/roundcube/program/lib/MDB2/Driver/Function/sqlite.php
share/roundcube/program/lib/MDB2/Driver/Manager/Common.php
share/roundcube/program/lib/MDB2/Driver/Manager/mssql.php
share/roundcube/program/lib/MDB2/Driver/Manager/mysql.php
share/roundcube/program/lib/MDB2/Driver/Manager/mysqli.php
share/roundcube/program/lib/MDB2/Driver/Manager/pgsql.php
share/roundcube/program/lib/MDB2/Driver/Manager/sqlite.php
share/roundcube/program/lib/MDB2/Driver/Native/Common.php
share/roundcube/program/lib/MDB2/Driver/Native/mssql.php
share/roundcube/program/lib/MDB2/Driver/Native/mysql.php
share/roundcube/program/lib/MDB2/Driver/Native/mysqli.php
share/roundcube/program/lib/MDB2/Driver/Native/pgsql.php
share/roundcube/program/lib/MDB2/Driver/Native/sqlite.php
share/roundcube/program/lib/MDB2/Driver/Reverse/Common.php
share/roundcube/program/lib/MDB2/Driver/Reverse/mssql.php
share/roundcube/program/lib/MDB2/Driver/Reverse/mysql.php
share/roundcube/program/lib/MDB2/Driver/Reverse/mysqli.php
share/roundcube/program/lib/MDB2/Driver/Reverse/pgsql.php
share/roundcube/program/lib/MDB2/Driver/Reverse/sqlite.php
share/roundcube/program/lib/MDB2/Driver/mssql.php
share/roundcube/program/lib/MDB2/Driver/mysql.php
share/roundcube/program/lib/MDB2/Driver/mysqli.php
share/roundcube/program/lib/MDB2/Driver/pgsql.php
share/roundcube/program/lib/MDB2/Driver/sqlite.php
share/roundcube/program/lib/MDB2/Extended.php
share/roundcube/program/lib/MDB2/Iterator.php
share/roundcube/program/lib/MDB2/LOB.php
share/roundcube/program/lib/Net/SMTP.php
share/roundcube/program/lib/Net/Socket.php
share/roundcube/program/lib/PEAR.php
share/roundcube/program/lib/des.inc
share/roundcube/program/lib/encoding/CP1250.map
share/roundcube/program/lib/encoding/CP1251.map
share/roundcube/program/lib/encoding/CP1252.map
share/roundcube/program/lib/encoding/CP1253.map
share/roundcube/program/lib/encoding/CP1254.map
share/roundcube/program/lib/encoding/CP1255.map
share/roundcube/program/lib/encoding/CP1256.map
share/roundcube/program/lib/encoding/CP1257.map
share/roundcube/program/lib/encoding/CP1258.map
share/roundcube/program/lib/encoding/ISO-8859-1.map
share/roundcube/program/lib/encoding/ISO-8859-10.map
share/roundcube/program/lib/encoding/ISO-8859-11.map
share/roundcube/program/lib/encoding/ISO-8859-13.map
share/roundcube/program/lib/encoding/ISO-8859-14.map
share/roundcube/program/lib/encoding/ISO-8859-15.map
share/roundcube/program/lib/encoding/ISO-8859-16.map
share/roundcube/program/lib/encoding/ISO-8859-2.map
share/roundcube/program/lib/encoding/ISO-8859-3.map
share/roundcube/program/lib/encoding/ISO-8859-4.map
share/roundcube/program/lib/encoding/ISO-8859-5.map
share/roundcube/program/lib/encoding/ISO-8859-6.map
share/roundcube/program/lib/encoding/ISO-8859-7.map
share/roundcube/program/lib/encoding/ISO-8859-8.map
share/roundcube/program/lib/encoding/ISO-8859-9.map
share/roundcube/program/lib/encoding/KSC5601.map
share/roundcube/program/lib/enriched.inc
share/roundcube/program/lib/html2text.inc
share/roundcube/program/lib/icl_commons.inc
@ -353,43 +273,14 @@ share/roundcube/program/lib/magic
share/roundcube/program/lib/mime.inc
share/roundcube/program/lib/rc_mail_mime.inc
share/roundcube/program/lib/utf7.inc
share/roundcube/program/lib/utf8.class.php
share/roundcube/program/localization/bs_BA/labels.inc
share/roundcube/program/localization/bs_BA/messages.inc
share/roundcube/program/localization/ge/labels.inc
share/roundcube/program/localization/ge/messages.inc
share/roundcube/program/localization/he/labels.inc
share/roundcube/program/localization/he/messages.inc
share/roundcube/program/localization/hi/labels.inc
share/roundcube/program/localization/hi/messages.inc
share/roundcube/program/localization/id_ID/labels.inc
share/roundcube/program/localization/id_ID/messages.inc
share/roundcube/program/localization/is/labels.inc
share/roundcube/program/localization/is/messages.inc
share/roundcube/program/localization/kr/labels.inc
share/roundcube/program/localization/kr/messages.inc
share/roundcube/program/localization/ne/labels.inc
share/roundcube/program/localization/ne/messages.inc
share/roundcube/program/localization/nl_BE/labels.inc
share/roundcube/program/localization/nl_BE/messages.inc
share/roundcube/program/localization/nn_NO/labels.inc
share/roundcube/program/localization/nn_NO/messages.inc
share/roundcube/program/localization/sq_AL/labels.inc
share/roundcube/program/localization/sq_AL/messages.inc
share/roundcube/program/localization/sr_cyrillic/labels.inc
share/roundcube/program/localization/sr_cyrillic/messages.inc
share/roundcube/program/localization/sr_latin/labels.inc
share/roundcube/program/localization/sr_latin/messages.inc
share/roundcube/program/localization/th_TH/labels.inc
share/roundcube/program/localization/th_TH/messages.inc
share/roundcube/program/localization/vn/labels.inc
share/roundcube/program/localization/vn/messages.inc
share/roundcube/program/localization/am/labels.inc
share/roundcube/program/localization/am/messages.inc
share/roundcube/program/localization/ar/labels.inc
share/roundcube/program/localization/ar/messages.inc
share/roundcube/program/localization/bg/labels.inc
share/roundcube/program/localization/bg/messages.inc
share/roundcube/program/localization/bs_BA/labels.inc
share/roundcube/program/localization/bs_BA/messages.inc
share/roundcube/program/localization/ca/labels.inc
share/roundcube/program/localization/ca/messages.inc
share/roundcube/program/localization/cz/labels.inc
@ -422,17 +313,31 @@ share/roundcube/program/localization/fr/labels.inc
share/roundcube/program/localization/fr/messages.inc
share/roundcube/program/localization/ga_IE/labels.inc
share/roundcube/program/localization/ga_IE/messages.inc
share/roundcube/program/localization/ge/labels.inc
share/roundcube/program/localization/ge/messages.inc
share/roundcube/program/localization/gl/labels.inc
share/roundcube/program/localization/gl/messages.inc
share/roundcube/program/localization/he/labels.inc
share/roundcube/program/localization/he/messages.inc
share/roundcube/program/localization/hi/labels.inc
share/roundcube/program/localization/hi/messages.inc
share/roundcube/program/localization/hr/labels.inc
share/roundcube/program/localization/hr/messages.inc
share/roundcube/program/localization/hu/labels.inc
share/roundcube/program/localization/hu/messages.inc
share/roundcube/program/localization/id_ID/labels.inc
share/roundcube/program/localization/id_ID/messages.inc
share/roundcube/program/localization/index.inc
share/roundcube/program/localization/is/labels.inc
share/roundcube/program/localization/is/messages.inc
share/roundcube/program/localization/it/labels.inc
share/roundcube/program/localization/it/messages.inc
share/roundcube/program/localization/ja/labels.inc
share/roundcube/program/localization/ja/messages.inc
share/roundcube/program/localization/kr/labels.inc
share/roundcube/program/localization/kr/messages.inc
share/roundcube/program/localization/ku/labels.inc
share/roundcube/program/localization/ku/messages.inc
share/roundcube/program/localization/lt/labels.inc
share/roundcube/program/localization/lt/messages.inc
share/roundcube/program/localization/lv/labels.inc
@ -443,8 +348,14 @@ share/roundcube/program/localization/ms_MY/labels.inc
share/roundcube/program/localization/ms_MY/messages.inc
share/roundcube/program/localization/nb_NO/labels.inc
share/roundcube/program/localization/nb_NO/messages.inc
share/roundcube/program/localization/ne/labels.inc
share/roundcube/program/localization/ne/messages.inc
share/roundcube/program/localization/nl_BE/labels.inc
share/roundcube/program/localization/nl_BE/messages.inc
share/roundcube/program/localization/nl_NL/labels.inc
share/roundcube/program/localization/nl_NL/messages.inc
share/roundcube/program/localization/nn_NO/labels.inc
share/roundcube/program/localization/nn_NO/messages.inc
share/roundcube/program/localization/pl/labels.inc
share/roundcube/program/localization/pl/messages.inc
share/roundcube/program/localization/pt_BR/labels.inc
@ -459,14 +370,24 @@ share/roundcube/program/localization/se/labels.inc
share/roundcube/program/localization/se/messages.inc
share/roundcube/program/localization/si/labels.inc
share/roundcube/program/localization/si/messages.inc
share/roundcube/program/localization/sl/labels.inc
share/roundcube/program/localization/sl/messages.inc
share/roundcube/program/localization/sk/labels.inc
share/roundcube/program/localization/sk/messages.inc
share/roundcube/program/localization/sl/labels.inc
share/roundcube/program/localization/sl/messages.inc
share/roundcube/program/localization/sq_AL/labels.inc
share/roundcube/program/localization/sq_AL/messages.inc
share/roundcube/program/localization/sr_cyrillic/labels.inc
share/roundcube/program/localization/sr_cyrillic/messages.inc
share/roundcube/program/localization/sr_latin/labels.inc
share/roundcube/program/localization/sr_latin/messages.inc
share/roundcube/program/localization/th_TH/labels.inc
share/roundcube/program/localization/th_TH/messages.inc
share/roundcube/program/localization/tr/labels.inc
share/roundcube/program/localization/tr/messages.inc
share/roundcube/program/localization/uk/labels.inc
share/roundcube/program/localization/uk/messages.inc
share/roundcube/program/localization/vn/labels.inc
share/roundcube/program/localization/vn/messages.inc
share/roundcube/program/localization/zh_CN/labels.inc
share/roundcube/program/localization/zh_CN/messages.inc
share/roundcube/program/localization/zh_TW/labels.inc
@ -507,6 +428,7 @@ share/roundcube/program/steps/settings/identities.inc
share/roundcube/program/steps/settings/manage_folders.inc
share/roundcube/program/steps/settings/save_identity.inc
share/roundcube/program/steps/settings/save_prefs.inc
share/roundcube/robots.txt
share/roundcube/skins/default/addresses.css
share/roundcube/skins/default/colorpicker.css
share/roundcube/skins/default/common.css
@ -670,7 +592,6 @@ share/roundcube/skins/default/templates/printmessage.html
share/roundcube/skins/default/templates/settings.html
share/roundcube/skins/default/templates/showcontact.html
share/roundcube/skins/default/watermark.html
@dirrm share/doc/roundcube
@dirrm share/roundcube/skins/default/templates
@dirrm share/roundcube/skins/default/includes
@dirrm share/roundcube/skins/default/images/icons
@ -684,38 +605,53 @@ share/roundcube/skins/default/watermark.html
@dirrm share/roundcube/program/steps/mail
@dirrm share/roundcube/program/steps/addressbook
@dirrm share/roundcube/program/steps
@dirrm share/roundcube/program/localization/eo
@dirrm share/roundcube/program/localization/ga_IE
@dirrm share/roundcube/program/localization/gl
@dirrm share/roundcube/program/localization/mk
@dirrm share/roundcube/program/localization/ms_MY
@dirrm share/roundcube/program/localization/uk
@dirrm share/roundcube/program/localization/zh_TW
@dirrm share/roundcube/program/localization/zh_CN
@dirrm share/roundcube/program/localization/vn
@dirrm share/roundcube/program/localization/uk
@dirrm share/roundcube/program/localization/tr
@dirrm share/roundcube/program/localization/th_TH
@dirrm share/roundcube/program/localization/sr_latin
@dirrm share/roundcube/program/localization/sr_cyrillic
@dirrm share/roundcube/program/localization/sq_AL
@dirrm share/roundcube/program/localization/sl
@dirrm share/roundcube/program/localization/sk
@dirrm share/roundcube/program/localization/si
@dirrm share/roundcube/program/localization/sl
@dirrm share/roundcube/program/localization/se
@dirrm share/roundcube/program/localization/ru
@dirrm share/roundcube/program/localization/ro
@dirrm share/roundcube/program/localization/pt_PT
@dirrm share/roundcube/program/localization/pt_BR
@dirrm share/roundcube/program/localization/pl
@dirrm share/roundcube/program/localization/nn_NO
@dirrm share/roundcube/program/localization/nl_NL
@dirrm share/roundcube/program/localization/nl_BE
@dirrm share/roundcube/program/localization/ne
@dirrm share/roundcube/program/localization/nb_NO
@dirrm share/roundcube/program/localization/ms_MY
@dirrm share/roundcube/program/localization/mk
@dirrm share/roundcube/program/localization/lv
@dirrm share/roundcube/program/localization/lt
@dirrm share/roundcube/program/localization/ku
@dirrm share/roundcube/program/localization/kr
@dirrm share/roundcube/program/localization/ja
@dirrm share/roundcube/program/localization/it
@dirrm share/roundcube/program/localization/is
@dirrm share/roundcube/program/localization/id_ID
@dirrm share/roundcube/program/localization/hu
@dirrm share/roundcube/program/localization/hr
@dirrm share/roundcube/program/localization/hi
@dirrm share/roundcube/program/localization/he
@dirrm share/roundcube/program/localization/gl
@dirrm share/roundcube/program/localization/ge
@dirrm share/roundcube/program/localization/ga_IE
@dirrm share/roundcube/program/localization/fr
@dirrm share/roundcube/program/localization/fi
@dirrm share/roundcube/program/localization/fa
@dirrm share/roundcube/program/localization/eu
@dirrm share/roundcube/program/localization/et_EE
@dirrm share/roundcube/program/localization/es
@dirrm share/roundcube/program/localization/eo
@dirrm share/roundcube/program/localization/en_US
@dirrm share/roundcube/program/localization/en_GB
@dirrm share/roundcube/program/localization/el
@ -724,38 +660,11 @@ share/roundcube/skins/default/watermark.html
@dirrm share/roundcube/program/localization/da
@dirrm share/roundcube/program/localization/cz
@dirrm share/roundcube/program/localization/ca
@dirrm share/roundcube/program/localization/bs_BA
@dirrm share/roundcube/program/localization/bg
@dirrm share/roundcube/program/localization/ar
@dirrm share/roundcube/program/localization/am
@dirrm share/roundcube/program/localization/vn
@dirrm share/roundcube/program/localization/th_TH
@dirrm share/roundcube/program/localization/sr_latin
@dirrm share/roundcube/program/localization/sr_cyrillic
@dirrm share/roundcube/program/localization/sq_AL
@dirrm share/roundcube/program/localization/nn_NO
@dirrm share/roundcube/program/localization/nl_BE
@dirrm share/roundcube/program/localization/ne
@dirrm share/roundcube/program/localization/kr
@dirrm share/roundcube/program/localization/is
@dirrm share/roundcube/program/localization/id_ID
@dirrm share/roundcube/program/localization/hi
@dirrm share/roundcube/program/localization/he
@dirrm share/roundcube/program/localization/ge
@dirrm share/roundcube/program/localization/bs_BA
@dirrm share/roundcube/program/localization
@dirrm share/roundcube/program/lib/encoding
@dirrm share/roundcube/program/lib/Net
@dirrm share/roundcube/program/lib/MDB2/Driver/Reverse
@dirrm share/roundcube/program/lib/MDB2/Driver/Native
@dirrm share/roundcube/program/lib/MDB2/Driver/Manager
@dirrm share/roundcube/program/lib/MDB2/Driver/Function
@dirrm share/roundcube/program/lib/MDB2/Driver/Datatype
@dirrm share/roundcube/program/lib/MDB2/Driver
@dirrm share/roundcube/program/lib/MDB2
@dirrm share/roundcube/program/lib/Mail
@dirrm share/roundcube/program/lib/DB
@dirrm share/roundcube/program/lib/Auth/SASL
@dirrm share/roundcube/program/lib/Auth
@dirrm share/roundcube/program/lib
@dirrm share/roundcube/program/js/tiny_mce/utils
@dirrm share/roundcube/program/js/tiny_mce/themes/advanced/langs
@ -805,7 +714,10 @@ share/roundcube/skins/default/watermark.html
@dirrm share/roundcube/program/js
@dirrm share/roundcube/program/include
@dirrm share/roundcube/program
@dirrm share/roundcube
@dirrm share/roundcube/installer/images
@dirrm share/roundcube/installer
@unexec ${RMDIR} %D/share/roundcube/config 2>/dev/null || ${TRUE}
@unexec ${RMDIR} %D/share/roundcube 2>/dev/null || ${TRUE}
@dirrm share/examples/roundcube/SQL
@dirrm share/examples/roundcube
@dirrm share/doc/roundcube

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.5 2008/03/15 13:54:59 adrianp Exp $
$NetBSD: distinfo,v 1.6 2008/05/04 16:34:03 adrianp Exp $
SHA1 (roundcubemail-0.1.tar.gz) = 8b5b516b41bad98c3bbaf0da0e70b0db82580424
RMD160 (roundcubemail-0.1.tar.gz) = 225b3a37c70bcf3b471b7d650233aec30dae2f76
Size (roundcubemail-0.1.tar.gz) = 1406854 bytes
SHA1 (roundcubemail-0.1.1-dep.tar.gz) = 747ea8ffedfbfea96a5139ffd2c4e4120cba7f60
RMD160 (roundcubemail-0.1.1-dep.tar.gz) = 525bde8ef722bc04a28ea326d716e390a0073c8a
Size (roundcubemail-0.1.1-dep.tar.gz) = 964612 bytes
SHA1 (patch-aa) = 621204db27874a799e5190e2cc00c3187cb3c61a
SHA1 (patch-ab) = 5379ccb823a8abf89e39498907730160d1fc517d
SHA1 (patch-ac) = 9e679ae35bf9722d26a6ea786ef0ff5c457116e3
SHA1 (patch-ad) = f0cd3aaf6f9dcd551e3cd630130a198c3e26a6b7

View file

@ -1,4 +1,4 @@
# $NetBSD: roundcube.conf,v 1.2 2007/06/06 18:40:16 adrianp Exp $
# $NetBSD: roundcube.conf,v 1.3 2008/05/04 16:34:03 adrianp Exp $
#
# RoundCube configuration file fragment for Apache
@ -11,5 +11,25 @@
DirectoryIndex index.php
<IfModule mod_php4.c>
php_flag file_uploads On
php_value session.auto_start Off
php_value upload_max_filesize 2M
</IfModule>
<IfModule mod_php5.c>
php_flag file_uploads On
php_value session.auto_start Off
php_value upload_max_filesize 2M
</IfModule>
</Directory>
#
# For security, don't serve pages from the roundcube installer directory.
#
# If you are using the installer to setup roundcube you will need access to
# the installer/ directory for the initial setup. It is recommended that
# after installation you uncomment the following block in order to restrict
# access to that directory.
#
#<Directory "@RCDIR@/installer">
# Order deny,allow
# Deny from all
#</Directory>

View file

@ -1,23 +1,24 @@
# $NetBSD: options.mk,v 1.2 2007/05/11 11:51:05 schmonz Exp $
# $NetBSD: options.mk,v 1.3 2008/05/04 16:34:03 adrianp Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.roundcube
PKG_OPTIONS_VAR= PKG_OPTIONS.roundcube
PKG_OPTIONS_REQUIRED_GROUPS= db
PKG_OPTIONS_GROUP.db= mysql pgsql sqlite
PKG_SUPPORTED_OPTIONS= iconv ldap multibyte
PKG_SUGGESTED_OPTIONS= mysql
PKG_SUPPORTED_OPTIONS= iconv ldap multibyte mcrypt sockets gd
# Following the recommendations in INSTALL the iconv, multibyte, gd and
# mcrypt PHP extensions are all 'recommended' requirements
PKG_SUGGESTED_OPTIONS= mysql iconv multibyte mcrypt sockets gd
.include "../../mk/bsd.options.mk"
.include "../../lang/php/phpversion.mk"
###
### Use mysql backend
###
.if !empty(PKG_OPTIONS:Mmysql)
. include "../../mk/mysql.buildlink3.mk"
DEPENDS+= ${PHP_PKG_PREFIX}-mysql>=4.3.1:../../databases/php-mysql
DEPENDS+= ${PHP_PKG_PREFIX}-pear-MDB2_Driver_mysql-[0-9]*:../../databases/pear-MDB2_Driver_mysql
.endif
###
@ -26,15 +27,16 @@ DEPENDS+= ${PHP_PKG_PREFIX}-mysql>=4.3.1:../../databases/php-mysql
.if !empty(PKG_OPTIONS:Mpgsql)
. include "../../mk/pgsql.buildlink3.mk"
DEPENDS+= ${PHP_PKG_PREFIX}-pgsql>=4.3.1:../../databases/php-pgsql
DEPENDS+= ${PHP_PKG_PREFIX}-pear-MDB2_Driver_pgsql-[0-9]*:../../databases/pear-MDB2_Driver_pgsql
.endif
###
### Use sqlite backend
###
.if !empty(PKG_OPTIONS:Msqlite)
PHP_VERSIONS_ACCEPTED= 4
. include "../../databases/sqlite/buildlink3.mk"
DEPENDS+= ${PHP_PKG_PREFIX}-sqlite-[0-9]*:../../databases/php-sqlite
DEPENDS+= ${PHP_PKG_PREFIX}-pear-MDB2_Driver_sqlite-[0-9]*:../../databases/pear-MDB2_Driver_sqlite
.endif
###
@ -57,3 +59,24 @@ DEPENDS+= ${PHP_PKG_PREFIX}-ldap>=4.3.1:../../databases/php-ldap
.if !empty(PKG_OPTIONS:Mmultibyte)
DEPENDS+= ${PHP_PKG_PREFIX}-mbstring>=4.3.1:../../misc/php-mbstring
.endif
###
### Use mcrypt
###
.if !empty(PKG_OPTIONS:Mmcrypt)
DEPENDS+= ${PHP_PKG_PREFIX}-mcrypt>=4.3.1:../../security/php-mcrypt
.endif
###
### Use sockets
###
.if !empty(PKG_OPTIONS:Msockets)
DEPENDS+= ${PHP_PKG_PREFIX}-sockets>=4.3.1:../../net/php-sockets
.endif
###
### Add support for gd
###
.if !empty(PKG_OPTIONS:Mgd)
DEPENDS+= ${PHP_PKG_PREFIX}-gd>=4.3.1:../../graphics/php-gd
.endif

View file

@ -1,34 +0,0 @@
$NetBSD: patch-ab,v 1.2 2008/03/15 13:54:59 adrianp Exp $
--- program/include/main.inc.orig 2008-02-27 08:39:22.000000000 -0500
+++ program/include/main.inc
@@ -134,7 +134,7 @@ function rcmail_load_config()
global $INSTALL_PATH;
// load config file
- include_once('config/main.inc.php');
+ include_once('@PKG_SYSCONFDIR@/roundcube/main.inc.php');
$conf = is_array($rcmail_config) ? $rcmail_config : array();
// load host-specific configuration
@@ -143,7 +143,7 @@ function rcmail_load_config()
$conf['skin_path'] = $conf['skin_path'] ? unslashify($conf['skin_path']) : 'skins/default';
// load db conf
- include_once('config/db.inc.php');
+ include_once('@PKG_SYSCONFDIR@/roundcube/db.inc.php');
$conf = array_merge($conf, $rcmail_config);
if (empty($conf['log_dir']))
@@ -181,9 +181,9 @@ function rcmail_load_host_config(&$confi
else if (!empty($config['include_host_config']))
$fname = preg_replace('/[^a-z0-9\.\-_]/i', '', $_SERVER['HTTP_HOST']) . '.inc.php';
- if ($fname && is_file('config/'.$fname))
+ if ($fname && is_file('@PKG_SYSCONFDIR@/roundcube/'.$fname))
{
- include('config/'.$fname);
+ include('@PKG_SYSCONFDIR@/roundcube/'.$fname);
$config = array_merge($config, $rcmail_config);
}
}

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ac,v 1.1 2008/05/04 16:34:03 adrianp Exp $
--- installer/config.php.orig 2008-04-05 13:49:21.000000000 +0100
+++ installer/config.php
@@ -187,7 +187,7 @@ echo $select_mdnreq->show(intval($RCI->g
<p>Database settings for read/write operations:</p>
<?php
-require_once 'DB.php';
+require_once 'MDB2.php';
$supported_dbs = array('MySQL' => 'mysql', 'MySQLi' => 'mysqli',
'PgSQL' => 'pgsql', 'SQLite' => 'sqlite');
@@ -204,7 +204,7 @@ $input_dbname = new textfield(array('nam
$input_dbuser = new textfield(array('name' => '_dbuser', 'size' => 20, 'id' => "cfgdbuser"));
$input_dbpass = new textfield(array('name' => '_dbpass', 'size' => 20, 'id' => "cfgdbpass"));
-$dsnw = DB::parseDSN($RCI->getprop('db_dsnw'));
+$dsnw = MDB2::parseDSN($RCI->getprop('db_dsnw'));
echo $select_dbtype->show($RCI->is_post ? $_POST['_dbtype'] : $dsnw['phptype']);
echo '<label for="cfgdbtype">Database type</label><br />';

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ad,v 1.1 2008/05/04 16:34:03 adrianp Exp $
--- index.php.orig 2008-04-05 13:49:21.000000000 +0100
+++ index.php
@@ -161,7 +161,7 @@ if ($_action=='login' && $_task=='mail')
}
else if ($_SESSION['temp'] && !empty($_POST['_user']) && isset($_POST['_pass']) &&
rcmail_login(trim(get_input_value('_user', RCUBE_INPUT_POST), ' '),
- get_input_value('_pass', RCUBE_INPUT_POST, true, 'ISO-8859-1'), $host))
+ get_input_value('_pass', RCUBE_INPUT_POST, true, ''), $host))
{
// create new session ID
unset($_SESSION['temp']);