update to 0.8.13

Version 0.8.13   - 18 November 2003
  * Add -s/--shadowbuiltin option to warn when overriding a builtin
  * Add warning when assigning a variable to itself
  * Add warning when dividing a variable by itself
  * Add warnings when using a bit-wise operator with the same variable (a & a)
  * Add warning when passing a constant string to getattr()/setattr()
  * Add --special option to check for __special__ (reserved) method names
    and that their signature (argument count) is correct
  * Add warning for using __getattribute__ in an old-style class
  * Suppress 'self as first argument' warning for static and class methods
  * Add --classmethodargs option to specify first argument name
    for class methods
This commit is contained in:
recht 2003-12-02 23:37:26 +00:00
parent 5131916fcc
commit b53fa27a66
3 changed files with 14 additions and 14 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.5 2003/07/21 16:43:45 martti Exp $
# $NetBSD: Makefile,v 1.6 2003/12/02 23:37:26 recht Exp $
DISTNAME= pychecker-0.8.12
PKGNAME= ${PYPKGPREFIX}-checker-0.8.12
DISTNAME= pychecker-0.8.13
PKGNAME= ${PYPKGPREFIX}-checker-0.8.13
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=pychecker/}

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.2 2003/06/28 14:49:48 drochner Exp $
$NetBSD: distinfo,v 1.3 2003/12/02 23:37:26 recht Exp $
SHA1 (pychecker-0.8.12.tar.gz) = 2bf27b90f6467eea913038781a079aa03ebfecaa
Size (pychecker-0.8.12.tar.gz) = 115719 bytes
SHA1 (patch-aa) = 47868b24926ffe3e44b57b61a380fc3bef94c874
SHA1 (pychecker-0.8.13.tar.gz) = 945f9ccb5d2ef543d17c123114c5b6b0416370d9
Size (pychecker-0.8.13.tar.gz) = 119974 bytes
SHA1 (patch-aa) = ef0328a153878fde74679c9480d60e80ffc3ffa0

View file

@ -1,7 +1,7 @@
$NetBSD: patch-aa,v 1.2 2003/06/28 14:49:48 drochner Exp $
$NetBSD: patch-aa,v 1.3 2003/12/02 23:37:26 recht Exp $
--- setup.py.orig 2002-12-24 02:05:58.000000000 +0100
+++ setup.py 2003-06-28 16:36:47.000000000 +0200
--- setup.py~ 2003-11-18 04:50:14.000000000 +0100
+++ setup.py 2003-11-19 14:42:48.000000000 +0100
@@ -10,7 +10,6 @@
import sys
@ -10,7 +10,7 @@ $NetBSD: patch-aa,v 1.2 2003/06/28 14:49:48 drochner Exp $
from distutils.core import setup
from distutils import sysconfig
@@ -42,8 +41,8 @@
@@ -56,8 +55,8 @@
script_str = '%s %s %s\n' % (py_exe, checker_py, arg_str)
script_suffix = '.bat'
@ -21,11 +21,11 @@ $NetBSD: patch-aa,v 1.2 2003/06/28 14:49:48 drochner Exp $
remove_file(LOCAL_SCRIPT)
try :
@@ -64,7 +63,6 @@
@@ -78,7 +77,6 @@
author_email = "pychecker@metaslash.com",
url = "http://pychecker.sourceforge.net/",
packages = [ 'pychecker' ],
- data_files = [ (install_dir, DOC_FILES) ],
scripts = [ LOCAL_SCRIPT, ],
long_description = LONG_DESCRIPTION
)
# classifiers was added in Python 2.3, but needed for PyPI
#classifiers = CLASSIFIERS,