microdc2: remove
Build broken, dead upstream since ~2006.
This commit is contained in:
parent
01dd781a68
commit
b545c618d0
10 changed files with 3 additions and 127 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: CHANGES-2023,v 1.864 2023/01/30 10:15:25 pho Exp $
|
||||
$NetBSD: CHANGES-2023,v 1.865 2023/01/30 10:29:31 wiz Exp $
|
||||
|
||||
Changes to the packages collection and infrastructure in 2023:
|
||||
|
||||
|
@ -1093,3 +1093,4 @@ Changes to the packages collection and infrastructure in 2023:
|
|||
Updated devel/gdbus-codegen to 2.74.5 [adam 2023-01-30]
|
||||
Added devel/hs-hls-ormolu-plugin version 1.0.3.0 [pho 2023-01-30]
|
||||
Updated devel/hs-hls-module-name-plugin to 1.1.1.0 [pho 2023-01-30]
|
||||
Removed net/microdc2 [wiz 2023-01-30]
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.1499 2023/01/27 02:41:07 pho Exp $
|
||||
# $NetBSD: Makefile,v 1.1500 2023/01/30 10:29:31 wiz Exp $
|
||||
#
|
||||
|
||||
COMMENT= Networking tools
|
||||
|
@ -375,7 +375,6 @@ SUBDIR+= mbrowse
|
|||
SUBDIR+= mcast-tools
|
||||
SUBDIR+= md-whois
|
||||
SUBDIR+= megatools
|
||||
SUBDIR+= microdc2
|
||||
SUBDIR+= mikutter
|
||||
SUBDIR+= mikutter-plugins-twitter
|
||||
SUBDIR+= mimms
|
||||
|
|
|
@ -1,7 +0,0 @@
|
|||
microdc2 is the successor of microdc, a command-line based Direct Connect
|
||||
client written in C and designed to compile and run on modern POSIX
|
||||
compatible systems.
|
||||
Direct Connect is a file sharing network made up by hubs, to which
|
||||
clients can connect. Once connected to a hub, the user can search for
|
||||
files on the hub or the network, or browse files of other users connected
|
||||
to the hub.
|
|
@ -1,30 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.15 2022/11/23 16:20:52 adam Exp $
|
||||
#
|
||||
|
||||
DISTNAME= microdc2-0.15.6
|
||||
PKGREVISION= 10
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ${MASTER_SITE_GENTOO:=distfiles/}
|
||||
|
||||
MAINTAINER= d.den.brok@uni-bonn.de
|
||||
HOMEPAGE= http://corsair626.no-ip.org/microdc/
|
||||
COMMENT= Console-based DirectConnect client
|
||||
|
||||
BUILDLINK_API_DEPENDS.readline+= readline>=4
|
||||
BUILDLINK_API_DEPENDS.libxml2+= libxml2>=2.6.16
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
USE_PKGLOCALEDIR= yes
|
||||
USE_TOOLS+= ln msgfmt msgmerge
|
||||
|
||||
post-install:
|
||||
cd ${DESTDIR:Q}${PREFIX:Q}/${PKGMANDIR}/man1 && \
|
||||
ln -s microdc.1 microdc2.1
|
||||
|
||||
.include "../../converters/libiconv/buildlink3.mk"
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
.include "../../devel/readline/buildlink3.mk"
|
||||
.include "../../textproc/libxml2/buildlink3.mk"
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,8 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2007/09/16 15:53:12 heinz Exp $
|
||||
bin/microdc2
|
||||
bin/tthsum
|
||||
man/man1/microdc.1
|
||||
man/man1/microdc.pl.1
|
||||
man/man1/microdc2.1
|
||||
share/locale/pl/LC_MESSAGES/microdc2.mo
|
||||
share/locale/sv/LC_MESSAGES/microdc2.mo
|
|
@ -1,9 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.8 2021/10/26 11:05:59 nia Exp $
|
||||
|
||||
BLAKE2s (microdc2-0.15.6.tar.gz) = 7a62bad94b2ab6831412a04d586281d78305971340a28772706e547526497196
|
||||
SHA512 (microdc2-0.15.6.tar.gz) = efa178e6639b897df52f467864019a4c5d259dc0ece3852c2e173d09ef3dfbd7c9936d41002ee0b8e3365e71cea687e484bcbe7ed340649b2035cd5a55b76308
|
||||
Size (microdc2-0.15.6.tar.gz) = 639392 bytes
|
||||
SHA1 (patch-aa) = 8801a9442911a6cdd3d154724db4ecc65965dd39
|
||||
SHA1 (patch-ab) = 557541ae05484690002c7d9fa2f1533220ea190b
|
||||
SHA1 (patch-ac) = 47ccedc9305c75f2926f4ff910345eeba0dc8478
|
||||
SHA1 (patch-lib_Makefile.in) = a372774b18bf6fee385f3b621ddf0809fc9a4465
|
|
@ -1,23 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2007/09/16 15:53:12 heinz Exp $
|
||||
|
||||
Provide hints for getaddrinfo(), otherwise there is not enough data
|
||||
to determine the correct address information.
|
||||
Works on NetBSD and Linux.
|
||||
AF_UNSPEC could not be used because IPv6 address information confuses the
|
||||
application.
|
||||
|
||||
--- src/hub.c.orig 2006-12-24 19:41:44.000000000 +0100
|
||||
+++ src/hub.c
|
||||
@@ -316,10 +316,11 @@ hub_new(const char *hostname, uint16_t p
|
||||
hub_connect(&addr); /* Ignore errors */
|
||||
} else {
|
||||
char portstr[6];
|
||||
+ struct addrinfo hints = { 0, AF_INET, SOCK_STREAM, 0, };
|
||||
|
||||
sprintf(portstr, "%" PRIu16, port);
|
||||
screen_putf(_("Looking up IP address for %s\n"), quotearg(hostname));
|
||||
- hub_lookup = add_lookup_request(hostname, portstr, NULL, hub_address_looked_up, xstrdup(hostname));
|
||||
+ hub_lookup = add_lookup_request(hostname, portstr, &hints, hub_address_looked_up, xstrdup(hostname));
|
||||
hub_state = DC_HUB_LOOKUP;
|
||||
}
|
||||
}
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.3 2012/12/25 21:04:32 joerg Exp $
|
||||
|
||||
--- configure.orig 2006-12-24 18:45:07.000000000 +0000
|
||||
+++ configure
|
||||
@@ -21508,7 +21508,10 @@ cat >>confdefs.h <<\_ACEOF
|
||||
_ACEOF
|
||||
|
||||
fi
|
||||
- if test $LIBXML2_VERSION -ge 2616; then
|
||||
+ good_libxml2=no
|
||||
+ case "$LIBXML2_VERSION" in 27*|28*|29*) good_libxml2=yes;; esac
|
||||
+ test $LIBXML2_VERSION -ge 2616 && good_libxml2=yes
|
||||
+ if test $good_libxml2 = yes; then
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define HAVE_LIBXML2 1
|
||||
_ACEOF
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.2 2012/12/25 21:04:32 joerg Exp $
|
||||
|
||||
--- configure.ac.orig 2006-12-24 18:43:36.000000000 +0000
|
||||
+++ configure.ac
|
||||
@@ -52,7 +52,10 @@ if test -n "$XML_CONFIG" && test -n "$TR
|
||||
if test $LIBXML2_VERSION -eq 2616; then
|
||||
AC_DEFINE([XML_SAVE_FORMAT], [1], [The libxml2 version 2.6.16 has no such option defined in the library headers])
|
||||
fi
|
||||
- if test $LIBXML2_VERSION -ge 2616; then
|
||||
+ good_libxml2=no
|
||||
+ case "$LIBXML2_VERSION" in 27*|28*|29*) good_libxml2=yes;; esac
|
||||
+ test $LIBXML2_VERSION -ge 2616 && good_libxml2=yes
|
||||
+ if test $good_libxml2 = yes; then
|
||||
AC_DEFINE([HAVE_LIBXML2])
|
||||
LIBXML2_LIBS="`$XML_CONFIG --libs`"
|
||||
LIBXML2_CFLAGS="`$XML_CONFIG --cflags`"
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-lib_Makefile.in,v 1.1 2015/11/08 21:50:08 dholland Exp $
|
||||
|
||||
Don't try to feed "-liconv" to ar(1). Breaks on OpenBSD.
|
||||
|
||||
--- lib/Makefile.in~ 2006-12-24 18:44:45.000000000 +0000
|
||||
+++ lib/Makefile.in
|
||||
@@ -259,7 +259,7 @@ libgnu_a_SOURCES = argmatch.h argmatch.c
|
||||
version-etc.h version-etc.c xalloc-die.c xgethostname.h \
|
||||
xgethostname.c xsize.h xstrndup.h xstrndup.c xstrtoumax.c \
|
||||
xvasprintf.h xvasprintf.c xasprintf.c
|
||||
-libgnu_a_LIBADD = @LIBOBJS@ @ALLOCA@ $(LTLIBICONV)
|
||||
+libgnu_a_LIBADD = @LIBOBJS@ @ALLOCA@ #$(LTLIBICONV)
|
||||
EXTRA_DIST = alloca_.h fnmatch_.h fnmatch_loop.c getopt_.h \
|
||||
getopt_int.h stdbool_.h stdint_.h
|
||||
BUILT_SOURCES = $(ALLOCA_H) $(FNMATCH_H) $(GETOPT_H) $(STDBOOL_H) \
|
Loading…
Reference in a new issue