Make this build in NetBSD -current.

This commit is contained in:
xtraeme 2004-04-29 14:18:34 +00:00
parent 053c3be42b
commit b5809503ff
2 changed files with 19 additions and 7 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.19 2004/04/28 08:16:44 jmmv Exp $
$NetBSD: distinfo,v 1.20 2004/04/29 14:18:34 xtraeme Exp $
SHA1 (gnome-vfs-2.6.0.tar.bz2) = a5cfea7568259fc6fe98322a7a01eb70d8f5f615
Size (gnome-vfs-2.6.0.tar.bz2) = 1431274 bytes
@ -12,4 +12,4 @@ SHA1 (patch-ag) = 0bec8918c71b2aa470c96c4512b11f42550484c4
SHA1 (patch-ai) = 3a45cd84dfa025a52c7db3aab2cca85b540078a6
SHA1 (patch-ak) = 83694081f9484c3f71fd1867007652eff6e26f93
SHA1 (patch-al) = e0f4727c0c0415f5e0bc182b0ae94093d45b4cd0
SHA1 (patch-am) = 51a0b9f06c1793a519286278207f81ea6831dbdb
SHA1 (patch-am) = 78a58aa257a95db6b9ae34da640e61003da3e00a

View file

@ -1,12 +1,12 @@
$NetBSD: patch-am,v 1.5 2004/04/28 08:16:44 jmmv Exp $
$NetBSD: patch-am,v 1.6 2004/04/29 14:18:34 xtraeme Exp $
--- libgnomevfs/gnome-vfs-unix-mounts.c.orig 2004-02-16 12:13:27.000000000 +0100
+++ libgnomevfs/gnome-vfs-unix-mounts.c
@@ -411,7 +411,11 @@ get_mtab_monitor_file (void)
--- libgnomevfs/gnome-vfs-unix-mounts.c.orig 2004-04-29 16:11:52.000000000 +0200
+++ libgnomevfs/gnome-vfs-unix-mounts.c 2004-04-29 16:13:57.000000000 +0200
@@ -411,7 +411,11 @@
gboolean
_gnome_vfs_get_current_unix_mounts (GList **return_list)
{
+#ifdef FSTYPE_STATVFS
+#ifdef HAVE_STATVFS
+ struct statvfs *mntent = NULL;
+#else
struct statfs *mntent = NULL;
@ -14,3 +14,15 @@ $NetBSD: patch-am,v 1.5 2004/04/28 08:16:44 jmmv Exp $
int num_mounts, i;
GnomeVFSUnixMount *mount_entry;
@@ -428,7 +432,11 @@
mount_entry->mount_path = g_strdup (mntent[i].f_mntonname);
mount_entry->device_path = g_strdup (mntent[i].f_mntfromname);
mount_entry->filesystem_type = g_strdup (mntent[i].f_fstypename);
+#ifdef HAVE_STATVFS
+ if (mntent[i].f_flag == MNT_RDONLY) {
+#else
if (mntent[i].f_flags == MNT_RDONLY) {
+#endif
mount_entry->is_read_only = TRUE;
}