Fix build under NetBSD-currenty removing unused custom function "getline"
which conflicts with getline(3).
This commit is contained in:
parent
efeec68a7c
commit
b593e41a0f
3 changed files with 37 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.10 2010/09/28 17:50:07 tnn Exp $
|
||||
$NetBSD: distinfo,v 1.11 2011/01/15 17:46:01 tron Exp $
|
||||
|
||||
SHA1 (star-1.4.3.tar.gz) = c59b68d97edba77a9ac6000be04d457ded1eefe9
|
||||
RMD160 (star-1.4.3.tar.gz) = f7ec71bfab1723c994e5eed7e6818394a41d44d9
|
||||
|
@ -7,3 +7,5 @@ SHA1 (patch-aa) = 4fe4af396adf23eb7ac071b02a7bf726ab1e4318
|
|||
SHA1 (patch-ab) = aea3af88d3bedf2ce7a7744c90062ba4e57bb79f
|
||||
SHA1 (patch-ac) = 81e6361db3903e5b04fae4e70ad3a37f9a2f4fa7
|
||||
SHA1 (patch-ad) = 2be98feac17350b37c242a6f84f539e81330ee14
|
||||
SHA1 (patch-ae) = 34786fc3c51ef14ca2ae9250d8d12d12788abdc5
|
||||
SHA1 (patch-af) = b28ca20dd8cd5326a9d9836880f09740abca7525
|
||||
|
|
15
archivers/star/patches/patch-ae
Normal file
15
archivers/star/patches/patch-ae
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ae,v 1.1 2011/01/15 17:46:01 tron Exp $
|
||||
|
||||
Remove unused custom function "getline" which conflicts with getline(3)
|
||||
which is part of the POSIX standard.
|
||||
|
||||
--- include/schily.h.orig 2002-12-24 18:28:01.000000000 +0000
|
||||
+++ include/schily.h 2011-01-15 17:41:23.000000000 +0000
|
||||
@@ -183,7 +183,6 @@
|
||||
extern char *findbytes __PR((const void *, int, char));
|
||||
extern int findline __PR((const char *, char, const char *,
|
||||
int, char **, int));
|
||||
-extern int getline __PR((char *, int));
|
||||
extern int getstr __PR((char *, int));
|
||||
extern int breakline __PR((char *, char, char **, int));
|
||||
extern int getallargs __PR((int *, char * const**, const char *, ...));
|
19
archivers/star/patches/patch-af
Normal file
19
archivers/star/patches/patch-af
Normal file
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-af,v 1.1 2011/01/15 17:46:01 tron Exp $
|
||||
|
||||
Remove unused custom function "getline" which conflicts with getline(3)
|
||||
which is part of the POSIX standard.
|
||||
|
||||
--- lib/stdio/fgetline.c.orig 2000-12-03 11:19:29.000000000 +0000
|
||||
+++ lib/stdio/fgetline.c 2011-01-15 17:42:18.000000000 +0000
|
||||
@@ -62,11 +62,3 @@
|
||||
|
||||
return (bp - buf);
|
||||
}
|
||||
-
|
||||
-EXPORT int
|
||||
-getline(buf, len)
|
||||
- char *buf;
|
||||
- int len;
|
||||
-{
|
||||
- return (fgetline(stdin, buf, len));
|
||||
-}
|
Loading…
Reference in a new issue