fix project properties tab crash, from John Marino per PR pkg/45135
(PKGREV bumped)
This commit is contained in:
parent
743f365cee
commit
b5a49dfb49
5 changed files with 55 additions and 5 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.2 2011/04/22 13:43:19 obache Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2011/07/19 18:32:13 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gps-${GPS_VERSION}
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://downloads.dragonlace.net/src/ \
|
||||
http://dragonlace.mirrors.ada.cx/src/
|
||||
|
@ -27,7 +27,7 @@ TPLS= ${PREFIX}/share/gps/templates
|
|||
|
||||
.include "options.mk"
|
||||
|
||||
# Do to hardcoding on GPS' part, can't get python to work yet
|
||||
# Doe to hardcoding on GPS' part, can't get python to work yet
|
||||
CONFIGURE_ARGS+= --with-gmp=${PREFIX}
|
||||
CONFIGURE_ARGS+= --with-python=no
|
||||
CONFIGURE_ARGS+= --enable-shared-python=yes
|
||||
|
@ -61,5 +61,4 @@ post-install:
|
|||
.include "../../x11/gtkada/buildlink3.mk"
|
||||
.include "../../textproc/xmlada/buildlink3.mk"
|
||||
.include "../../devel/gprbuild-aux/buildlink3.mk"
|
||||
#.include "../../lang/python26/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2011/02/08 18:32:23 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.2 2011/07/19 18:32:13 drochner Exp $
|
||||
|
||||
SHA1 (gps-5.0.0.tar.bz2) = 913aca264a341e228b3b02e7bb8ea77b0cb96805
|
||||
RMD160 (gps-5.0.0.tar.bz2) = 67fd5e95e1e4fd1f728522395623812091b7dfda
|
||||
|
@ -10,3 +10,6 @@ SHA1 (patch-ad) = 058f89c0fa9bf2c2d4baca8d35ce11c97086697a
|
|||
SHA1 (patch-ae) = 2847e353fdec774262adc14f80c4ba6c6a5fe283
|
||||
SHA1 (patch-af) = c3c29f06eb91a7656a8c251b1914686b4aea9723
|
||||
SHA1 (patch-ag) = b1756db403619becb790c3e0641d5e0606f4e92c
|
||||
SHA1 (patch-ah) = 8b5fb8546a6de24cc8d9ce0a5125bda03149ec06
|
||||
SHA1 (patch-ai) = 604edae7bc4fcf8e0cbd707848d79b22aca1a3df
|
||||
SHA1 (patch-aj) = eb5c2f7850468d5718ddd30d54f8f4efdb2187e5
|
||||
|
|
22
devel/gps/patches/patch-ah
Normal file
22
devel/gps/patches/patch-ah
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ah,v 1.1 2011/07/19 18:32:14 drochner Exp $
|
||||
|
||||
--- prj_editor/src/project_properties.adb.orig 2010-12-14 22:30:31.000000000 +0000
|
||||
+++ prj_editor/src/project_properties.adb
|
||||
@@ -4925,7 +4925,7 @@ package body Project_Properties is
|
||||
then
|
||||
-- Some pages might not be visible though...
|
||||
P := Get_Nth_Project_Editor_Page
|
||||
- (Ed.Kernel, Page - Pages_From_XML_Count);
|
||||
+ (Ed.Kernel, Page - Pages_From_XML_Count + 1);
|
||||
end if;
|
||||
|
||||
if P /= null then
|
||||
@@ -4934,7 +4934,7 @@ package body Project_Properties is
|
||||
begin
|
||||
Refresh
|
||||
(Page => P,
|
||||
- Widget => Ed.Pages (Page - Pages_From_XML_Count),
|
||||
+ Widget => Ed.Pages (Page - Pages_From_XML_Count + 1),
|
||||
Project => Ed.Project,
|
||||
Languages => Languages.all);
|
||||
Free (Languages);
|
13
devel/gps/patches/patch-ai
Normal file
13
devel/gps/patches/patch-ai
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ai,v 1.1 2011/07/19 18:32:14 drochner Exp $
|
||||
|
||||
--- prj_editor/src/project_viewers.ads.orig 2010-12-14 22:30:31.000000000 +0000
|
||||
+++ prj_editor/src/project_viewers.ads
|
||||
@@ -159,7 +159,7 @@ package Project_Viewers is
|
||||
-- Return the number of registered project editor pages
|
||||
|
||||
function Get_Nth_Project_Editor_Page
|
||||
- (Kernel : access GPS.Kernel.Kernel_Handle_Record'Class; Num : Natural)
|
||||
+ (Kernel : access GPS.Kernel.Kernel_Handle_Record'Class; Num : Positive)
|
||||
return Project_Editor_Page;
|
||||
-- Return the Num-th registered project editor page.
|
||||
-- First page is number 1.
|
13
devel/gps/patches/patch-aj
Normal file
13
devel/gps/patches/patch-aj
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aj,v 1.1 2011/07/19 18:32:14 drochner Exp $
|
||||
|
||||
--- prj_editor/src/project_viewers.adb.orig 2010-12-14 22:30:31.000000000 +0000
|
||||
+++ prj_editor/src/project_viewers.adb
|
||||
@@ -1657,7 +1657,7 @@ package body Project_Viewers is
|
||||
---------------------------------
|
||||
|
||||
function Get_Nth_Project_Editor_Page
|
||||
- (Kernel : access Kernel_Handle_Record'Class; Num : Natural)
|
||||
+ (Kernel : access Kernel_Handle_Record'Class; Num : Positive)
|
||||
return Project_Editor_Page
|
||||
is
|
||||
pragma Unreferenced (Kernel);
|
Loading…
Reference in a new issue