Update to sqlite-2.8.13. Closes PR pkg/24660.

FreeBSD 4 portability hint from Michal Pasternak.

Some of the changes since 2.8.5 include:
* Refactor parts of the code in order to make the code footprint
  smaller.  The code is now also a little bit faster.
* The built-in min() and max() functions now honor the difference
  between NUMERIC and TEXT datatypes.
* New HH:MM:SS modifier to the built-in date/time functions.
* Add function prototypes for the database encryption API.
* Fix a bug that might corrupt the rollback journal if a power failure or
  external program halt occurs in the middle of a COMMIT.
* Reduce the size and increase the speed of various modules.
* Fix a potential database corruption problem on Unix.
* Fix a 32-bit integer overflow problem that could result in corrupt
  indices in a database if large negative numbers (less than -2147483648)
  were inserted into a indexed numeric column.
* Fix a locking problem on multi-threaded Linux implementations.
* Fix a critical bug introduced in 2.8.0 which could cause database corruption.
* The VACUUM command now works with the non-callback API
* If the name of the database is an empty string, open a new database in a
  temporary file that is automatically deleted when the database is
  closed.
* Performance enhancements in the lemon-generated parser
* Documentation updates and typo fixes
* Removed support for the Oracle8 outer join syntax.
* Allow GLOB and LIKE operators to work as functions.
* Make sure the journal file directory entry is committed to disk before
  writing the database file.
This commit is contained in:
snj 2004-03-31 05:50:17 +00:00
parent 703c2a4805
commit b5b942e431
29 changed files with 40 additions and 272 deletions

View file

@ -1,18 +1,18 @@
# $NetBSD: Makefile,v 1.21 2004/02/14 17:21:36 jlam Exp $
# $NetBSD: Makefile,v 1.22 2004/03/31 05:50:17 snj Exp $
DISTNAME= sqlite-2.8.5
DISTNAME= sqlite-2.8.13
CATEGORIES= databases
MASTER_SITES= http://www.hwaci.com/sw/sqlite/ \
http://www.sqlite.org/
MAINTAINER= jlam@NetBSD.org
HOMEPAGE= http://www.hwaci.com/sw/sqlite/
COMMENT= SQL Database Engine In A C Library
COMMENT= SQL Database Engine in a C Library
WRKSRC= ${WRKDIR}/sqlite-build
USE_BUILDLINK2= YES
USE_LIBTOOL= YES
USE_BUILDLINK3= YES
USE_GNU_TOOLS+= make
USE_LIBTOOL= YES
GNU_CONFIGURE= YES
CONFIGURE_SCRIPT= ../sqlite/configure
@ -27,5 +27,5 @@ PKGCONFIG_OVERRIDE= ${WRKDIR}/sqlite/sqlite.pc.in
post-extract:
${MKDIR} ${WRKSRC}
.include "../../devel/readline/buildlink2.mk"
.include "../../devel/readline/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,9 +1,9 @@
@comment $NetBSD: PLIST,v 1.2 2003/08/01 14:22:18 drochner Exp $
@comment $NetBSD: PLIST,v 1.3 2004/03/31 05:50:17 snj Exp $
bin/sqlite
include/sqlite.h
lib/libsqlite.a
lib/libsqlite.la
lib/libsqlite.so
lib/libsqlite.so.5
lib/libsqlite.so.5.3
lib/libsqlite.so.8
lib/libsqlite.so.8.6
lib/pkgconfig/sqlite.pc

View file

@ -0,0 +1,18 @@
# $NetBSD: buildlink3.mk,v 1.1 2004/03/31 05:50:17 snj Exp $
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
SQLITE_BUILDLINK3_MK:= ${SQLITE_BUILDLINK3_MK}+
.if !empty(BUILDLINK_DEPTH:M+)
BUILDLINK_DEPENDS+= sqlite
.endif
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nsqlite}
BUILDLINK_PACKAGES+= sqlite
.if !empty(SQLITE_BUILDLINK3_MK:M+)
BUILDLINK_DEPENDS.sqlite+= sqlite>=2.8.0
BUILDLINK_PKGSRCDIR.sqlite?= ../../databases/sqlite
.endif # SQLITE_BUILDLINK3_MK
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}

View file

@ -1,29 +1,5 @@
$NetBSD: distinfo,v 1.14 2003/12/30 14:41:09 cjep Exp $
$NetBSD: distinfo,v 1.15 2004/03/31 05:50:17 snj Exp $
SHA1 (sqlite-2.8.5.tar.gz) = f7819edfb360a14155c61f6c61f644ac3e3c514b
Size (sqlite-2.8.5.tar.gz) = 817792 bytes
SHA1 (patch-aa) = 6bb6d7778b517a3ad1ee630eba91526491cca5ea
SHA1 (patch-ab) = 77ae6de033c741f99763b2ae3cda0d350d2142ae
SHA1 (patch-ac) = 094c1143bbdb419fe9430a145afa7f35e8015c18
SHA1 (patch-ad) = 7c805c28295464158a9888d67417f520e676355f
SHA1 (patch-ae) = 7df7d4efb923e51ff66b0474cfb0fa41b81194fa
SHA1 (patch-af) = bf1c47f3c4f0846a7513dbcb8bd4a12d6ec621bf
SHA1 (patch-ag) = 0a0070ae00ad396c63c132ddc58aedc1b1087c2d
SHA1 (patch-ah) = c5d0f884f0b644f0ffd086216081b073f8beb6d7
SHA1 (patch-ai) = 53aec32dee3a7a3ee9e5e7ac5f58c2832e213124
SHA1 (patch-aj) = 875fb93fb4152fcf56ce66ed1c56f8cd7867c79f
SHA1 (patch-ak) = 921d2d9575080c174ca4ea467e55e34c9c959615
SHA1 (patch-al) = 585c4266ba3dee04bb3c2b7ad1971a81823f05d2
SHA1 (patch-am) = 242b1657a533b9d3b3d028328af898ed16c4ced5
SHA1 (patch-an) = cc67198919f62825e993f9332f973013a5874e51
SHA1 (patch-ao) = a7b5583b796ad744dac06e4d13093d72618276c9
SHA1 (patch-ap) = 37f6853dac0cd6f2c1be602a0e30fe46122a36a0
SHA1 (patch-aq) = f09c05affac7067d899a2586e8db2f26b8cc20b4
SHA1 (patch-ar) = a8f0a10f0572531287fc3c8aa0c6e49b807822e7
SHA1 (patch-as) = d23c2882f368a1f721bc82c4dd9b0ae68d1d709c
SHA1 (patch-at) = 153dd5eec50f4268f5f1b54b2956b9a7b45a3446
SHA1 (patch-au) = b379e6e9426fc5b273153af83a511db79a70883d
SHA1 (patch-av) = f7513459ed3083ffdea162597709f1a924eb1e29
SHA1 (patch-aw) = 7f33b270c299f8090f87c7fb7de91c7a201da82a
SHA1 (patch-ax) = 22e7133dcdca779bbb8c3531570b587d43424a0c
SHA1 (patch-ay) = b28e643bd51229de052181278d46d41a2bfb879e
SHA1 (sqlite-2.8.13.tar.gz) = 42e426dab768a908f4e622ac65006732da4c615c
Size (sqlite-2.8.13.tar.gz) = 956008 bytes
SHA1 (patch-aa) = 21d2122f84de65cb29ae1b2d5b92984ac0868f98

View file

@ -1,8 +1,12 @@
$NetBSD: patch-aa,v 1.5 2003/12/30 14:41:09 cjep Exp $
$NetBSD: patch-aa,v 1.6 2004/03/31 05:50:17 snj Exp $
--- ../sqlite/src/attach.c.orig 2003-06-14 13:04:08.000000000 +0100
+++ ../sqlite/src/attach.c
@@ -15,2 +15,3 @@
--- ../sqlite/src/sqliteInt.h.orig 2004-03-30 21:10:23.000000000 -0800
+++ ../sqlite/src/sqliteInt.h 2004-03-30 21:12:51.000000000 -0800
@@ -14,6 +14,7 @@
** @(#) $Id: patch-aa,v 1.6 2004/03/31 05:50:17 snj Exp $
*/
#include "config.h"
+#include "os.h"
#include "sqliteInt.h"
#include "sqlite.h"
#include "hash.h"
#include "parse.h"

View file

@ -1,8 +0,0 @@
$NetBSD: patch-ab,v 1.5 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/auth.c.orig 2003-05-10 04:36:54.000000000 +0100
+++ ../sqlite/src/auth.c
@@ -18,2 +18,3 @@
*/
+#include "os.h"
#include "sqliteInt.h"

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ac,v 1.4 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/btree.c.orig 2003-06-17 03:57:18.000000000 +0100
+++ ../sqlite/src/btree.c
@@ -49,6 +49,7 @@
** BTree begins on page 2 of the file. (Pages are numbered beginning with
** 1, not 0.) Thus a minimum database contains 2 pages.
*/
+#include "os.h"
#include "sqliteInt.h"
#include "pager.h"
#include "btree.h"

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ad,v 1.4 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/btree_rb.c.orig 2003-06-29 19:29:48.000000000 +0100
+++ ../sqlite/src/btree_rb.c
@@ -16,6 +16,7 @@
**
** It was contributed to SQLite by anonymous on 2003-Feb-04 23:24:49 UTC.
*/
+#include "os.h"
#include "btree.h"
#include "sqliteInt.h"
#include <assert.h>

View file

@ -1,8 +0,0 @@
$NetBSD: patch-ae,v 1.4 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/build.c.orig 2003-07-01 19:13:15.000000000 +0100
+++ ../sqlite/src/build.c
@@ -27,2 +27,3 @@
*/
+#include "os.h"
#include "sqliteInt.h"

View file

@ -1,8 +0,0 @@
$NetBSD: patch-af,v 1.4 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/copy.c.orig 2003-06-02 23:50:26.000000000 +0100
+++ ../sqlite/src/copy.c
@@ -15,2 +15,3 @@
*/
+#include "os.h"
#include "sqliteInt.h"

View file

@ -1,8 +0,0 @@
$NetBSD: patch-ag,v 1.4 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/delete.c.orig 2003-05-17 18:35:11.000000000 +0100
+++ ../sqlite/src/delete.c
@@ -16,2 +16,3 @@
*/
+#include "os.h"
#include "sqliteInt.h"

View file

@ -1,8 +0,0 @@
$NetBSD: patch-ah,v 1.2 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/expr.c.orig 2003-07-20 02:16:47.000000000 +0100
+++ ../sqlite/src/expr.c
@@ -16,2 +16,3 @@
*/
+#include "os.h"
#include "sqliteInt.h"

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ai,v 1.2 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/func.c.orig 2003-06-28 17:20:23.000000000 +0100
+++ ../sqlite/src/func.c
@@ -22,6 +22,7 @@
#include <math.h>
#include <stdlib.h>
#include <assert.h>
+#include "os.h"
#include "sqliteInt.h"
/*

View file

@ -1,8 +0,0 @@
$NetBSD: patch-aj,v 1.2 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/hash.c.orig 2003-05-13 00:06:53.000000000 +0100
+++ ../sqlite/src/hash.c
@@ -16,2 +16,3 @@
*/
+#include "os.h"
#include "sqliteInt.h"

View file

@ -1,8 +0,0 @@
$NetBSD: patch-ak,v 1.2 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/insert.c.orig 2003-06-04 17:24:39.000000000 +0100
+++ ../sqlite/src/insert.c
@@ -16,2 +16,3 @@
*/
+#include "os.h"
#include "sqliteInt.h"

View file

@ -1,10 +0,0 @@
$NetBSD: patch-al,v 1.2 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/main.c.orig 2003-07-22 14:05:10.000000000 +0100
+++ ../sqlite/src/main.c
@@ -18,4 +18,4 @@
*/
-#include "sqliteInt.h"
#include "os.h"
+#include "sqliteInt.h"
#include <ctype.h>

View file

@ -1,12 +0,0 @@
$NetBSD: patch-am,v 1.2 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/parse.y.orig 2003-07-16 03:19:38.000000000 +0100
+++ ../sqlite/src/parse.y
@@ -33,6 +33,7 @@
}
%name sqliteParser
%include {
+#include "os.h"
#include "sqliteInt.h"
#include "parse.h"

View file

@ -1,8 +0,0 @@
$NetBSD: patch-an,v 1.2 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/pragma.c.orig 2003-06-16 00:42:24.000000000 +0100
+++ ../sqlite/src/pragma.c
@@ -15,2 +15,3 @@
*/
+#include "os.h"
#include "sqliteInt.h"

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ao,v 1.2 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/printf.c.orig 2003-06-16 04:08:19.000000000 +0100
+++ ../sqlite/src/printf.c
@@ -46,6 +46,7 @@
** + All functions are fully reentrant.
**
*/
+#include "os.h"
#include "sqliteInt.h"
/*

View file

@ -1,10 +0,0 @@
$NetBSD: patch-ap,v 1.2 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/random.c.orig 2002-02-19 13:39:23.000000000 +0000
+++ ../sqlite/src/random.c
@@ -19,4 +19,4 @@
*/
-#include "sqliteInt.h"
#include "os.h"
+#include "sqliteInt.h"

View file

@ -1,8 +0,0 @@
$NetBSD: patch-aq,v 1.2 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/select.c.orig 2003-07-20 02:16:47.000000000 +0100
+++ ../sqlite/src/select.c
@@ -16,2 +16,3 @@
*/
+#include "os.h"
#include "sqliteInt.h"

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ar,v 1.2 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/table.c.orig 2003-05-17 01:05:50.000000000 +0100
+++ ../sqlite/src/table.c
@@ -18,6 +18,7 @@
*/
#include <stdlib.h>
#include <string.h>
+#include "os.h"
#include "sqliteInt.h"
/*

View file

@ -1,10 +0,0 @@
$NetBSD: patch-as,v 1.2 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/tokenize.c.orig 2003-05-04 19:30:59.000000000 +0100
+++ ../sqlite/src/tokenize.c
@@ -19,4 +19,4 @@
*/
-#include "sqliteInt.h"
#include "os.h"
+#include "sqliteInt.h"
#include <ctype.h>

View file

@ -1,12 +0,0 @@
$NetBSD: patch-at,v 1.2 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/trigger.c.orig 2003-06-03 02:47:11.000000000 +0100
+++ ../sqlite/src/trigger.c
@@ -10,6 +10,7 @@
*************************************************************************
*
*/
+#include "os.h"
#include "sqliteInt.h"
/*

View file

@ -1,8 +0,0 @@
$NetBSD: patch-au,v 1.1 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/update.c.orig 2003-06-01 02:10:33.000000000 +0100
+++ ../sqlite/src/update.c
@@ -16,2 +16,3 @@
*/
+#include "os.h"
#include "sqliteInt.h"

View file

@ -1,8 +0,0 @@
$NetBSD: patch-av,v 1.1 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/util.c.orig 2003-06-05 15:27:56.000000000 +0100
+++ ../sqlite/src/util.c
@@ -18,2 +18,3 @@
*/
+#include "os.h"
#include "sqliteInt.h"

View file

@ -1,10 +0,0 @@
$NetBSD: patch-aw,v 1.1 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/vacuum.c.orig 2003-05-13 01:21:59.000000000 +0100
+++ ../sqlite/src/vacuum.c
@@ -18,4 +18,4 @@
*/
-#include "sqliteInt.h"
#include "os.h"
+#include "sqliteInt.h"

View file

@ -1,10 +0,0 @@
$NetBSD: patch-ax,v 1.1 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/vdbe.c.orig 2003-07-22 14:05:10.000000000 +0100
+++ ../sqlite/src/vdbe.c
@@ -40,4 +40,4 @@
*/
-#include "sqliteInt.h"
#include "os.h"
+#include "sqliteInt.h"
#include <ctype.h>

View file

@ -1,8 +0,0 @@
$NetBSD: patch-ay,v 1.1 2003/12/30 14:41:09 cjep Exp $
--- ../sqlite/src/where.c.orig 2003-07-16 01:54:31.000000000 +0100
+++ ../sqlite/src/where.c
@@ -16,2 +16,3 @@
*/
+#include "os.h"
#include "sqliteInt.h"