Copy the build fix for freetype2 from xetex.
This commit is contained in:
parent
f309b6d71c
commit
b5c36f104c
3 changed files with 32 additions and 5 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.23 2017/09/06 16:49:47 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.24 2018/05/05 23:17:33 dholland Exp $
|
||||
|
||||
DISTNAME= texlive-20170524-source
|
||||
PKGNAME= xdvik-22.87.03
|
||||
|
@ -39,6 +39,8 @@ CONFIGURE_ARGS+= --with-system-zlib \
|
|||
CONFIGURE_ARGS+= --with-xdvi-x-toolkit=xaw
|
||||
CONFIGURE_ARGS+= --with-default-dvips-path=${LOCALBASE}/bin/dvips
|
||||
CONFIGURE_ARGS+= --with-default-ps2pdf-path=${LOCALBASE}/bin/ps2pdf
|
||||
CONFIGURE_ENV+= FT2_CONFIG=pkg-config \
|
||||
PKG_CONFIG=${TOOLS_CMD.pkg-config}
|
||||
|
||||
PKG_SYSCONFSUBDIR= texmf
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.13 2017/09/06 16:49:47 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.14 2018/05/05 23:17:33 dholland Exp $
|
||||
|
||||
SHA1 (texlive-20170524-source.tar.xz) = 1c1383ddb1b871c6b8ce49a4ae3c1a33d454a7b6
|
||||
RMD160 (texlive-20170524-source.tar.xz) = a8430c19fe1727cf308fe03e5838105260c0d71e
|
||||
|
@ -6,4 +6,4 @@ SHA512 (texlive-20170524-source.tar.xz) = 18c18940992ab94ce22e22ccd4ad798253ea14
|
|||
Size (texlive-20170524-source.tar.xz) = 63483372 bytes
|
||||
SHA1 (patch-aa) = 08bc8e8a7a2cd7a65c0a176f02fdd2930d1d9ae2
|
||||
SHA1 (patch-ab) = 09dbadaa8fb4575e4a437f3a3df266ae808e3278
|
||||
SHA1 (patch-configure) = bd3b6309a60ea8173cb020335f7337abbda07103
|
||||
SHA1 (patch-configure) = 35e18dca51b22e8f469d5471c6139416fe933012
|
||||
|
|
|
@ -1,8 +1,20 @@
|
|||
$NetBSD: patch-configure,v 1.1 2015/06/22 21:28:38 markd Exp $
|
||||
$NetBSD: patch-configure,v 1.2 2018/05/05 23:17:33 dholland Exp $
|
||||
|
||||
- check more aggressively for XInput 2.1 to fix native X netbsd-6 build
|
||||
- freetype2 upstream removed freetype-config; use pkg-config instead
|
||||
|
||||
--- configure.orig 2015-03-12 14:42:02.000000000 +0000
|
||||
+++ configure
|
||||
@@ -15788,6 +15788,9 @@ LDFLAGS="$X_LIBS $LDFLAGS"
|
||||
@@ -1519,7 +1519,7 @@ Optional Packages:
|
||||
zlib headers installed in DIR
|
||||
--with-zlib-libdir=DIR zlib library installed in DIR
|
||||
--with-system-freetype2 use installed freetype2 headers and library
|
||||
- (requires freetype-config)
|
||||
+ (requires pkg-config)
|
||||
--with-default-gs-lib-path=PATH
|
||||
set default path for finding font aliases to PATH
|
||||
--with-default-dvips-path=CMD
|
||||
@@ -15845,6 +15845,9 @@ LDFLAGS="$X_LIBS $LDFLAGS"
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
/* end confdefs.h. */
|
||||
#include <X11/extensions/XInput2.h>
|
||||
|
@ -12,3 +24,16 @@ $NetBSD: patch-configure,v 1.1 2015/06/22 21:28:38 markd Exp $
|
|||
int
|
||||
main ()
|
||||
{
|
||||
@@ -18955,9 +18958,9 @@ esac
|
||||
else
|
||||
FT2_CONFIG="$ac_cv_prog_FT2_CONFIG"
|
||||
fi
|
||||
-if $FT2_CONFIG --ftversion >/dev/null 2>&1; then
|
||||
- FREETYPE2_INCLUDES=`$FT2_CONFIG --cflags`
|
||||
- FREETYPE2_LIBS=`$FT2_CONFIG --libs`
|
||||
+if $PKG_CONFIG --version >/dev/null 2>&1; then
|
||||
+ FREETYPE2_INCLUDES=`$PKG_CONFIG --cflags freetype2`
|
||||
+ FREETYPE2_LIBS=`$PKG_CONFIG --libs freetype2`
|
||||
elif test "x$need_freetype2:$with_system_freetype2" = xyes:yes; then
|
||||
as_fn_error $? "did not find freetype-config required for system freetype2 library" "$LINENO" 5
|
||||
fi
|
||||
|
|
Loading…
Reference in a new issue