Force monotonic clock on DragonFly to prevent build from failing.
This commit is contained in:
parent
b6c211f9e4
commit
b62197fd68
2 changed files with 24 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.67 2006/09/04 09:45:36 tron Exp $
|
||||
$NetBSD: distinfo,v 1.68 2006/09/08 09:32:57 joerg Exp $
|
||||
|
||||
SHA1 (glib-2.12.3.tar.bz2) = 117abb0e73fddb46650f0f38bfbbddc658dc2ddf
|
||||
RMD160 (glib-2.12.3.tar.bz2) = 65c6d717742add451af769299428f4597effb4a8
|
||||
|
@ -10,4 +10,5 @@ SHA1 (patch-ad) = c926d96bdc9ddf4f434fc57af0adbe11002cffc3
|
|||
SHA1 (patch-ae) = 09f16e8e14bdea3ee0e478d335f65cb66939e5f5
|
||||
SHA1 (patch-af) = 192998d1e2188c0210d7a471786495b758c437ae
|
||||
SHA1 (patch-ah) = 8b65c137b07659351b97089c10db0dac61f04905
|
||||
SHA1 (patch-ai) = eda9bb160d7eeee9b48bd9ca6ce3004278acf17c
|
||||
SHA1 (patch-aj) = f0c15174e83dae88cca50d040d0c09438ee9053b
|
||||
|
|
22
devel/glib2/patches/patch-ai
Normal file
22
devel/glib2/patches/patch-ai
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ai,v 1.7 2006/09/08 09:32:57 joerg Exp $
|
||||
|
||||
--- glib/gtimer.c.orig 2006-09-08 09:11:08.000000000 +0000
|
||||
+++ glib/gtimer.c
|
||||
@@ -91,12 +91,17 @@ init_posix_clock (void)
|
||||
if (!initialized)
|
||||
{
|
||||
initialized = TRUE;
|
||||
+#if defined(__DragonFly__)
|
||||
+ /* DragonFly has a monotonic clock, but not the define or sysconf support */
|
||||
+ posix_clock = CLOCK_MONOTONIC;
|
||||
+#else
|
||||
#if !defined(_POSIX_MONOTONIC_CLOCK) || _POSIX_MONOTONIC_CLOCK >= 0
|
||||
if (sysconf (_SC_MONOTONIC_CLOCK) >= 0)
|
||||
posix_clock = CLOCK_MONOTONIC;
|
||||
else
|
||||
#endif
|
||||
posix_clock = CLOCK_REALTIME;
|
||||
+#endif
|
||||
}
|
||||
}
|
||||
#endif
|
Loading…
Reference in a new issue