Fix scaling issue caused by jpeg7 update.
http://bugzilla.gnome.org/show_bug.cgi?id=588740
This commit is contained in:
parent
d74c580087
commit
b684021a30
2 changed files with 26 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.114 2009/07/18 19:19:55 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.115 2009/08/29 05:47:41 dogcow Exp $
|
||||
|
||||
SHA1 (gtk+-2.16.5.tar.bz2) = 4482e698730c8ea88239512a49306dc27a661145
|
||||
RMD160 (gtk+-2.16.5.tar.bz2) = 2e938a81a95b99275fd7738b1fc99f8f224d1e02
|
||||
|
@ -10,4 +10,5 @@ SHA1 (patch-ad) = b28feb33311f4b42bdeeae257a470edd677d5c15
|
|||
SHA1 (patch-ae) = 33e5411076362295329f82e2106e1cd7f0529863
|
||||
SHA1 (patch-aj) = 4e36ab908ae14d81bd62c3eb170be87f14bb6a35
|
||||
SHA1 (patch-gb) = 6c0728eda2d4a59add4f8962bdab4f05022eda79
|
||||
SHA1 (patch-iojpeg) = 0042e773df5ed24abea22fa4b15469db0457d88d
|
||||
SHA1 (patch-ob) = 51cbaa82d534ca4ea5253e3a938daa3a5d1e05fb
|
||||
|
|
24
x11/gtk2/patches/patch-iojpeg
Normal file
24
x11/gtk2/patches/patch-iojpeg
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-iojpeg,v 1.1 2009/08/29 05:47:41 dogcow Exp $
|
||||
|
||||
Fix a scaling issue with jpeg7; see
|
||||
http://bugzilla.gnome.org/show_bug.cgi?id=588740 and
|
||||
http://bbs.archlinux.org/viewtopic.php?pid=589488#p589488
|
||||
|
||||
--- gdk-pixbuf/io-jpeg.c.orig 2009-08-29 13:46:13.000000000 +0900
|
||||
+++ gdk-pixbuf/io-jpeg.c 2009-08-29 13:49:10.000000000 +0900
|
||||
@@ -922,13 +922,13 @@ gdk_pixbuf__jpeg_image_load_increment (g
|
||||
}
|
||||
}
|
||||
|
||||
- for (cinfo->scale_denom = 2; cinfo->scale_denom <= 8; cinfo->scale_denom *= 2) {
|
||||
+ for (cinfo->scale_denom = 2; cinfo->scale_denom <= 16; cinfo->scale_denom++) {
|
||||
jpeg_calc_output_dimensions (cinfo);
|
||||
if (cinfo->output_width < width || cinfo->output_height < height) {
|
||||
- cinfo->scale_denom /= 2;
|
||||
break;
|
||||
}
|
||||
}
|
||||
+ cinfo->scale_denom--;
|
||||
jpeg_calc_output_dimensions (cinfo);
|
||||
|
||||
context->pixbuf = gdk_pixbuf_new (GDK_COLORSPACE_RGB,
|
Loading…
Reference in a new issue