Make it use weak symbols with Clang.
This commit is contained in:
parent
e53bec5194
commit
b68956a77e
2 changed files with 18 additions and 1 deletions
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.22 2013/04/15 21:40:17 adam Exp $
|
||||
$NetBSD: distinfo,v 1.23 2013/04/20 17:39:00 asau Exp $
|
||||
|
||||
SHA1 (mpich-3.0.3.tar.gz) = cf515e9779e292d42ca5ceff34ee7b57b8978da2
|
||||
RMD160 (mpich-3.0.3.tar.gz) = 15ba7729108c39359624a937dd3857f3cdfacc0a
|
||||
Size (mpich-3.0.3.tar.gz) = 11018114 bytes
|
||||
SHA1 (patch-Makefile.in) = 32a78a384ecb94a30631a8a756e746edbe6e0060
|
||||
SHA1 (patch-configure) = 0e7fec4d30e33387d8b434c6b4e90bab1daa42ba
|
||||
SHA1 (patch-src_mpid_ch3_channels_nemesis_include_mpidi_ch3_impl.h) = e0f3de9c7c229fee3de5e85e589b88987ef11a11
|
||||
SHA1 (patch-src_pm_hydra_configure) = c8d25676499386e4a2616db5ab2d86443f29b1f7
|
||||
|
|
16
parallel/mpi-ch/patches/patch-configure
Normal file
16
parallel/mpi-ch/patches/patch-configure
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-configure,v 1.1 2013/04/20 17:39:01 asau Exp $
|
||||
|
||||
Make it use weak symbols with Clang.
|
||||
|
||||
--- configure.orig 2013-03-28 21:03:38.000000000 +0000
|
||||
+++ configure
|
||||
@@ -27768,7 +27768,9 @@ else
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
/* end confdefs.h. */
|
||||
|
||||
+#ifndef __clang__
|
||||
extern int PFoo(int);
|
||||
+#endif
|
||||
#pragma weak PFoo = Foo
|
||||
int Foo(int a) { return a; }
|
||||
|
Loading…
Reference in a new issue