libXaw on many X11 distributions is linked against libXpm. The linker

should automatically pull in libXpm when -lXaw is given, but it doesn't
seem to work correctly on Darwin.  Modify the xglyph Makefile so that
we explicitly link in -lXpm when we link against -lXaw.  This should
fix the problem noted on Darwin in the bulk builds.  Bump the PKGREVISION
to 4.
This commit is contained in:
jlam 2005-06-15 04:43:09 +00:00
parent 8a6826e1f7
commit b6a0bbbbe5
3 changed files with 18 additions and 4 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.21 2005/06/01 18:02:49 jlam Exp $
# $NetBSD: Makefile,v 1.22 2005/06/15 04:43:09 jlam Exp $
#
DISTNAME= t1lib-5.0.2
PKGREVISION= 3
PKGREVISION= 4
CATEGORIES= fonts devel graphics
MASTER_SITES= ${MASTER_SITE_SUNSITE:=libs/graphics/} \
ftp://ftp.foolabs.com/pub/xpdf/
@ -25,7 +25,7 @@ DATADIR= ${PREFIX}/share/${PKGBASE}
CONF_FILES= ${EGDIR}/t1lib.config.sample ${DATADIR}/t1lib.config
CONF_FILES+= ${EGDIR}/FontDataBase ${DATADIR}/FontDataBase
.include "../../mk/x11.buildlink3.mk"
.include "../../graphics/xpm/buildlink3.mk"
pre-build:
${FIND} ${WRKSRC} -name "*.orig" -print | ${XARGS} ${RM}

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.8 2005/02/23 19:18:29 agc Exp $
$NetBSD: distinfo,v 1.9 2005/06/15 04:43:09 jlam Exp $
SHA1 (t1lib-5.0.2.tar.gz) = 71a6ec6c84a2e28a21f261be865e0dabe52daeb5
RMD160 (t1lib-5.0.2.tar.gz) = d6ff7fa3baca4a4ce78960a145bfa69b4cd771fa
@ -8,3 +8,4 @@ SHA1 (patch-ab) = 4dbcc243c125b27ada972219da25a807f8c5a138
SHA1 (patch-ac) = aae10307ac7da8f095e7b294273503b5900e52aa
SHA1 (patch-ad) = ce242734ad7077ddd459c9d1c63fb88025d34de8
SHA1 (patch-ae) = eaeaf0b4e57c01fdf907f075ae1c2872f237bbef
SHA1 (patch-af) = e89df0d94e0748e468c7c3d40ce2fc0ccdb0116c

View file

@ -0,0 +1,13 @@
$NetBSD: patch-af,v 1.1 2005/06/15 04:43:09 jlam Exp $
--- xglyph/Makefile.in.orig 2001-01-15 17:06:53.000000000 -0500
+++ xglyph/Makefile.in
@@ -65,7 +65,7 @@ SRCS = \
T1LIB = ../lib/libt1.la
T1LIBX = ../lib/libt1x.la
-XAWLIB = -lXaw -lXt -lXmu
+XAWLIB = -lXaw -lXt -lXmu $(XPM_LIB)
all: xglyph