Update to 2.2.0. Tested by kim@, fixes PR 28835.

****New features for 2.2 (in no particular order):****

- Theora Video support -
Icecast now supports video streaming via theora.  Currently, we require the latest
(alpha 4) version of libtheora.  This is an optional compile, so if you don't
have theora then icecast will safely ignore it

- Shoutcast style source client support -
Icecast now supports the connection protocol used by the Shoutcast DSP source
client.  This is the same connection protocol used by their NSV encoding tools.
This means that not only can you use the Shoutcast DSP to stream to icecast, but
that you can also stream NSV via their tools.

- AAC is added as a supported streaming format -
Not too many source clients support streaming in this format, but we support it.

- Cluster password -
Now you can specify a cluster password as a <mount> option in the config. This
will allow you to cluster multiple servers/mounts into a single listing on the
stream directory.  Note that this is different than "grouping" which groups together
streams coming from the same physical IP and with the same stream name.  Clusters
are meant for relays of the same stream and will only be listed *once* in the stream
directory.  When a listener tunes into a cluster, they will be served an m3u file
with all the clusters for that stream.

- Playlist Log -
This is an option setting that will create an audit trail of metadata that comes through
icecast.  It is a single file that contains information for all mountpoints.

- Range Support for static files -
We now support seeking in files served off the icecast fserve.

- Metadata Update via Admin -
We now support metadata updates via the admin interface for both MP3 AND Ogg Vorbis
streams.

- Per mount hidden stats and YP prevention -
You many now indicate certains mounts to be excluded (i.e. hidden) from the main
status.xsl page.  This is useful when using local private relays.  You can also
override the YP setting (as in disable) on a per-mount basis.  Also useful for
local private relays.

- Multiple example config files -
We now have multiple config files for you to use as a base.  A "simple" one for
quick-start, and a more detailed "advanced" one with all the features, as well
as a "shoutcast compatable" one, which shows how you'd config for using the
shoutcast DSP.

- Relay user/pass -
You can now specify authentication used by a relay.  This is for the case where
you have listener authentication enabled for a mountpoint, and want to connect
a relay to it.
This commit is contained in:
wiz 2005-01-02 17:46:39 +00:00
parent 63d95ff6af
commit b6b3607524
5 changed files with 23 additions and 24 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.30 2004/12/28 02:47:41 reed Exp $
# $NetBSD: Makefile,v 1.31 2005/01/02 17:46:39 wiz Exp $
#
DISTNAME= icecast-2.1.0
PKGREVISION= 1
DISTNAME= icecast-2.2.0
CATEGORIES= audio
MASTER_SITES= http://svn.xiph.org/releases/icecast/

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.9 2004/11/27 20:45:04 wiz Exp $
@comment $NetBSD: PLIST,v 1.10 2005/01/02 17:46:39 wiz Exp $
bin/icecast
share/doc/icecast/AUTHORS
share/doc/icecast/COPYING
@ -25,6 +25,7 @@ share/icecast/admin/manageauth.xsl
share/icecast/admin/moveclients.xsl
share/icecast/admin/response.xsl
share/icecast/admin/stats.xsl
share/icecast/admin/updatemetadata.xsl
share/icecast/web/auth.xsl
share/icecast/web/corner_bottomleft.jpg
share/icecast/web/corner_bottomright.jpg

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.12 2004/11/27 20:45:04 wiz Exp $
$NetBSD: distinfo,v 1.13 2005/01/02 17:46:39 wiz Exp $
SHA1 (icecast-2.1.0.tar.gz) = 48913d2f50e1eb2fbf058080d11413d709c95fa0
Size (icecast-2.1.0.tar.gz) = 684382 bytes
SHA1 (patch-aa) = fa92a4a704a3f471a0669c9933b36a3586425dc5
SHA1 (patch-ab) = 39cf0ed1e9da8c7d90fa192731307817e91496c9
SHA1 (icecast-2.2.0.tar.gz) = 5cfd558b159517a55bdf99da8e5e5ebeca232a5e
Size (icecast-2.2.0.tar.gz) = 702418 bytes
SHA1 (patch-aa) = 8da022897737e6fd5ef335b75ecde119bc01a114
SHA1 (patch-ab) = 521ccf6ed4fb6492197a86c9c3a83aa56b40ef12

View file

@ -1,13 +1,13 @@
$NetBSD: patch-aa,v 1.2 2004/01/08 20:49:39 xtraeme Exp $
$NetBSD: patch-aa,v 1.3 2005/01/02 17:46:39 wiz Exp $
--- Makefile.in.orig 2004-01-08 18:59:21.000000000 +0100
+++ Makefile.in 2004-01-08 18:59:45.000000000 +0100
@@ -112,7 +112,7 @@
--- Makefile.in.orig 2004-12-21 20:31:02.000000000 +0100
+++ Makefile.in
@@ -124,7 +124,7 @@ install_sh = @install_sh@
AUTOMAKE_OPTIONS = 1.6 foreign dist-zip
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = src conf debian doc web admin win32
+SUBDIRS = src doc web admin
EXTRA_DIST = HACKING m4/acx_pthread.m4 m4/ogg.m4 m4/vorbis.m4 \
m4/xiph_compiler.m4 m4/xiph_curl.m4 m4/xiph_net.m4 \
EXTRA_DIST = HACKING m4/acx_pthread.m4 m4/ogg.m4 \
m4/theora.m4 m4/vorbis.m4 \

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ab,v 1.5 2004/01/08 20:49:39 xtraeme Exp $
$NetBSD: patch-ab,v 1.6 2005/01/02 17:46:39 wiz Exp $
--- conf/icecast.fixme.orig 2004-01-08 19:10:14.000000000 +0100
+++ conf/icecast.fixme 2004-01-08 19:14:15.000000000 +0100
@@ -82,14 +82,15 @@
--- conf/icecast.fixme.orig 2004-12-02 22:15:35.000000000 +0100
+++ conf/icecast.fixme
@@ -110,14 +110,15 @@
<paths>
<!-- basedir is only used if chroot is enabled -->
@ -23,24 +23,23 @@ $NetBSD: patch-ab,v 1.5 2004/01/08 20:49:39 xtraeme Exp $
<!-- Aliases: treat requests for 'source' path as being for 'dest' path
May be made specific to a port or bound address using the "port"
@@ -103,16 +104,14 @@
<logging>
@@ -137,15 +138,15 @@
<accesslog>access.log</accesslog>
<errorlog>error.log</errorlog>
<!-- <playlistlog>playlist.log</playlistlog> -->
- <loglevel>4</loglevel> <!-- 4 Debug, 3 Info, 2 Warn, 1 Error -->
+ <loglevel>2</loglevel> <!-- 4 Debug, 3 Info, 2 Warn, 1 Error -->
</logging>
<security>
- <chroot>0</chroot>
- <!--
+ <chroot>1</chroot>
<!--
<changeowner>
- <user>nobody</user>
- <group>nogroup</group>
+ <user>@ICECAST_USER@</user>
+ <group>@ICECAST_GROUP@</group>
</changeowner>
- -->
-->
</security>
</icecast>