libzip: update to 1.8.0.
Add one post-release patch. 1.8.0 [2021-06-18] ================== * Add support for zstd (Zstandard) compression. * Add support for lzma (ID 14) compression. * Add `zip_source_window_create()`. * Add `zip_source_zip_create()` variant to `zip_source_zip()`. * Allow method specific `comp_flags` in `zip_set_file_compression()`. * Allow `zip_source_tell()` on sources that don't support seeking and `zip_ftell()` on compressed data. * Provide more details for consistency check errors. * Improve output of `zipcmp`. * In `zipcmp`, don’t ignore empty directories when comparing directory listing. * Treat empty string as no password given in `zip_file_set_encryption()`, `zip_fopen_encrypted()`, and `zip_set_default_password()`.
This commit is contained in:
parent
5572b73f4c
commit
b6b8e3e9c2
5 changed files with 32 additions and 15 deletions
|
@ -1,12 +1,11 @@
|
|||
# $NetBSD: Makefile,v 1.54 2021/05/24 19:49:02 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.55 2021/06/24 21:40:06 wiz Exp $
|
||||
|
||||
DISTNAME= libzip-1.7.3
|
||||
PKGREVISION= 3
|
||||
DISTNAME= libzip-1.8.0
|
||||
CATEGORIES= archivers devel
|
||||
MASTER_SITES= https://libzip.org/download/
|
||||
MASTER_SITES+= ${MASTER_SITE_GITHUB:=nih-at/}
|
||||
EXTRACT_SUFX= .tar.xz
|
||||
GITHUB_RELEASE= v${PKGVERSION_NOREV}
|
||||
EXTRACT_SUFX= .tar.xz
|
||||
|
||||
MAINTAINER= wiz@NetBSD.org
|
||||
HOMEPAGE= https://www.libzip.org/
|
||||
|
@ -25,4 +24,5 @@ MAKE_ENV+= LD_LIBRARY_PATH=${WRKSRC}/lib
|
|||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../archivers/bzip2/buildlink3.mk"
|
||||
.include "../../archivers/xz/buildlink3.mk"
|
||||
.include "../../archivers/zstd/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.16 2020/07/11 10:26:04 wiz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.17 2021/06/24 21:40:06 wiz Exp $
|
||||
bin/zipcmp
|
||||
bin/zipmerge
|
||||
bin/ziptool
|
||||
|
@ -10,7 +10,7 @@ lib/cmake/libzip/libzip-targets-noconfig.cmake
|
|||
lib/cmake/libzip/libzip-targets.cmake
|
||||
lib/libzip.so
|
||||
lib/libzip.so.5
|
||||
lib/libzip.so.5.3
|
||||
lib/libzip.so.5.4
|
||||
lib/pkgconfig/libzip.pc
|
||||
man/man1/zipcmp.1
|
||||
man/man1/zipmerge.1
|
||||
|
@ -81,6 +81,7 @@ man/man3/zip_libzip_version.3
|
|||
man/man3/zip_name_locate.3
|
||||
man/man3/zip_open.3
|
||||
man/man3/zip_open_from_source.3
|
||||
man/man3/zip_register_cancel_callback_with_state.3
|
||||
man/man3/zip_register_progress_callback.3
|
||||
man/man3/zip_register_progress_callback_with_state.3
|
||||
man/man3/zip_rename.3
|
||||
|
@ -125,6 +126,7 @@ man/man3/zip_source_win32handle.3
|
|||
man/man3/zip_source_win32handle_create.3
|
||||
man/man3/zip_source_win32w.3
|
||||
man/man3/zip_source_win32w_create.3
|
||||
man/man3/zip_source_window.3
|
||||
man/man3/zip_source_write.3
|
||||
man/man3/zip_source_zip.3
|
||||
man/man3/zip_stat.3
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.25 2021/04/21 13:24:06 adam Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.26 2021/06/24 21:40:06 wiz Exp $
|
||||
|
||||
BUILDLINK_TREE+= libzip
|
||||
|
||||
|
@ -9,9 +9,9 @@ BUILDLINK_API_DEPENDS.libzip+= libzip>=1.3.1
|
|||
BUILDLINK_ABI_DEPENDS.libzip+= libzip>=1.7.3nb2
|
||||
BUILDLINK_PKGSRCDIR.libzip?= ../../archivers/libzip
|
||||
|
||||
BUILDLINK_FILES.libzip+= bin/zipcmp
|
||||
BUILDLINK_FILES.libzip+= bin/zipmerge
|
||||
BUILDLINK_FILES.libzip+= bin/ziptool
|
||||
BUILDLINK_FILES.libzip+= bin/zipcmp
|
||||
BUILDLINK_FILES.libzip+= bin/zipmerge
|
||||
BUILDLINK_FILES.libzip+= bin/ziptool
|
||||
|
||||
.include "../../archivers/bzip2/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.38 2020/07/15 08:15:39 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.39 2021/06/24 21:40:06 wiz Exp $
|
||||
|
||||
SHA1 (libzip-1.7.3.tar.xz) = 2a2e2fb4f18a65a996252dfa247b38a6519af712
|
||||
RMD160 (libzip-1.7.3.tar.xz) = 51efb3e8b7b219e05b9146604cd6398a6ab391ff
|
||||
SHA512 (libzip-1.7.3.tar.xz) = 488866348a0c859f6f995c50e956bd51b4105278f07b63fe019cb44ab36c09ef958cc0684fd5444c474d83874b999e8ed1aa9b2da51b74caa37bbe7934b9c870
|
||||
Size (libzip-1.7.3.tar.xz) = 747372 bytes
|
||||
SHA1 (libzip-1.8.0.tar.xz) = cfe0c5cdaa6c3bc4986464797de8fd4359d2d4d5
|
||||
RMD160 (libzip-1.8.0.tar.xz) = 2041a081ad92828d98ce1ec39199e80a57d52dd7
|
||||
SHA512 (libzip-1.8.0.tar.xz) = fe94a26a2797dff7c9b27334f29982f8e523dd5095bf32ebcadc6443726864f0ff7b2e8bf243e52cad8f79297bc7a87d73fdbc35edae4ffc8ab6aa0bcc93b03e
|
||||
Size (libzip-1.8.0.tar.xz) = 760604 bytes
|
||||
SHA1 (patch-CMakeLists.txt) = 17745d56f98cd4a6298c54b8562b463207c5a7ee
|
||||
|
|
14
archivers/libzip/patches/patch-CMakeLists.txt
Normal file
14
archivers/libzip/patches/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-CMakeLists.txt,v 1.1 2021/06/24 21:40:06 wiz Exp $
|
||||
|
||||
Upstream commit ca61524e05d785f0d14f40802c6a1a54a46b74bb
|
||||
|
||||
--- CMakeLists.txt.orig 2021-06-18 16:08:29.000000000 +0000
|
||||
+++ CMakeLists.txt
|
||||
@@ -299,6 +299,7 @@ foreach(LIB ${LIBS_PRIVATE})
|
||||
endforeach()
|
||||
string(REGEX REPLACE "-lBZip2::BZip2" "-lbz2" LIBS ${LIBS})
|
||||
string(REGEX REPLACE "-lLibLZMA::LibLZMA" "-llzma" LIBS ${LIBS})
|
||||
+string(REGEX REPLACE "-lZstd::Zstd" "-lzstd" LIBS ${LIBS})
|
||||
string(REGEX REPLACE "-lOpenSSL::Crypto" "-lssl -lcrypto" LIBS ${LIBS})
|
||||
string(REGEX REPLACE "-lZLIB::ZLIB" "-lz" LIBS ${LIBS})
|
||||
string(REGEX REPLACE "-lGnuTLS::GnuTLS" "-lgnutls" LIBS ${LIBS})
|
Loading…
Reference in a new issue