Update to 3.20. Changes since last version (3.15.1):

Changes to procmail:
   - SECURITY: don't do unsafe things from signal handlers:
      - ignore TRAP when terminating because of a signal
      - resolve the host and protocol of COMSAT when it is set
      - save the absolute path form of $LASTFOLDER for the comsat
        message when it is set
      - only use the log buffer if it's safe
   - Support LMTP for delivery mode (not enabled by default)
   - Preliminary support for using mmap() for `large' messages
     (this doesn't work yet)
   - SWITCHRC=zero-length-file didn't always abort the current
     rcfile
   - A race to create the mailspool would bounce one of the
     messages due to an internal error
   - LC_ in KEEPENV would preserve only the first LC_foo variable
   - Strip runtime linker variables (LD_*) from environment on
     all platforms
   - Drop duplicate and malformed environment entries
   - Multiple -a options will now set $2, $3, etc
   - Command line assignments to INCLUDERC and SWITCHRC no longer
     have any effect
   - Worked around AIX 4.3.3 xlc compiler (incorrect file-scope
     variable initialization)
   - When delivering to a maildir, don't force the message to end
     with an empty line
   - Be more paranoid about leaking information between recipients
   - Unset LOCKFILE if we can't actually lock it
   - Set MAILDIR to '.' if the chdir fails
   - LASTFOLDER was sometimes set by '?' conditions
   - Buffer the log more efficiently
   - Use the `standard' format for maildir filenames and retry
     on name collision
   - Rename by linking to prevent lossage
Changes to lockfile:
   - Include the system mailbox lockfile path in the -v output
   - Resist attempts to use a setuid lockfile command
   - Fix infinite loop on -l, -r, or -s flag with no value.
Documented formail's treatment of >From_ lines as continuations
   of the From_ line and warned of problems caused by non-RFC822
   field names like 'Old-From '
Clarified procmail's treatment of $@ and $#
Fixed a man page formatting problem
Use long, not off_t, with fseek()/ftell()
Increase our paranoia: start to use strlcat()
The default MAILDIR is now configurable separately from the
   default rcfile location
Include an RPM spec file in the examples directory for automated
   builds
Include and use mkinstalldirs
Called nice() when shouldn't have (this time for sure!)
This commit is contained in:
wiz 2001-06-29 17:19:07 +00:00
parent 5187edfa6a
commit b748ce7f08
3 changed files with 10 additions and 10 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.23 2001/06/20 14:08:41 wiz Exp $
# $NetBSD: Makefile,v 1.24 2001/06/29 17:19:07 wiz Exp $
#
DISTNAME= procmail-3.15.1
DISTNAME= procmail-3.20
CATEGORIES= mail
MASTER_SITES= ftp://ftp.procmail.org/pub/procmail/

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.3 2001/06/20 14:08:41 wiz Exp $
$NetBSD: distinfo,v 1.4 2001/06/29 17:19:07 wiz Exp $
SHA1 (procmail-3.15.1.tar.gz) = 72bf2596b35b34c47eed2bd71e9ae6f9bacb8570
Size (procmail-3.15.1.tar.gz) = 201913 bytes
SHA1 (procmail-3.20.tar.gz) = 4776bf0b1bb816f3fe07d956dbef0432c6c13095
Size (procmail-3.20.tar.gz) = 225060 bytes
SHA1 (patch-aa) = 29d0b8bc73313fe655c97f7d5adafab5b9104309
SHA1 (patch-ab) = 6655435092feacfc1b0a8ab6908ea7856532ce09
SHA1 (patch-ac) = fe2350e704546c2262d546bb615175dd0591ba8b
SHA1 (patch-ad) = 569d357c6afb9d7644c8094878aec08d22ae609d
SHA1 (patch-ae) = c5921ea2723d64615b6e76c4ea7a0b4afec7d452
SHA1 (patch-ae) = 8c08d3e5f0eb01ce087aea2f94dbbc7bebf8d787

View file

@ -1,17 +1,17 @@
$NetBSD: patch-ae,v 1.4 2000/08/26 14:26:59 wiz Exp $
$NetBSD: patch-ae,v 1.5 2001/06/29 17:19:08 wiz Exp $
If these lines stay, `make install; make deinstall; make install' fails.
--- Makefile.1.orig Sat Dec 21 04:28:05 1996
--- Makefile.1.orig Fri Jun 29 04:20:17 2001
+++ Makefile.1
@@ -102,14 +102,12 @@
@@ -101,14 +101,12 @@
then $(MANCOMPRESS) -c new/$$a.5 >$(MAN5DIR)/$$a.$(MAN5SUFFIX); \
else :; fi; \
done
- echo Housekeeping file >install.man
install.bin: $(BINS) $(BASENAME)
@-mkdir $(BINDIR) 2>$(DEVNULL); exit 0
@-$(MKDIRS) $(BINDIR) 2>$(DEVNULL); exit 0
@chmod 0755 $(BINS)
$(INSTALL) $(BINS) $(BINDIR)
@-dirname / >$(DEVNULL) || $(INSTALL) examples/dirname $(BINDIR)