* Add libvcdinfo vcdinfo_get_area_selection() a routine to get the
  selection number represented by an area for a specified a point
  location
* Add libvcdinfo vcdinfo_get_set_resolution() a routine to get the
  resolution for a given segment
* hack on memory leaks some more
* vcdxrip options more like vcd-info options
* check that selection area hot-spot values don't exceed 255.
* Update documentation
* Remove gcc 4 warnings and potential problems noted
* make --disable-static --enable-shared work with --versioned-libs

patch-aa fixes infinite loop in vcdinf_update_offset_list().  The fix is
already submitted to upstream:
http://savannah.gnu.org/support/index.php?func=detailitem&item_id=105012
This commit is contained in:
ben 2006-01-11 02:23:19 +00:00
parent 74bc5c5b01
commit b758a44711
3 changed files with 24 additions and 7 deletions

View file

@ -1,10 +1,10 @@
# $NetBSD: Makefile,v 1.30 2005/10/29 06:17:20 grant Exp $
# $NetBSD: Makefile,v 1.31 2006/01/11 02:23:19 ben Exp $
#
DISTNAME= vcdimager-0.7.22
PKGREVISION= 1
DISTNAME= vcdimager-0.7.23
CATEGORIES= sysutils
MASTER_SITES= http://www.vcdimager.org/pub/vcdimager/vcdimager-0.7/
PKGREVISION= 1
MAINTAINER= ben@NetBSD.org
HOMEPAGE= http://www.vcdimager.org/

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.9 2005/05/18 18:48:37 drochner Exp $
$NetBSD: distinfo,v 1.10 2006/01/11 02:23:19 ben Exp $
SHA1 (vcdimager-0.7.22.tar.gz) = f160f57afbb4f14f0c27b8f64801250e5c124aaf
RMD160 (vcdimager-0.7.22.tar.gz) = 9339726076db3596f361cc1524a20ac988f53f88
Size (vcdimager-0.7.22.tar.gz) = 984278 bytes
SHA1 (vcdimager-0.7.23.tar.gz) = 6d1a3125fa8b7fa88a993e0c028cadcc03ac6304
RMD160 (vcdimager-0.7.23.tar.gz) = c43ed14f0b81ada40c94b5954e9e689831cef2c2
Size (vcdimager-0.7.23.tar.gz) = 1009549 bytes
SHA1 (patch-aa) = 7d58fc0497711891e44c37b7d4fe59db5e500210
SHA1 (patch-ac) = 7424deb20d9a74f5452491ef5c2b88dd8c0a6338

View file

@ -0,0 +1,16 @@
$NetBSD: patch-aa,v 1.5 2006/01/11 02:23:19 ben Exp $
--- lib/info_private.c.orig 2005-02-02 00:37:37.000000000 +0000
+++ lib/info_private.c
@@ -102,10 +102,9 @@ vcdinf_update_offset_list(struct _vcdinf
}
} else {
/* See if we've skipped any LID numbers. */
- last_lid++;
while (last_lid != ofs->lid ) {
lid_t * lid=calloc(1, sizeof(lid_t));
- *lid = last_lid;
+ *lid = last_lid++;
_cdio_list_append(unused_lids, lid);
}
if (last_lid > max_seen_lid) max_seen_lid=last_lid;