Educate this package to co-exist with the "screen" package under SunOS
and fix some package lists problems there.
This commit is contained in:
parent
4e6408c34d
commit
b766930a9d
4 changed files with 2277 additions and 2253 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.39 2002/08/25 18:38:38 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.40 2002/09/01 18:36:35 tron Exp $
|
||||
|
||||
DISTNAME= ncurses-${NC_VERS}
|
||||
NC_VERS= 5.2
|
||||
|
@ -11,10 +11,10 @@ MAINTAINER= jlam@netbsd.org
|
|||
HOMEPAGE= http://dickey.his.com/ncurses/ncurses.html
|
||||
COMMENT= CRT screen handling and optimization package
|
||||
|
||||
USE_LIBTOOL= # defined
|
||||
USE_BUILDLINK2= # defined
|
||||
USE_LIBTOOL= YES
|
||||
USE_BUILDLINK2= YES
|
||||
|
||||
GNU_CONFIGURE= # defined
|
||||
GNU_CONFIGURE= YES
|
||||
CONFIGURE_ARGS+= --with-libtool
|
||||
CONFIGURE_ARGS+= --enable-bsdpad
|
||||
CONFIGURE_ARGS+= --with-cxx-binding
|
||||
|
@ -24,6 +24,16 @@ CONFIGURE_ARGS+= --without-gpm
|
|||
CONFIGURE_ARGS+= --with-manpage-format=normal
|
||||
CONFIGURE_ARGS+= --with-manpage-tbl
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if (${OPSYS} == SunOS)
|
||||
PLIST_SUBST+= NOT_SUNOS="@comment " TERMINFODIR=share/lib/terminfo
|
||||
|
||||
TERMINFO_SRC= ${WRKSRC}/misc/terminfo.src
|
||||
.else
|
||||
PLIST_SUBST+= NOT_SUNOS= TERMINFODIR=share/terminfo
|
||||
.endif
|
||||
|
||||
# Remove these manpages from the distribution so they won't get installed
|
||||
CURSES_NO_MAN= clear.1 tput.1 tset.1
|
||||
|
||||
|
@ -36,6 +46,11 @@ post-configure:
|
|||
for file in *.3x; do \
|
||||
${MV} -f $${file} `basename $${file} .3x`.3; \
|
||||
done
|
||||
.if (${OPSYS} == SunOS)
|
||||
${MV} ${TERMINFO_SRC} ${TERMINFO_SRC}.old
|
||||
${SED} -e "/^screen|/,/^$$/d" -e "/^screen-w|/,/^$$/d" \
|
||||
<${TERMINFO_SRC}.old >${TERMINFO_SRC}
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/c++/demo.cc \
|
||||
|
|
4480
devel/ncurses/PLIST
4480
devel/ncurses/PLIST
File diff suppressed because it is too large
Load diff
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.5 2002/08/25 18:38:39 jlam Exp $
|
||||
$NetBSD: distinfo,v 1.6 2002/09/01 18:36:35 tron Exp $
|
||||
|
||||
SHA1 (ncurses-5.2.tar.gz) = 47e13874118568c48bdb6034d716dcf424f3bf12
|
||||
Size (ncurses-5.2.tar.gz) = 1743818 bytes
|
||||
SHA1 (patch-aa) = 235774ae5a52a31b833ff3a8a48d4b3e8ead9d3b
|
||||
SHA1 (patch-aa) = 141a7c8cb500f3a12d2d0648ae36ccdb43e0280e
|
||||
SHA1 (patch-ab) = c523e86cf4faf08930c95f0aee59be85c962a147
|
||||
|
|
|
@ -1,14 +1,23 @@
|
|||
$NetBSD: patch-aa,v 1.11 2000/10/15 04:50:11 jlam Exp $
|
||||
$NetBSD: patch-aa,v 1.12 2002/09/01 18:36:36 tron Exp $
|
||||
|
||||
--- misc/run_tic.in.orig Mon Oct 9 18:57:35 2000
|
||||
+++ misc/run_tic.in
|
||||
@@ -113,6 +113,9 @@
|
||||
--- misc/run_tic.in.orig Tue Oct 10 00:57:35 2000
|
||||
+++ misc/run_tic.in Sun Sep 1 20:19:08 2002
|
||||
@@ -81,7 +81,7 @@
|
||||
# would generate a lot of confusing error messages if we tried to overwrite it.
|
||||
# We explicitly remove its contents rather than the directory itself, in case
|
||||
# the directory is actually a symbolic link.
|
||||
-( cd $TERMINFO && rm -fr ? 2>/dev/null )
|
||||
+#( cd $TERMINFO && rm -fr ? 2>/dev/null )
|
||||
|
||||
# If we're not installing into /usr/share/, we'll have to adjust the location
|
||||
# of the tabset files in terminfo.src (which are in a parallel directory).
|
||||
@@ -112,6 +112,9 @@
|
||||
echo '? tic could not build '$TERMINFO
|
||||
exit 1
|
||||
fi
|
||||
|
||||
+
|
||||
+# For NetBSD pkgsrc, don't bother with setting a symbolic link.
|
||||
+exit 0
|
||||
+
|
||||
|
||||
# Make a symbolic link to provide compatibility with applications that expect
|
||||
# to find terminfo under /usr/lib. That is, we'll _try_ to do that. Not
|
||||
# all systems support symbolic links, and those that do provide a variety
|
||||
|
|
Loading…
Reference in a new issue